summaryrefslogtreecommitdiff
path: root/dev-java/commons-collections
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/commons-collections
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/commons-collections')
-rw-r--r--dev-java/commons-collections/Manifest7
-rw-r--r--dev-java/commons-collections/commons-collections-3.2.1-r1.ebuild72
-rw-r--r--dev-java/commons-collections/commons-collections-3.2.1-r2.ebuild63
-rw-r--r--dev-java/commons-collections/commons-collections-4.1.ebuild51
-rw-r--r--dev-java/commons-collections/files/commons-collections-3.2.1-Java-8.patch160
-rw-r--r--dev-java/commons-collections/metadata.xml11
6 files changed, 364 insertions, 0 deletions
diff --git a/dev-java/commons-collections/Manifest b/dev-java/commons-collections/Manifest
new file mode 100644
index 000000000000..bbbff6d57b9b
--- /dev/null
+++ b/dev-java/commons-collections/Manifest
@@ -0,0 +1,7 @@
+AUX commons-collections-3.2.1-Java-8.patch 7059 BLAKE2B c2dd3d388b15cd61224e96eb8b380f881ad4629ce58082c1b80cb843372741f10eaa4f3a71689a3f7817d7a702a82ef61dc7634187992fb03b2a8730262035ff SHA512 1007c9c46944c4b0104b0b13c4c2acdfc9791274019b20bd38b95769095843e4be1ee29d81ff61517d9a7d9b2ad5bd77c92a2f25ebe3bab68f9a04d3a986a44d
+DIST commons-collections-3.2.1-src.tar.gz 609930 BLAKE2B 547b785b82e16f1c318fafb5761292c5fe8beb57dd4a4881cc16ef7df7328df279713442cd1fc4a64fad0d84457c06d5536c084fd8084f62495ce44bfde19a34 SHA512 8b9b5344528b3b8a53142abd944ff6b89cc149a3fa0c1eadf3f2172509499af5820ba86859e47fe7f15f994f680fa3c577c21891540b64f41f826babe81a0fc0
+DIST commons-collections4-4.1-src.tar.gz 704671 BLAKE2B dea1b630168373013ca937c9b02414b92845fdd9ddf7a22a05c4d7f8d30ff26d73f3a2d399d7a4c026f8ec43a282120fdf3d3cb1042a311c3b490ffed1774e30 SHA512 c5666f41b68c9fdba3731730595616b16f98579c077cf047f421a46729b5a65476a8707125a2c0b0c6c024ca94df8c2633123bd99e705149fcb1afadcd3bf68b
+EBUILD commons-collections-3.2.1-r1.ebuild 1728 BLAKE2B 56dd7214eff19ebe391363a1c1066ab234290a458ee8943e5e13838cf41f6eca68abd6e9a31e62bc8e2c4285c628afdda809c2b6544080ba13b2ee54498d12dd SHA512 dea746396617ff3b693f444056ab157510980f191567d09910005352d51c0b3807d7a2c91897125da8a9a5608a35991898f41ad77d7948082ab100d7f64f15e3
+EBUILD commons-collections-3.2.1-r2.ebuild 1294 BLAKE2B a61b2884d319cc5c648ce5133d57a87f6d95128094d344adf4f206e5eacb3e925e370adeb958adaf8f41bac4a7d9b73a2010c3477dfb175cc487db9b6e822db4 SHA512 bccd79f3babd4416a1cdd0d27f3c6540258c61a395a261af024f84622f01f8bfcd3d0a3bcccff8f392a3a921637e40709dee12e1812f87f3533ab35b45be3cb8
+EBUILD commons-collections-4.1.ebuild 1182 BLAKE2B c127dfbfc2dcab974143e7efb1a5eee63e2472b81f2a75b8eff8d011d8b6528e023326aec74de1447bec9acdfb330e91ee19b949941dd33939333965291eb7c2 SHA512 e55765f2d3896a45f064cbaecb05b90d5a8bc9004055ca22629428b6778c62584a0ce3264cd3285edbcd5cfe7ce10559cd24f202b55d6e2a718948142a717605
+MISC metadata.xml 325 BLAKE2B af3d8863d79f6cb8290734821ff82fbff7b65ec3d017f7f530e5c74d745d94f4a15713fa06b24b7e3dcd092dedc10f6642a0a480ee13e916bbd5895c52f1fab0 SHA512 23d211dbb0efeb5909d6d43ddf7a58ab34d33d25fc80216e0e6d7722424c06df89912947105070e63a64d44b6ad37e3053e19bcddc4c808d9cfc234f4d923645
diff --git a/dev-java/commons-collections/commons-collections-3.2.1-r1.ebuild b/dev-java/commons-collections/commons-collections-3.2.1-r1.ebuild
new file mode 100644
index 000000000000..accce8f13e04
--- /dev/null
+++ b/dev-java/commons-collections/commons-collections-3.2.1-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2 java-utils-2 eutils
+
+DESCRIPTION="Jakarta-Commons Collections Component"
+HOMEPAGE="http://commons.apache.org/collections/"
+SRC_URI="mirror://apache/${PN/-//}/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test-framework"
+
+CDEPEND="
+ test-framework? (
+ dev-java/junit:0
+ dev-java/ant-junit:0
+ )
+ "
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+S="${WORKDIR}/${P}-src"
+
+java_prepare() {
+ # Check for VM version.
+ java-pkg_is-vm-version-ge 1.8
+ if [[ $? -eq 0 ]]; then
+ einfo "You are running a JVM greater or equal than version 1.8."
+ epatch "${FILESDIR}"/${P}-Java-8.patch
+ fi
+}
+
+src_compile() {
+ local antflags
+ if use test-framework; then
+ antflags="tf.jar -Djunit.jar=$(java-pkg_getjars junit)"
+ #no support for installing two sets of javadocs via dojavadoc atm
+ #use doc && antflags="${antflags} tf.javadoc"
+ fi
+ eant jar $(use_doc) ${antflags}
+}
+
+src_test() {
+ if [[ "${ARCH}" = "ppc" ]]; then
+ einfo "Tests are disabled on ppc"
+ else
+ ANT_TASKS="ant-junit" eant testjar -Djunit.jar="$(java-pkg_getjars junit)"
+ fi
+}
+
+src_install() {
+ java-pkg_newjar build/${P}.jar ${PN}.jar
+ use test-framework && \
+ java-pkg_newjar build/${PN}-testframework-${PV}.jar \
+ ${PN}-testframework.jar
+
+ dodoc README.txt || die
+ java-pkg_dohtml *.html || die
+ if use doc; then
+ java-pkg_dojavadoc build/docs/apidocs
+ #use test-framework && java-pkg_dojavadoc build/docs/testframework
+ fi
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-collections/commons-collections-3.2.1-r2.ebuild b/dev-java/commons-collections/commons-collections-3.2.1-r2.ebuild
new file mode 100644
index 000000000000..50ad9b9cf0a5
--- /dev/null
+++ b/dev-java/commons-collections/commons-collections-3.2.1-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2 java-utils-2
+
+DESCRIPTION="Jakarta-Commons Collections Component"
+HOMEPAGE="https://commons.apache.org/collections/"
+SRC_URI="mirror://apache/${PN/-//}/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-java/junit:0
+ dev-java/ant-junit:0
+ )
+ >=virtual/jdk-1.6"
+
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}/${P}-src"
+
+PATCHES=( "${FILESDIR}/${P}-Java-8.patch" )
+
+src_prepare() {
+ default
+}
+
+src_compile() {
+ local antflags
+ if use test; then
+ antflags="tf.jar -Djunit.jar=$(java-pkg_getjars junit)"
+ fi
+ eant jar $(use_doc) ${antflags}
+}
+
+src_test() {
+ if [[ "${ARCH}" = "ppc" ]]; then
+ einfo "tests are disabled on ppc"
+ else
+ ANT_TASKS="ant-junit" eant testjar -Djunit.jar="$(java-pkg_getjars junit)"
+ fi
+}
+
+src_install() {
+ java-pkg_newjar build/${P}.jar ${PN}.jar
+ use test && \
+ java-pkg_newjar build/${PN}-testframework-${PV}.jar \
+ ${PN}-testframework.jar
+
+ java-pkg_dohtml *.html
+ if use doc; then
+ java-pkg_dojavadoc build/docs/apidocs
+ fi
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-collections/commons-collections-4.1.ebuild b/dev-java/commons-collections/commons-collections-4.1.ebuild
new file mode 100644
index 000000000000..bd84b509220a
--- /dev/null
+++ b/dev-java/commons-collections/commons-collections-4.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+SLOT="4"
+MY_P="${PN}${SLOT}-${PV}"
+
+DESCRIPTION="Extends the JCF classes with new interfaces, implementations and utilities"
+HOMEPAGE="https://commons.apache.org/collections/"
+SRC_URI="mirror://apache/${PN/-//}/source/${MY_P}-src.tar.gz"
+LICENSE="Apache-2.0"
+KEYWORDS="amd64 ppc64 x86"
+IUSE="test"
+
+DEPEND="
+ >=virtual/jdk-1.7
+ test? (
+ dev-java/easymock:3.2
+ dev-java/junit:4
+ )"
+
+RDEPEND="
+ >=virtual/jre-1.7"
+
+S="${WORKDIR}/${MY_P}-src"
+
+JAVA_SRC_DIR="src/main/java"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc RELEASE-NOTES.txt
+ docinto html
+ dodoc {DEVELOPERS-GUIDE,PROPOSAL}.html
+}
+
+src_test() {
+ local DIR=src/test/java
+ local CP="${DIR}:${DIR}/../resources:${PN}.jar:$(java-pkg_getjars easymock-3.2,junit-4)"
+ local TESTS=$(find ${DIR} -name "*Test.java" ! -name "Abstract*" ! -name "BulkTest.*")
+ TESTS="${TESTS//src\/test\/java\/}"
+ TESTS="${TESTS//.java}"
+ TESTS="${TESTS//\//.}"
+
+ ejavac -cp "${CP}" -d ${DIR} $(find ${DIR} -name "*.java")
+ ejunit4 -classpath "${CP}" ${TESTS}
+}
diff --git a/dev-java/commons-collections/files/commons-collections-3.2.1-Java-8.patch b/dev-java/commons-collections/files/commons-collections-3.2.1-Java-8.patch
new file mode 100644
index 000000000000..1a5ebe241f76
--- /dev/null
+++ b/dev-java/commons-collections/files/commons-collections-3.2.1-Java-8.patch
@@ -0,0 +1,160 @@
+--- a/src/java/org/apache/commons/collections/map/MultiValueMap.java
++++ b/src/java/org/apache/commons/collections/map/MultiValueMap.java
+@@ -153,7 +153,7 @@
+ * @param value the value to remove
+ * @return the value removed (which was passed in), null if nothing removed
+ */
+- public Object remove(Object key, Object value) {
++ public Object removeMapping(Object key, Object value) {
+ Collection valuesForKey = getCollection(key);
+ if (valuesForKey == null) {
+ return null;
+--- a/src/java/org/apache/commons/collections/MultiHashMap.java
++++ b/src/java/org/apache/commons/collections/MultiHashMap.java
+@@ -331,7 +331,7 @@
+ * @param item the value to remove
+ * @return the value removed (which was passed in), null if nothing removed
+ */
+- public Object remove(Object key, Object item) {
++ public Object removeMapping(Object key, Object item) {
+ Collection valuesForKey = getCollection(key);
+ if (valuesForKey == null) {
+ return null;
+--- a/src/java/org/apache/commons/collections/MultiMap.java
++++ b/src/java/org/apache/commons/collections/MultiMap.java
+@@ -66,7 +66,7 @@
+ * @throws ClassCastException if the key or value is of an invalid type
+ * @throws NullPointerException if the key or value is null and null is invalid
+ */
+- public Object remove(Object key, Object item);
++ public Object removeMapping(Object key, Object item);
+
+ //-----------------------------------------------------------------------
+ /**
+--- a/src/test/org/apache/commons/collections/map/TestMultiValueMap.java
++++ b/src/test/org/apache/commons/collections/map/TestMultiValueMap.java
+@@ -160,7 +160,7 @@
+ MultiValueMap one = new MultiValueMap();
+ Integer value = new Integer(1);
+ one.put("One", value);
+- one.remove("One", value);
++ one.removeMapping("One", value);
+
+ MultiValueMap two = new MultiValueMap();
+ assertEquals(two, one);
+@@ -186,7 +186,7 @@
+ assertEquals(4, map.totalSize());
+ map.remove("A");
+ assertEquals(3, map.totalSize());
+- map.remove("B", "BC");
++ map.removeMapping("B", "BC");
+ assertEquals(2, map.totalSize());
+ }
+
+@@ -203,7 +203,7 @@
+ assertEquals(2, map.size());
+ map.remove("A");
+ assertEquals(2, map.size());
+- map.remove("B", "BC");
++ map.removeMapping("B", "BC");
+ assertEquals(2, map.size());
+ }
+
+@@ -226,7 +226,7 @@
+ map.remove("A");
+ assertEquals(0, map.size("A"));
+ assertEquals(3, map.size("B"));
+- map.remove("B", "BC");
++ map.removeMapping("B", "BC");
+ assertEquals(0, map.size("A"));
+ assertEquals(2, map.size("B"));
+ }
+@@ -327,11 +327,11 @@
+ map.put("A", "AA");
+ map.put("A", "AB");
+ map.put("A", "AC");
+- assertEquals(null, map.remove("C", "CA"));
+- assertEquals(null, map.remove("A", "AD"));
+- assertEquals("AC", map.remove("A", "AC"));
+- assertEquals("AB", map.remove("A", "AB"));
+- assertEquals("AA", map.remove("A", "AA"));
++ assertEquals(null, map.removeMapping("C", "CA"));
++ assertEquals(null, map.removeMapping("A", "AD"));
++ assertEquals("AC", map.removeMapping("A", "AC"));
++ assertEquals("AB", map.removeMapping("A", "AB"));
++ assertEquals("AA", map.removeMapping("A", "AA"));
+ assertEquals(new MultiValueMap(), map);
+ }
+
+--- a/src/test/org/apache/commons/collections/TestMultiHashMap.java
++++ b/src/test/org/apache/commons/collections/TestMultiHashMap.java
+@@ -217,7 +217,7 @@
+ MultiHashMap one = new MultiHashMap();
+ Integer value = new Integer(1);
+ one.put("One", value);
+- one.remove("One", value);
++ one.removeMapping("One", value);
+
+ MultiHashMap two = new MultiHashMap();
+ assertEquals(two, one);
+@@ -269,7 +269,7 @@
+ assertEquals(4, map.totalSize());
+ map.remove("A");
+ assertEquals(3, map.totalSize());
+- map.remove("B", "BC");
++ map.removeMapping("B", "BC");
+ assertEquals(2, map.totalSize());
+ }
+
+@@ -292,7 +292,7 @@
+ map.remove("A");
+ assertEquals(0, map.size("A"));
+ assertEquals(3, map.size("B"));
+- map.remove("B", "BC");
++ map.removeMapping("B", "BC");
+ assertEquals(0, map.size("A"));
+ assertEquals(2, map.size("B"));
+ }
+@@ -464,11 +464,11 @@
+ map.put("A", "AA");
+ map.put("A", "AB");
+ map.put("A", "AC");
+- assertEquals(null, map.remove("C", "CA"));
+- assertEquals(null, map.remove("A", "AD"));
+- assertEquals("AC", map.remove("A", "AC"));
+- assertEquals("AB", map.remove("A", "AB"));
+- assertEquals("AA", map.remove("A", "AA"));
++ assertEquals(null, map.removeMapping("C", "CA"));
++ assertEquals(null, map.removeMapping("A", "AD"));
++ assertEquals("AC", map.removeMapping("A", "AC"));
++ assertEquals("AB", map.removeMapping("A", "AB"));
++ assertEquals("AA", map.removeMapping("A", "AA"));
+ assertEquals(new MultiHashMap(), map);
+ }
+
+--- a/src/java/org/apache/commons/collections/map/MultiKeyMap.java
++++ b/src/java/org/apache/commons/collections/map/MultiKeyMap.java
+@@ -197,7 +197,7 @@
+ * @param key2 the second key
+ * @return the value mapped to the removed key, null if key not in map
+ */
+- public Object remove(Object key1, Object key2) {
++ public Object removeMultiKey(Object key1, Object key2) {
+ int hashCode = hash(key1, key2);
+ int index = map.hashIndex(hashCode, map.data.length);
+ AbstractHashedMap.HashEntry entry = map.data[index];
+--- a/src/test/org/apache/commons/collections/map/TestMultiKeyMap.java
++++ b/src/test/org/apache/commons/collections/map/TestMultiKeyMap.java
+@@ -315,10 +315,10 @@
+ switch (key.size()) {
+ case 2:
+ assertEquals(true, multimap.containsKey(key.getKey(0), key.getKey(1)));
+- assertEquals(value, multimap.remove(key.getKey(0), key.getKey(1)));
++ assertEquals(value, multimap.removeMultiKey(key.getKey(0), key.getKey(1)));
+ assertEquals(false, multimap.containsKey(key.getKey(0), key.getKey(1)));
+ assertEquals(size - 1, multimap.size());
+- assertEquals(null, multimap.remove(key.getKey(0), key.getKey(1)));
++ assertEquals(null, multimap.removeMultiKey(key.getKey(0), key.getKey(1)));
+ assertEquals(false, multimap.containsKey(key.getKey(0), key.getKey(1)));
+ break;
+ case 3:
diff --git a/dev-java/commons-collections/metadata.xml b/dev-java/commons-collections/metadata.xml
new file mode 100644
index 000000000000..3e4d58fc9fa2
--- /dev/null
+++ b/dev-java/commons-collections/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <use>
+ <flag name="test-framework">Install the test framework</flag>
+ </use>
+</pkgmetadata>