summaryrefslogtreecommitdiff
path: root/dev-java/commons-codec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/commons-codec
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/commons-codec')
-rw-r--r--dev-java/commons-codec/Manifest5
-rw-r--r--dev-java/commons-codec/commons-codec-1.7.ebuild41
-rw-r--r--dev-java/commons-codec/metadata.xml29
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-java/commons-codec/Manifest b/dev-java/commons-codec/Manifest
new file mode 100644
index 000000000000..50f0419bd3fd
--- /dev/null
+++ b/dev-java/commons-codec/Manifest
@@ -0,0 +1,5 @@
+DIST commons-codec-1.7-src.tar.gz 291251 SHA256 816b5a9ae9ee67b918cb1864d0a24fbbc24ab1875992b6fc46ada6d62435e38a SHA512 31358283ac2827cb05486b8ff1512242153f61deb086f7fe145ee3ca38d96e43fba080a1e89a3b8cd44d09761015ff4dbe5226d29b7f9fcd59e68ca7701b28d6 WHIRLPOOL edc4caaf6ef56fd9c1a7437dacf873be53802eccbcb1f6035163946c07e3f4373e0698f069f00a8ad2bb5562a2c6a1ab909eccfccd6a527ce51dcedd2bd2bbfc
+EBUILD commons-codec-1.7.ebuild 905 SHA256 cb0ca3de4dfb7003121f48e135838a3260d0d18ee2e14b4b3f197cbeb6d56fe5 SHA512 2f62c9745717fcf1bd7761531933bd0eb4aa0c65251ae6a33f4b353ac8594e390c69c915ba4805ff132874c3f53fe38075478c51d62c778103730ab1168b5cd7 WHIRLPOOL 2c347997f06540fd7eea013efeabe517c381da1d7b07a65139b0fecd088f4233c62cdfdceb1ef2a8e1350601594975e040a73eeaec9545854f6be200110d2707
+MISC ChangeLog 2976 SHA256 b4c249f256b5e72e9b3fbf72456669e583405e439af1463ba885b69d1a77a95d SHA512 695a82f6e81b9658ee8a595fc1c70a3445a2d8644d9898fb836121a43c9e93b13ccf5c7b8c6f83875870928a0d5fdf68909e00064a6beb72f1f55cb6fbcff2cf WHIRLPOOL 4257c99a9c9641af82d9e2feb99f2cb7c6fd3c94fe350c9f957bec36d7242dd0a6bc7860b25bdb8063a006e4b4882c5e7c51b92ea96ff4e0ab33975eebf3e16d
+MISC ChangeLog-2015 6197 SHA256 940459964f70a38a85799fec209318b8dec9c538e78c13fe1052f34e6ba80baf SHA512 0497ba44de9dc325c723d9c2d4accf77fb41dd73c3d72e31c10ba056b6eb7b38d35aefc4e47979f14e1d8243d52233a419603996a00aa68d38e55f5d7526b1a1 WHIRLPOOL c085b9be280e8b703680ab6e340385d84a0f1b6c5b8254be2c6fd057d852a214b291d064117b1fe6a5c402b68f6f3828dff25358f5af0ad952e5fc23481c9cc6
+MISC metadata.xml 1360 SHA256 9b35ea4a5fda681cfaccb6375f1f2af6777e8e88acf327840e6c6c97fda75cf5 SHA512 d16f70860d4880e50d25e6297823fb71955c147eedd115ca7eda0a0bf6c4cbc6121bf8b12062241192facd4583f10df56a838c84940b5914f75d13f10c96e9ae WHIRLPOOL 8272cd691f3e19557198d900ada6bc9717cfd0018a0284a617f32617150810b25df0b38c8d1cc1e0ac1a689a50e831bcfe2c31a757ef17cae0d73c5a50920757
diff --git a/dev-java/commons-codec/commons-codec-1.7.ebuild b/dev-java/commons-codec/commons-codec-1.7.ebuild
new file mode 100644
index 000000000000..a4da5c3a9be3
--- /dev/null
+++ b/dev-java/commons-codec/commons-codec-1.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Implementations of common encoders and decoders in Java"
+HOMEPAGE="http://commons.apache.org/codec"
+SRC_URI="mirror://apache/commons/codec/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="test"
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6
+ test? (
+ dev-java/ant-junit:0
+ dev-java/junit:4
+ )"
+
+S=${WORKDIR}/${P}-src
+
+JAVA_ANT_ENCODING="ISO-8859-1"
+EANT_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}*.jar
+
+ dodoc RELEASE-NOTES.txt
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/commons-codec/metadata.xml b/dev-java/commons-codec/metadata.xml
new file mode 100644
index 000000000000..f27bbde4a60f
--- /dev/null
+++ b/dev-java/commons-codec/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+</maintainer>
+
+<longdescription>
+Codec was formed as an attempt to focus development effort on one
+definitive implementation of the Base64 encoder. At the time of Codec's
+proposal, there were approximately 34 different Java classes that dealt
+with Base64 encoding spread over the Foundation's CVS repository.
+Developers in the Jakarta Tomcat project had implemented an original
+version of the Base64 codec which had been copied by the Commons
+HttpClient and Apache XML project's XML-RPC subproject. After almost one
+year, the two forked versions of Base64 had significantly diverged from
+one another. XML-RPC had applied numerous fixes and patches which were
+not applied to the Commons HttpClient Base64. Different subprojects had
+differing implementations at various levels of compliance with the RFC
+2045.
+
+Out of that confusing duplication of effort sprang this simple attempt
+to encourage code reuse among various projects. While this package
+contains a abstract framework for the creation of encoders and decoders,
+Codec itself is primarily focused on providing functional utilities for
+working with common encodings.
+</longdescription>
+</pkgmetadata>