summaryrefslogtreecommitdiff
path: root/dev-java/commons-beanutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-java/commons-beanutils
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-java/commons-beanutils')
-rw-r--r--dev-java/commons-beanutils/Manifest2
-rw-r--r--dev-java/commons-beanutils/commons-beanutils-1.9.4-r1.ebuild101
-rw-r--r--dev-java/commons-beanutils/commons-beanutils-1.9.4.ebuild69
3 files changed, 102 insertions, 70 deletions
diff --git a/dev-java/commons-beanutils/Manifest b/dev-java/commons-beanutils/Manifest
index 18f57a4bc030..2d1bcb2a0848 100644
--- a/dev-java/commons-beanutils/Manifest
+++ b/dev-java/commons-beanutils/Manifest
@@ -1,5 +1,5 @@
DIST commons-beanutils-1.9.2-src.tar.gz 396910 BLAKE2B 1324c49605c9640aa3eee5c016a43bbb45b1984dd49eeab8f9b7a4ef1c5284ff8869228dda51719c2e6b3576517fdd02018a4f36654efc7f92d3fb7432008d05 SHA512 cf43aace33eb91368f86445874b16d977e827451f1355bb00e9b33bf0707855b5d757b0d58ad617f3a7f86f9065e7c900907dd604ba4de5ae61473d40cb758a9
DIST commons-beanutils-1.9.4-src.tar.gz 412606 BLAKE2B 213a2ad4d976ed4c55c9a73c0970a656e2f03efcba886369c8be164e04618937ad636ce7ffa6aa7b981e9595b24e4cbacc2bc632268bbfede8172091ef6eb4ff SHA512 6f3d30d02b9a66cf20509bd868c6e2dadb44bb27da1e6b9af7275675e0f3826845a5d4005509dd1eb77a5b2937820c4770a3753daaab072785dcdab0caa69e73
EBUILD commons-beanutils-1.9.2.ebuild 1829 BLAKE2B 987acca0c9832be1c004a01d37d88973295cff44640884edbec92aa35e7e70c68cd0721038dc10c5907149c134408bba6598ecae73ae11834b4617cd44d7444e SHA512 b05fec1515bf71928fd9463de580ec191200549cf3a079027725bdf5b0f1029047608de5f893863c22f690b3bffec3d03b3273c1aef0b0e2002ce1b358e530be
-EBUILD commons-beanutils-1.9.4.ebuild 2210 BLAKE2B 1567a8fbded5a1634b7b703487e519f5131ffbff844debb52c93328f4f55ccfa625c8cd3bea3657da585591563f191d513a23698dc658bbc069aa94e5a4b1350 SHA512 38c25f0e231c9c4e9967b0c8e9c9fd030a5d942fd51b5edc949d0beb1993b0a0e02b197bb939136ca08eda0911267cd3855c0db0056c08aba8f1a2acbb728cae
+EBUILD commons-beanutils-1.9.4-r1.ebuild 4624 BLAKE2B e8142e5028d4960da7886dae50ed229bea902b1879dbc3e08dc3cfaa25fcc6513aeab438b4bc1edb3389082d798ff6c4fbf10ce3321c34299fe2dfc5dfe039e7 SHA512 16804bc672b5f32a352919bae336578364142f37eeb9a25b0d5a9e63e890d469d5191f8a88f9e1064e994354d4890ea9c3052f21775dd2ae17c37541be365bf0
MISC metadata.xml 233 BLAKE2B 2b385ca77219f08b2874b3a4a91a0c836d3cb45ec44b05babb33d590c56ceb5337ecb93a8450a37f8e6bbf4cfc1455892e8142d22e0a1d527d40361e2dce350b SHA512 1acc975a7dc3344bc63282d652ca00d8245970b58353b4fd00f09a4859db3eaba2dcd85e1537d424b7174e4f9c01c2ffb10ec6d107b5c895c9ca20730666de7f
diff --git a/dev-java/commons-beanutils/commons-beanutils-1.9.4-r1.ebuild b/dev-java/commons-beanutils/commons-beanutils-1.9.4-r1.ebuild
new file mode 100644
index 000000000000..b7f3e06ece9c
--- /dev/null
+++ b/dev-java/commons-beanutils/commons-beanutils-1.9.4-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri mirror://apache/commons/beanutils/source/1.9.4-src.tar.gz --slot 1.7 --keywords "~amd64 ~x86 ~ppc64 ~amd64-linux ~x86-linux ~x64-macos" --ebuild commons-beanutils-1.9.4.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="commons-beanutils:commons-beanutils:1.9.4"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Provides easy-to-use wrappers around Reflection and Introspection APIs"
+HOMEPAGE="https://commons.apache.org/proper/commons-beanutils/"
+SRC_URI="mirror://apache/commons/beanutils/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1.7"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+# Common dependencies
+# POM: pom.xml
+# commons-collections:commons-collections:3.2.2 -> >=dev-java/commons-collections-3.2.2:0
+# commons-logging:commons-logging:1.2 -> >=dev-java/commons-logging-1.2:0
+
+CP_DEPEND="
+ dev-java/commons-collections:0
+ dev-java/commons-logging:0
+"
+
+# Compile dependencies
+# POM: pom.xml
+# test? commons-collections:commons-collections-testframework:3.2.1 -> !!!artifactId-not-found!!!
+# test? junit:junit:4.12 -> >=dev-java/junit-4.12:4
+
+DEPEND="${CP_DEPEND}
+ >=virtual/jdk-1.8:*
+ test? (
+ dev-java/commons-collections:0[test]
+ )"
+
+RDEPEND="${CP_DEPEND}
+ >=virtual/jre-1.8:*"
+
+DOCS=( {CONTRIBUTING,README}.md {LICENSE,NOTICE,RELEASE-NOTES}.txt )
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ENCODING="iso-8859-1"
+
+JAVA_SRC_DIR="src/main/java"
+
+JAVA_TEST_GENTOO_CLASSPATH="commons-collections,junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
+
+JAVA_TEST_EXCLUDES=(
+ # Upstream: Tests run: 1293, Failures: 0, Errors: 0, Skipped: 3
+ "org.apache.commons.beanutils.TestBeanPublicSubclass" # Invalid test class
+ "org.apache.commons.beanutils.TestBeanPackageSubclass" # Invalid test class
+ "org.apache.commons.beanutils.TestResultSetMetaData" # Invalid test class
+ "org.apache.commons.beanutils.TestResultSet" # Test class can only have one constructor
+ "org.apache.commons.beanutils.TestBean" # Test class can only have one constructor
+ # https://github.com/apache/commons-beanutils/blob/32ceb2c92512d44f97638805e2f3fd9d70dfcfc6/pom.xml#L378-L383
+ # <!-- This test case is known to fail, and there isn't any proposed fix
+ # - so we will just exclude it until someone comes up with a solution.
+ # -->
+ "org.apache.commons.beanutils.converters.MemoryTestCase"
+)
+
+src_test() {
+ # There were 8 failures:
+ # 1) testPropertyUtilsBean_descriptorsCache_memoryLeak(org.apache.commons.beanutils.memoryleaktests.MemoryLeakTestCase)
+ # java.lang.OutOfMemoryError: Java heap space: failed reallocation of scalar replaced objects
+ # 2) testPropertyUtilsBean_mappedDescriptorsCache_memoryLeak(org.apache.commons.beanutils.memoryleaktests.MemoryLeakTestCase)
+ # java.lang.OutOfMemoryError: Java heap space: failed reallocation of scalar replaced objects
+ # 3) testMappedPropertyDescriptor_MappedMethodReference1(org.apache.commons.beanutils.memoryleaktests.MemoryLeakTestCase)
+ # java.lang.OutOfMemoryError: Java heap space: failed reallocation of scalar replaced objects
+ # 4) testMappedPropertyDescriptor_MappedMethodReference2(org.apache.commons.beanutils.memoryleaktests.MemoryLeakTestCase)
+ # java.lang.OutOfMemoryError: Java heap space: failed reallocation of scalar replaced objects
+ # 5) testLocaleConvertUtilsBean_converters_memoryLeak(org.apache.commons.beanutils.memoryleaktests.MemoryLeakTestCase)
+ # java.lang.OutOfMemoryError: Java heap space: failed reallocation of scalar replaced objects
+ # 6) testWrapDynaClass_dynaClasses_memoryLeak(org.apache.commons.beanutils.memoryleaktests.MemoryLeakTestCase)
+ # java.lang.OutOfMemoryError: Java heap space: failed reallocation of scalar replaced objects
+ # 7) testMethodUtils_cache_memoryLeak(org.apache.commons.beanutils.memoryleaktests.MemoryLeakTestCase)
+ # java.lang.OutOfMemoryError: Java heap space: failed reallocation of scalar replaced objects
+ # 8) testConvertUtilsBean_converters_memoryLeak(org.apache.commons.beanutils.memoryleaktests.MemoryLeakTestCase)
+ # java.lang.OutOfMemoryError: Java heap space: failed reallocation of scalar replaced objects
+ local vm_version="$(java-config -g PROVIDES_VERSION)"
+ if [[ "${vm_version}" == "11" ]] ; then
+ JAVA_TEST_EXCLUDES+=( "org.apache.commons.beanutils.memoryleaktests.MemoryLeakTestCase" )
+ fi
+
+ java-pkg-simple_src_test
+}
+
+src_install() {
+ default # https://bugs.gentoo.org/789582
+ java-pkg-simple_src_install
+}
diff --git a/dev-java/commons-beanutils/commons-beanutils-1.9.4.ebuild b/dev-java/commons-beanutils/commons-beanutils-1.9.4.ebuild
deleted file mode 100644
index a36a6aea1cef..000000000000
--- a/dev-java/commons-beanutils/commons-beanutils-1.9.4.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri mirror://apache/commons/beanutils/source/1.9.4-src.tar.gz --slot 1.7 --keywords "~amd64 ~x86 ~ppc64 ~amd64-linux ~x86-linux ~x64-macos" --ebuild commons-beanutils-1.9.4.ebuild
-
-EAPI=7
-
-JAVA_PKG_IUSE="doc source test"
-MAVEN_ID="commons-beanutils:commons-beanutils:1.9.4"
-JAVA_TESTING_FRAMEWORKS="junit-4"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Provides easy-to-use wrappers around Reflection and Introspection APIs"
-HOMEPAGE="https://commons.apache.org/proper/commons-beanutils/"
-SRC_URI="mirror://apache/commons/beanutils/source/${P}-src.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="1.7"
-KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-# Common dependencies
-# POM: pom.xml
-# commons-collections:commons-collections:3.2.2 -> >=dev-java/commons-collections-3.2.2:0
-# commons-logging:commons-logging:1.2 -> >=dev-java/commons-logging-1.2:0
-
-CDEPEND="
- dev-java/commons-collections:0
- dev-java/commons-logging:0
-"
-
-# Compile dependencies
-# POM: pom.xml
-# test? commons-collections:commons-collections-testframework:3.2.1 -> !!!artifactId-not-found!!!
-# test? junit:junit:4.12 -> >=dev-java/junit-4.12:4
-
-DEPEND="
- >=virtual/jdk-1.8:*
- ${CDEPEND}
- test? (
- dev-java/commons-collections:0[test]
- )
-"
-
-RDEPEND="
- >=virtual/jre-1.8:*
- ${CDEPEND}
-"
-
-S="${WORKDIR}/${P}-src"
-
-JAVA_ENCODING="iso-8859-1"
-
-JAVA_GENTOO_CLASSPATH="commons-collections,commons-logging"
-JAVA_SRC_DIR="src/main/java"
-# JAVA_RESOURCE_DIRS="src/main/resources"
-
-JAVA_TEST_GENTOO_CLASSPATH="commons-collections,junit-4"
-JAVA_TEST_SRC_DIR="src/test/java"
-# JAVA_TEST_RESOURCE_DIRS="src/test/resources"
-
-JAVA_TEST_EXCLUDES=(
- "org.apache.commons.beanutils.TestBeanPublicSubclass" # Invalid test class
- "org.apache.commons.beanutils.TestBeanPackageSubclass" # Invalid test class
- "org.apache.commons.beanutils.TestResultSetMetaData" # Invalid test class
- "org.apache.commons.beanutils.TestResultSet" # Test class can only have one constructor
- "org.apache.commons.beanutils.TestBean" # Test class can only have one constructor
-)