summaryrefslogtreecommitdiff
path: root/dev-java/bnd-junit/bnd-junit-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-java/bnd-junit/bnd-junit-2.1.0.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/bnd-junit/bnd-junit-2.1.0.ebuild')
-rw-r--r--dev-java/bnd-junit/bnd-junit-2.1.0.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-java/bnd-junit/bnd-junit-2.1.0.ebuild b/dev-java/bnd-junit/bnd-junit-2.1.0.ebuild
deleted file mode 100644
index e4de5405feee..000000000000
--- a/dev-java/bnd-junit/bnd-junit-2.1.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-JAVA_PKG_IUSE="test"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Junit plugin for bndlib, a swiss army knife for OSGi"
-HOMEPAGE="http://www.aqute.biz/Bnd/Bnd"
-SRC_URI="https://github.com/bndtools/bnd/archive/${PV}.REL.tar.gz -> bndlib-${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-CDEPEND="
- dev-java/osgi-core-api:0
- dev-java/bndlib:0"
-
-DEPEND=">=virtual/jdk-1.5
- test? ( dev-java/junit:4 )
- ${CDEPEND}"
-
-RDEPEND=">=virtual/jre-1.5
- ${CDEPEND}"
-
-S="${WORKDIR}/bnd-${PV}.REL/biz.aQute.junit"
-
-EANT_BUILD_TARGET="build"
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-EANT_GENTOO_CLASSPATH="bndlib,junit-4,osgi-core-api"
-
-# Tests appear broken and cause a circular dependency.
-RESTRICT="test"
-
-java_prepare() {
- # Move the correct build.xml into place, needed for testing.
- cp ../cnf/build.xml . || die
-
- # Remove bundled jar files.
- find . -name '*.jar' -delete > /dev/null
-}
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_newjar generated/biz.aQute.junit.jar
-}