summaryrefslogtreecommitdiff
path: root/dev-java/bcprov
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-java/bcprov
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-java/bcprov')
-rw-r--r--dev-java/bcprov/Manifest4
-rw-r--r--dev-java/bcprov/bcprov-1.71-r1.ebuild111
-rw-r--r--dev-java/bcprov/metadata.xml2
3 files changed, 115 insertions, 2 deletions
diff --git a/dev-java/bcprov/Manifest b/dev-java/bcprov/Manifest
index aaa1cc15f6eb..f4f1f59bfe3a 100644
--- a/dev-java/bcprov/Manifest
+++ b/dev-java/bcprov/Manifest
@@ -1,3 +1,5 @@
DIST bc-java-r1rv69.tar.gz 56587177 BLAKE2B be5321f48911840de70d3201c0436cf4147a25999abb605dc4c176ea9292796ca25633635d66dccab685a4bb162258c4495ccc764782119a0750ec1b7456a7db SHA512 5224f424faf549e8e3f2db1134e74647b09bebb654ed23bb0bcd493f065fdb3f2b4f2815be0137ebcc9d62b25a6725b7a26b76d55eb3ad014ad0ce92961126de
+DIST bc-java-r1rv71.tar.gz 117684695 BLAKE2B db0a1b2576a55592e0447aa8734e8ecb6fe8452d08dabf010070f3c6b5a3b4caa7a5929baaa52796fed0ef397e18fe58fdb91dfef6da75af8f28efb627d2b808 SHA512 c9a095a034863a46027e28754ae96d9750162120bc1af124fa700ad05d23716a606633b674e2e8490bda658d30d30e93f42ba00dcc1ac13596a24f8aa43a666d
EBUILD bcprov-1.69.ebuild 2754 BLAKE2B 189ff7bfda398f16df34cfc644024a5287dd51fa2c5e2c0919ed4cc2ae2df9083d7c0efb604402156e58292589ef6c8eb631ade1d497db9943623178155a8689 SHA512 72828c651c1deaf67721d0515feab2821876810fe29554bf0cadb09a5274115f10ba2df1f3b4b2bb93ab205dfb6e7182275dbccd19931902186c84464abb8324
-MISC metadata.xml 482 BLAKE2B 0afc6ceb6e81b57040e44020b919d226bd8d9ae3eb64bb4955a31c23f929712db16c0c2245dad2dbd7750ec20d0794af53ba05fc7411cf19445daee331b1f21d SHA512 1c342946be63fe9caf6905074d8590b60c1044ef8a6b89714a33b8e97f3ab70409748a697453d23f7b8d3c27ccf14dc8f3be84fb36cc5f810c30b54ce6118b06
+EBUILD bcprov-1.71-r1.ebuild 3491 BLAKE2B 4543cbddc8afe392f7bd8840ca297284989a8698394df1db9c2886cdd1989f64a6c68f61ad879a70fadb2a10a8a9af9698653cb86d3e2fa34fd894974f5fd4d0 SHA512 f3c394e75f2f09dde4cd29cbe548cf99c221b3528a0e505d190641eb2d757272b4b6ec226cb5b1f4cfd78d8734b462388f5457186fdaf2d8495f3e19a9cdf815
+MISC metadata.xml 476 BLAKE2B b065e42576858847f7c1e2a8f27b836c59ca67f9514bae2077d884601e73fe7cf347beae0c31f2d4e795787bf22d9e7d575555cf0a1d1de2de36bd200fc4af0b SHA512 510131e9259fbe497800cc5ac8650a970e45013c398b4aa26a240c5ef66186fe594f9ff9d21258d7bb744aed1d5365ab462fa5abfec7ef48efbd15071789ea15
diff --git a/dev-java/bcprov/bcprov-1.71-r1.ebuild b/dev-java/bcprov/bcprov-1.71-r1.ebuild
new file mode 100644
index 000000000000..6863a4a66716
--- /dev/null
+++ b/dev-java/bcprov/bcprov-1.71-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="org.bouncycastle:bcprov-jdk18on:1.71"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple check-reqs
+
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="https://www.bouncycastle.org/java.html"
+SRC_URI="https://github.com/bcgit/bc-java/archive/r${PV/./rv}.tar.gz -> bc-java-r${PV/./rv}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-11:*"
+RDEPEND=">=virtual/jre-1.8:*"
+BDEPEND="app-arch/zip"
+
+DOCS=( ../{README,SECURITY}.md )
+HTML_DOCS=( ../{CONTRIBUTORS,index}.html )
+
+S="${WORKDIR}/bc-java-r${PV/./rv}/prov"
+
+JAVA_SRC_DIR=(
+ "src/main/java"
+ "../core/src/main/java" # package org.bouncycastle.asn1 does not exist
+ "src/main/jdk1.9" # https://bugs.gentoo.org/797634
+)
+JAVA_RESOURCE_DIRS="src/main/resources"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR=( "src/test/java" "../core/src/test/java" )
+JAVA_TEST_RESOURCE_DIRS=( "src/test/resources" "../core/src/test/resources" )
+
+JAVA_TEST_EXTRA_ARGS="-Dbc.test.data.home=${S}/../core/src/test/data"
+
+# Depending on vm_version 11 or 17 there are 2 different errrors
+# 1) testJCE(org.bouncycastle.jce.provider.test.SimpleTestTest)
+# junit.framework.AssertionFailedError: index 29 KeyStore: Exception: java.security.KeyStoreException: BKS-V1 not found
+# at junit.framework.Assert.fail(Assert.java:57)
+# at junit.framework.TestCase.fail(TestCase.java:223)
+# at org.bouncycastle.jce.provider.test.SimpleTestTest.testJCE(SimpleTestTest.java:26)
+#
+# 1) testJCE(org.bouncycastle.jce.provider.test.SimpleTestTest)
+# junit.framework.AssertionFailedError: index 9 BlockCipher: IDEA/PGPCFB/NoPadding failed encryption - java.io.IOException: javax.crypto.ShortBufferException: output buffer too short for input.
+# at junit.framework.Assert.fail(Assert.java:57)
+# at junit.framework.TestCase.fail(TestCase.java:223)
+# at org.bouncycastle.jce.provider.test.SimpleTestTest.testJCE(SimpleTestTest.java:26)
+JAVA_TEST_RUN_ONLY=(
+ "org.bouncycastle.asn1.test.AllTests"
+ "org.bouncycastle.crypto.agreement.test.AllTests"
+ "org.bouncycastle.crypto.ec.test.AllTests"
+ "org.bouncycastle.crypto.prng.test.AllTests"
+ "org.bouncycastle.crypto.test.AllTests"
+ "org.bouncycastle.jcajce.provider.test.AllTests"
+# "org.bouncycastle.jce.provider.test.AllTests" # bug #827146
+ "org.bouncycastle.jce.provider.test.nist.AllTests"
+ "org.bouncycastle.jce.provider.test.rsa3.AllTests"
+ "org.bouncycastle.pqc.crypto.lms.AllTests"
+ "org.bouncycastle.pqc.crypto.test.AllTests"
+ "org.bouncycastle.pqc.jcajce.provider.test.AllTests"
+ "org.bouncycastle.util.encoders.test.AllTests"
+)
+
+check_env() {
+ if use test; then
+ # this is needed only for tests
+ CHECKREQS_MEMORY="2048M"
+ check-reqs_pkg_pretend
+ fi
+}
+
+pkg_pretend() {
+ check_env
+}
+
+pkg_setup() {
+ check_env
+ java-pkg-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ java-pkg_clean ..
+}
+
+src_test() {
+ JAVA_TEST_EXTRA_ARGS+=" -Xmx${CHECKREQS_MEMORY}"
+ java-pkg-simple_src_test
+}
+
+src_install() {
+ default
+ einstalldocs
+ docinto html
+ dodoc -r ../docs
+
+ # These files are not present in the upstream jar but are used for tests
+ # Removing them from the jar file after testing
+ zip --delete "${S}"/bcprov.jar \
+ "org/bouncycastle/pqc/crypto/ntru/*" \
+ "org/bouncycastle/pqc/math/ntru/*" \
+ || die "cleaning after tests failed"
+
+ java-pkg-simple_src_install
+}
diff --git a/dev-java/bcprov/metadata.xml b/dev-java/bcprov/metadata.xml
index b5ad9ebd01ee..1a34130e2c63 100644
--- a/dev-java/bcprov/metadata.xml
+++ b/dev-java/bcprov/metadata.xml
@@ -6,6 +6,6 @@
<name>Java</name>
</maintainer>
<longdescription>
- "The Bouncy Castle Crypto package is a Java implementation of cryptographic algorithms. This jar contains JCE provider and lightweight API for the Bouncy Castle Cryptography APIs for JDK 1.5 to JDK 1.8."
+ The Bouncy Castle Crypto package is a Java implementation of cryptographic algorithms. This jar contains JCE provider and lightweight API for the Bouncy Castle Cryptography APIs for JDK 1.8 and up.
</longdescription>
</pkgmetadata>