summaryrefslogtreecommitdiff
path: root/dev-java/bcpkix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-java/bcpkix
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-java/bcpkix')
-rw-r--r--dev-java/bcpkix/Manifest4
-rw-r--r--dev-java/bcpkix/bcpkix-1.71-r1.ebuild116
-rw-r--r--dev-java/bcpkix/metadata.xml3
3 files changed, 122 insertions, 1 deletions
diff --git a/dev-java/bcpkix/Manifest b/dev-java/bcpkix/Manifest
index 92ec3d9465c8..cfeba047df3b 100644
--- a/dev-java/bcpkix/Manifest
+++ b/dev-java/bcpkix/Manifest
@@ -1,3 +1,5 @@
DIST bc-java-r1rv69.tar.gz 56587177 BLAKE2B be5321f48911840de70d3201c0436cf4147a25999abb605dc4c176ea9292796ca25633635d66dccab685a4bb162258c4495ccc764782119a0750ec1b7456a7db SHA512 5224f424faf549e8e3f2db1134e74647b09bebb654ed23bb0bcd493f065fdb3f2b4f2815be0137ebcc9d62b25a6725b7a26b76d55eb3ad014ad0ce92961126de
+DIST bc-java-r1rv71.tar.gz 117684695 BLAKE2B db0a1b2576a55592e0447aa8734e8ecb6fe8452d08dabf010070f3c6b5a3b4caa7a5929baaa52796fed0ef397e18fe58fdb91dfef6da75af8f28efb627d2b808 SHA512 c9a095a034863a46027e28754ae96d9750162120bc1af124fa700ad05d23716a606633b674e2e8490bda658d30d30e93f42ba00dcc1ac13596a24f8aa43a666d
EBUILD bcpkix-1.69.ebuild 2556 BLAKE2B 842dfda2673810899cc1a164924b97f142214ab7f34164a87bfc2b16360e688a082a5bc09aca36765086d2b42b0f6e499fd10c2f31e8a63d72742a4afeb7859a SHA512 fdff8b61adafbf1eff91ff020c8042c0f332f53e66be300e73eadb9efe30cf57f28468a64a9a9b13842305db4219757a9d6349e2fae26b98dd9611ed7ba7f89e
-MISC metadata.xml 237 BLAKE2B 7c3263833976c18611a5cba44845af4d80f2f86c48cf587a657292ed0074022088cef88756e3209b292252dce5c0eea307c4f2f45f28b8517609124708f7d09a SHA512 e8227b536eb45569cbf744907106e101d1aa6bf9ba8337783786d719ab107d8bda0fde5dd7067d168181d694b4161b12d1ef3cb5a83b14971b21aa4479670559
+EBUILD bcpkix-1.71-r1.ebuild 3078 BLAKE2B ee7b23d5ba7f18ab15201d3b308d0a02507869e28fd1f77c71d400da9681988438deb90a977adfaed99d38eb9d54d82cb17eea5166d442920f73716d4c0c33b2 SHA512 ba7e8f697f2b4b793d47ea81b92af29526e2643719a97ba9afdc41b80f2e70cc3de968cf04239618d809a7e16460de3b2cf45173c3c1ffcee41fd1b7049fd907
+MISC metadata.xml 546 BLAKE2B 3e07f58b65f0148062a3f1b20c06d71ce1925cf7b91d167a07d21028f541cfbc69b8a78e914ea6b86598afb3f3ae7f841defa6e1b691fac5293f2cb6746c1f0c SHA512 137f6f4d3d26d90109102fa49e37a42ea3628104adaf65e0b93ca652abd1aa6392e3f76dbf342aa70706b734d8b7f262f2b826e3ce33ae35fa60c40e548bf89b
diff --git a/dev-java/bcpkix/bcpkix-1.71-r1.ebuild b/dev-java/bcpkix/bcpkix-1.71-r1.ebuild
new file mode 100644
index 000000000000..208e40ffb41e
--- /dev/null
+++ b/dev-java/bcpkix/bcpkix-1.71-r1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="org.bouncycastle:bcpkix-jdk18on:1.71"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple check-reqs
+
+DESCRIPTION="Java APIs for CMS, PKCS, EAC, TSP, CMP, CRMF, OCSP, and certificate generation"
+HOMEPAGE="https://www.bouncycastle.org/java.html"
+SRC_URI="https://github.com/bcgit/bc-java/archive/r${PV/./rv}.tar.gz -> bc-java-r${PV/./rv}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+# 1) testSANMismatchIP(org.bouncycastle.est.test.TestHostNameAuthorizer)
+# org.bouncycastle.est.ESTException: localhost.me: Temporary failure in name resolution HTTP Status Code: 0
+PROPERTIES="test_network"
+RESTRICT="test"
+
+CDEPEND="
+ ~dev-java/bcprov-${PV}:0
+ ~dev-java/bcutil-${PV}:0
+ "
+DEPEND="${CDEPEND}
+ >=virtual/jdk-11:*"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.8:*"
+
+DOCS=( ../{README,SECURITY}.md )
+HTML_DOCS=( ../{CONTRIBUTORS,index}.html )
+
+S="${WORKDIR}/bc-java-r${PV/./rv}/pkix"
+
+JAVA_GENTOO_CLASSPATH="bcprov,bcutil"
+JAVA_SRC_DIR=(
+ "src/main/java"
+ "src/main/jdk1.9" # https://bugs.gentoo.org/797634
+)
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS="src/test/resources"
+
+JAVA_TEST_EXTRA_ARGS="-Dbc.test.data.home=${S}/../core/src/test/data"
+
+# There was 1 failure:
+# 1) testSimpleTests(org.bouncycastle.cert.test.AllTests)
+# junit.framework.AssertionFailedError: CertTest:
+# CertTest: 9 failed - exception java.security.InvalidKeyException: cannot identify EdDSA public key
+# at junit.framework.Assert.fail(Assert.java:57)
+# at junit.framework.TestCase.fail(TestCase.java:223)
+# at org.bouncycastle.cert.test.AllTests.testSimpleTests(AllTests.java:30)
+#
+# FAILURES!!!
+# Tests run: 474, Failures: 1
+JAVA_TEST_RUN_ONLY=(
+ "org.bouncycastle.cert.cmp.test.AllTests"
+ "org.bouncycastle.cert.crmf.test.AllTests"
+ "org.bouncycastle.cert.ocsp.test.AllTests"
+ "org.bouncycastle.cert.path.test.AllTests"
+# "org.bouncycastle.cert.test.AllTests"
+ "org.bouncycastle.cms.test.AllTests"
+ "org.bouncycastle.dvcs.test.AllTests"
+ "org.bouncycastle.eac.test.AllTests"
+ "org.bouncycastle.est.test.AllTests"
+ "org.bouncycastle.mime.test.AllTests"
+ "org.bouncycastle.mozilla.test.AllTests"
+ "org.bouncycastle.openssl.test.AllTests"
+ "org.bouncycastle.operator.test.AllTests"
+ "org.bouncycastle.pkcs.test.AllTests"
+ "org.bouncycastle.tsp.test.AllTests"
+)
+
+# https://bugs.gentoo.org/823347
+check_env() {
+ if use test; then
+ # this is needed only for tests
+ CHECKREQS_MEMORY="2048M"
+ check-reqs_pkg_pretend
+ fi
+}
+
+# https://bugs.gentoo.org/823347
+pkg_pretend() {
+ check_env
+}
+
+# https://bugs.gentoo.org/823347
+pkg_setup() {
+ check_env
+ java-pkg-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ java-pkg_clean ..
+}
+
+# https://bugs.gentoo.org/823347
+src_test() {
+ JAVA_TEST_EXTRA_ARGS+=" -Xmx${CHECKREQS_MEMORY}"
+ java-pkg-simple_src_test
+}
+
+src_install() {
+ default
+ einstalldocs
+ docinto html
+ dodoc -r ../docs
+ java-pkg-simple_src_install
+}
diff --git a/dev-java/bcpkix/metadata.xml b/dev-java/bcpkix/metadata.xml
index 4221e170cbc0..40c8ee28be10 100644
--- a/dev-java/bcpkix/metadata.xml
+++ b/dev-java/bcpkix/metadata.xml
@@ -5,4 +5,7 @@
<email>java@gentoo.org</email>
<name>Java</name>
</maintainer>
+ <longdescription>
+ The Bouncy Castle Java APIs for CMS, PKCS, EAC, TSP, CMP, CRMF, OCSP, and certificate generation. This jar contains APIs for JDK 1.8 and up. The APIs can be used in conjunction with a JCE/JCA provider such as the one provided with the Bouncy Castle Cryptography APIs.
+ </longdescription>
</pkgmetadata>