summaryrefslogtreecommitdiff
path: root/dev-java/bcpg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/bcpg
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/bcpg')
-rw-r--r--dev-java/bcpg/Manifest7
-rw-r--r--dev-java/bcpg/bcpg-1.50-r1.ebuild70
-rw-r--r--dev-java/bcpg/bcpg-1.50-r2.ebuild73
-rw-r--r--dev-java/bcpg/bcpg-1.52-r1.ebuild70
-rw-r--r--dev-java/bcpg/bcpg-1.52-r2.ebuild73
-rw-r--r--dev-java/bcpg/metadata.xml8
6 files changed, 301 insertions, 0 deletions
diff --git a/dev-java/bcpg/Manifest b/dev-java/bcpg/Manifest
new file mode 100644
index 000000000000..b21ac5d01952
--- /dev/null
+++ b/dev-java/bcpg/Manifest
@@ -0,0 +1,7 @@
+DIST bcpg-jdk15on-150.tar.gz 691012 BLAKE2B ee566fb6deb44177e31bfe80b6bd1f13d39d6820cffe3693bd85314ccfd65c4805275b3925d52a6bda6b1ad7e3ea267f1f0bed3926420b5920e5f300020ecd9a SHA512 763d253b9bb45b7e7fab75d557daa784c3d4a503ced979adc986e5688c3939db248853c864a2f4bec6d5b1dd9ed668d5f278c91b5607774fc703971d0b330fe6
+DIST bcpg-jdk15on-152.tar.gz 748424 BLAKE2B f847fa95ae4eff6c9c95f23ad318d3b967bd224a5dbaea20f8e904a50173076e16723519e8985d4afd2ac02c6a7fe83399e0c6005971bd460b41055c4866a506 SHA512 1619a8cd4024129876266415406882ac5df3dd84fd3e01d7593304874ad641fe72ae95150d0e4414b294e2e5ca8eb39e41a25658f9502b4cd9622fbf0f3d45a0
+EBUILD bcpg-1.50-r1.ebuild 1515 BLAKE2B 25e57aba985350e8922eb0edf9f6a12dbc8f5a2750e4d45c1cb9eb0df0b9ba909ac1eb8d2aa151bdaaa123e7e6accce4eb6182fdd9105c39a2414de9eda46c07 SHA512 eddecb8d3365fe745bf132119d52a46d12a835973e5c9e3e0121822f53b525e8ee24a2b3a6c98920082c24cdc7daf2da6d9d27784abcc424dc41dfbd6a185558
+EBUILD bcpg-1.50-r2.ebuild 1536 BLAKE2B 00122a19f7a787b43507a1a73ae345bd1783efca518818511ea8d8717b42706a2c30f9af202811be5ca60317e3e18250459aa9dd82564daff4e7cd27e36207af SHA512 ad42a74689b4012041e201121ccd134af357b6296f32a4bcba1faad79b03c4ed17579e0e514bdd8c9bcf7f628ad9602a1d8de0f0ff52841a984c408f3ed858cb
+EBUILD bcpg-1.52-r1.ebuild 1515 BLAKE2B 72b4bf72e59b56261b478537c5a29ac660a1504ba824c69c17355d61bdc9284b90e4aaac577856c145576eceff0ed1d453fad2fd22f6fffa70b2c4ec0f00cd3d SHA512 fe5f38bbb296c0217acf3564e403b184dae5e3e87f7a782b55a19e316869fd41853e9c8d7825e51a6825020965c5a7f30c884ba36ccfbb030555d5ddcc948814
+EBUILD bcpg-1.52-r2.ebuild 1536 BLAKE2B e98881a8414cd34669bbe93ef2e2d70b5cf6c69ed1233b1eb6e7f019cc2e3162d6564087c1c594222eb1a9c7c18e88f8d52331ef00ca42a4803c5bf62529f3b5 SHA512 992062b60f1d753f497739101032404483e86af1a1f01121d541d17b6b122f6c16b2e5ab553e67a6292b3644b69137a8c1ff38d7551d36b22bc490f4d8d2a95c
+MISC metadata.xml 236 BLAKE2B 5a64c4404c26415501f50132968e687d4f1b852738cb0e1a5aef8cc4de9e4ea623066f46068fce3d80514ff122d85304e3fd12282c4b1513a4084523ef8bef07 SHA512 1755c2590e59060f697294c5ad125b83f2d50e05a71f7091b7de75953941914cd2db3a893bd6154a2c90fa4aff5e313e75e3e174dbba1edd5c112787da5be253
diff --git a/dev-java/bcpg/bcpg-1.50-r1.ebuild b/dev-java/bcpg/bcpg-1.50-r1.ebuild
new file mode 100644
index 000000000000..b895d1674885
--- /dev/null
+++ b/dev-java/bcpg/bcpg-1.50-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="${PN}-jdk15on-${PV/./}"
+
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="http://www.bouncycastle.org/java.html"
+SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="1.50"
+KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+# Tests are currently broken. Appears to need older version of bcprov; but since bcprov is not slotted, this can cause conflicts.
+# Needs further investigation; though, only a small part has tests and there are no tests for bcpg itself.
+RESTRICT="test"
+
+CDEPEND="dev-java/bcprov:${SLOT}"
+
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ test? (
+ dev-java/ant-junit:0
+ )
+ ${CDEPEND}"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+JAVA_GENTOO_CLASSPATH="bcprov-${SLOT}"
+
+src_unpack() {
+ default
+ cd "${S}"
+ unpack ./src.zip
+}
+
+java_prepare() {
+ if ! use test; then
+ local RM_TEST_FILES=(
+ org/bouncycastle/openpgp/test
+ org/bouncycastle/openpgp/examples/test
+ )
+ rm -rf "${RM_TEST_FILES[@]}" || die
+ fi
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+}
+
+src_test() {
+ local cp="${PN}.jar:bcprov.jar:junit.jar"
+ local pkg="org.bouncycastle"
+ java -cp ${cp} ${pkg}.openpgp.test.AllTests | tee openpgp.tests
+ grep -q FAILURES *.tests && die "Tests failed."
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ use source && java-pkg_dosrc org
+}
diff --git a/dev-java/bcpg/bcpg-1.50-r2.ebuild b/dev-java/bcpg/bcpg-1.50-r2.ebuild
new file mode 100644
index 000000000000..6a89f6e93494
--- /dev/null
+++ b/dev-java/bcpg/bcpg-1.50-r2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="${PN}-jdk15on-${PV/./}"
+
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="http://www.bouncycastle.org/java.html"
+SRC_URI="http://polydistortion.net/bc/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="1.50"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+# Tests are currently broken. Appears to need older version of bcprov; but
+# since bcprov is not slotted, this can cause conflicts. Needs further
+# investigation; though, only a small part has tests and there are no tests for
+# bcpg itself.
+RESTRICT="test"
+
+CDEPEND="dev-java/bcprov:${SLOT}"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6
+ test? ( dev-java/ant-junit:0 )"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+S="${WORKDIR}/${MY_P}"
+
+JAVA_GENTOO_CLASSPATH="bcprov-${SLOT}"
+
+src_unpack() {
+ default
+ cd "${S}" || die
+ unpack ./src.zip
+}
+
+src_prepare() {
+ default
+ if ! use test; then
+ local RM_TEST_FILES=(
+ org/bouncycastle/openpgp/test
+ org/bouncycastle/openpgp/examples/test
+ )
+ rm -rv "${RM_TEST_FILES[@]}" || die
+ fi
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+}
+
+src_test() {
+ local cp="${PN}.jar:bcprov.jar:junit.jar"
+ local pkg="org.bouncycastle"
+ java -cp ${cp} ${pkg}.openpgp.test.AllTests | tee openpgp.tests
+ grep -q FAILURES *.tests && die "Tests failed."
+}
+
+src_install() {
+ einstalldocs
+ java-pkg-simple_src_install
+ use source && java-pkg_dosrc org
+}
diff --git a/dev-java/bcpg/bcpg-1.52-r1.ebuild b/dev-java/bcpg/bcpg-1.52-r1.ebuild
new file mode 100644
index 000000000000..74354a732de7
--- /dev/null
+++ b/dev-java/bcpg/bcpg-1.52-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="${PN}-jdk15on-${PV/./}"
+
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="http://www.bouncycastle.org/java.html"
+SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="1.52"
+KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+# Tests are currently broken. Appears to need older version of bcprov; but since bcprov is not slotted, this can cause conflicts.
+# Needs further investigation; though, only a small part has tests and there are no tests for bcpg itself.
+RESTRICT="test"
+
+CDEPEND="dev-java/bcprov:${SLOT}"
+
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ test? (
+ dev-java/ant-junit:0
+ )
+ ${CDEPEND}"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+JAVA_GENTOO_CLASSPATH="bcprov-${SLOT}"
+
+src_unpack() {
+ default
+ cd "${S}"
+ unpack ./src.zip
+}
+
+java_prepare() {
+ if ! use test; then
+ local RM_TEST_FILES=(
+ org/bouncycastle/openpgp/test
+ org/bouncycastle/openpgp/examples/test
+ )
+ rm -rf "${RM_TEST_FILES[@]}" || die
+ fi
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+}
+
+src_test() {
+ local cp="${PN}.jar:bcprov.jar:junit.jar"
+ local pkg="org.bouncycastle"
+ java -cp ${cp} ${pkg}.openpgp.test.AllTests | tee openpgp.tests
+ grep -q FAILURES *.tests && die "Tests failed."
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ use source && java-pkg_dosrc org
+}
diff --git a/dev-java/bcpg/bcpg-1.52-r2.ebuild b/dev-java/bcpg/bcpg-1.52-r2.ebuild
new file mode 100644
index 000000000000..a819a8dcd7e9
--- /dev/null
+++ b/dev-java/bcpg/bcpg-1.52-r2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="${PN}-jdk15on-${PV/./}"
+
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="http://www.bouncycastle.org/java.html"
+SRC_URI="http://polydistortion.net/bc/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="1.52"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+# Tests are currently broken. Appears to need older version of bcprov; but
+# since bcprov is not slotted, this can cause conflicts. Needs further
+# investigation; though, only a small part has tests and there are no tests for
+# bcpg itself.
+RESTRICT="test"
+
+CDEPEND="dev-java/bcprov:${SLOT}"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6
+ test? ( dev-java/ant-junit:0 )"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+S="${WORKDIR}/${MY_P}"
+
+JAVA_GENTOO_CLASSPATH="bcprov-${SLOT}"
+
+src_unpack() {
+ default
+ cd "${S}" || die
+ unpack ./src.zip
+}
+
+src_prepare() {
+ default
+ if ! use test; then
+ local RM_TEST_FILES=(
+ org/bouncycastle/openpgp/test
+ org/bouncycastle/openpgp/examples/test
+ )
+ rm -rv "${RM_TEST_FILES[@]}" || die
+ fi
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+}
+
+src_test() {
+ local cp="${PN}.jar:bcprov.jar:junit.jar"
+ local pkg="org.bouncycastle"
+ java -cp ${cp} ${pkg}.openpgp.test.AllTests | tee openpgp.tests
+ grep -q FAILURES *.tests && die "Tests failed."
+}
+
+src_install() {
+ einstalldocs
+ java-pkg-simple_src_install
+ use source && java-pkg_dosrc org
+}
diff --git a/dev-java/bcpg/metadata.xml b/dev-java/bcpg/metadata.xml
new file mode 100644
index 000000000000..952a4b9b605c
--- /dev/null
+++ b/dev-java/bcpg/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+</pkgmetadata>