summaryrefslogtreecommitdiff
path: root/dev-java/bcpg/bcpg-1.50-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-java/bcpg/bcpg-1.50-r1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/bcpg/bcpg-1.50-r1.ebuild')
-rw-r--r--dev-java/bcpg/bcpg-1.50-r1.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/dev-java/bcpg/bcpg-1.50-r1.ebuild b/dev-java/bcpg/bcpg-1.50-r1.ebuild
deleted file mode 100644
index b895d1674885..000000000000
--- a/dev-java/bcpg/bcpg-1.50-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-pkg-simple
-
-MY_P="${PN}-jdk15on-${PV/./}"
-
-DESCRIPTION="Java cryptography APIs"
-HOMEPAGE="http://www.bouncycastle.org/java.html"
-SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="1.50"
-KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-# Tests are currently broken. Appears to need older version of bcprov; but since bcprov is not slotted, this can cause conflicts.
-# Needs further investigation; though, only a small part has tests and there are no tests for bcpg itself.
-RESTRICT="test"
-
-CDEPEND="dev-java/bcprov:${SLOT}"
-
-DEPEND=">=virtual/jdk-1.6
- app-arch/unzip
- test? (
- dev-java/ant-junit:0
- )
- ${CDEPEND}"
-
-RDEPEND=">=virtual/jre-1.6
- ${CDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-JAVA_GENTOO_CLASSPATH="bcprov-${SLOT}"
-
-src_unpack() {
- default
- cd "${S}"
- unpack ./src.zip
-}
-
-java_prepare() {
- if ! use test; then
- local RM_TEST_FILES=(
- org/bouncycastle/openpgp/test
- org/bouncycastle/openpgp/examples/test
- )
- rm -rf "${RM_TEST_FILES[@]}" || die
- fi
-}
-
-src_compile() {
- java-pkg-simple_src_compile
-}
-
-src_test() {
- local cp="${PN}.jar:bcprov.jar:junit.jar"
- local pkg="org.bouncycastle"
- java -cp ${cp} ${pkg}.openpgp.test.AllTests | tee openpgp.tests
- grep -q FAILURES *.tests && die "Tests failed."
-}
-
-src_install() {
- java-pkg-simple_src_install
- use source && java-pkg_dosrc org
-}