summaryrefslogtreecommitdiff
path: root/dev-java/antlr-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-java/antlr-runtime
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-java/antlr-runtime')
-rw-r--r--dev-java/antlr-runtime/Manifest4
-rw-r--r--dev-java/antlr-runtime/antlr-runtime-3.5.2.ebuild2
-rw-r--r--dev-java/antlr-runtime/antlr-runtime-4.9.3.ebuild37
3 files changed, 41 insertions, 2 deletions
diff --git a/dev-java/antlr-runtime/Manifest b/dev-java/antlr-runtime/Manifest
index d4e17964331a..c0cc4328b691 100644
--- a/dev-java/antlr-runtime/Manifest
+++ b/dev-java/antlr-runtime/Manifest
@@ -1,3 +1,5 @@
+DIST antlr-4.9.3.tar.gz 4640242 BLAKE2B fb58f5e533051cb2c439c32f0462c1d463c99df862ba7e1a37a1c61378ab36a9edb9525c2a342de5b517da6f02d8291de5976c550932314f3464aad1a778afb9 SHA512 61452404c9639b5a0908cda16605f17c0fed0c9adfc3278c7408f9971420e9d1fe8f9e974e0826c2e3e780fdd83324094c0246cd5b28fa63f5686b094ea08127
DIST antlr-runtime-3.5.2-sources.jar 206095 BLAKE2B 62b5ca08b13b80e1cdfe82d7354f75dcd3d82d7618bb2d20c4973c0b588d60cc034a8bc265d1cba6b3fc09f5583450a48948dc0beb86c4b13c6b9fdb32de37fd SHA512 fda8b0b1d6f779098c885360ea5f5e93eac5153f5bf761f3dbc954209b69b76edd21a8e4915bb9e567e5c095f1d173e19429bea34da9698bf241d17599858847
-EBUILD antlr-runtime-3.5.2.ebuild 1016 BLAKE2B 9a6e1c257499efad2c9c25488ef5e3707c863ce5660888763b9f29e7c5fec55fb26b698bfe791440fe42356dc3f0262294f7afa70105ae328096e136772a3e68 SHA512 bd128a0a0a6e7746154cb9e1da027f7a35a77941d35e263852859a0b080e9710bed143cb86e8c2ceb00db4af72885fddfb8d34a238c2aef8da87535a98d95f61
+EBUILD antlr-runtime-3.5.2.ebuild 1012 BLAKE2B 4bca36c4491f8e88fd31a8c270737d868b30465e7068db823a354e9dd0d611b19799101cdf448581e4551740f88f70708451f92c93ee9443eb6aab5b6c75e8b7 SHA512 1517b4284e15876a4a4c6dde04ea45410bb20b95f6a5d86c49f6c545bf48d774fcba54ff65a41ed585f440fe2e1f30fc96ab1b29061740e18727f4fd7b35b7d6
+EBUILD antlr-runtime-4.9.3.ebuild 929 BLAKE2B af9f6572ff15703e27f59e03cf151c0dc4c06bcfbcb95cb6a75b7d3162e9d538c502adc03d0bcc148bd56d0b1b3d636c8ab94a22058b91b7467538fbb7093581 SHA512 a577027d78dd7b091187f018e39444db8083417cb8d9beb273ef03862c7fe26de2a1422b2caae9bb62d1bbda194146f67a61091a4ff279f8703cd061cfc353cc
MISC metadata.xml 402 BLAKE2B 8a48b0d50a6356a3bf1f8f2545269d5d21b75af4ba38b07dea53d5660216a8580f5c87b58dc6c235c79f7b5d15f7e4f6925105a2402f557413cf942d21153686 SHA512 26faab37f0c4c1c44000705ee08ec536c6503b70d972b353fcebbd48236688f3d7b5604b2db55753a9b38ac5b86a2d214a937cc68676e1356bec00045cacfe2b
diff --git a/dev-java/antlr-runtime/antlr-runtime-3.5.2.ebuild b/dev-java/antlr-runtime/antlr-runtime-3.5.2.ebuild
index 27593c24d267..036aa905f922 100644
--- a/dev-java/antlr-runtime/antlr-runtime-3.5.2.ebuild
+++ b/dev-java/antlr-runtime/antlr-runtime-3.5.2.ebuild
@@ -17,7 +17,7 @@ SRC_URI="https://repo1.maven.org/maven2/org/antlr/${PN}/${PV}/${P}-sources.jar"
LICENSE="BSD"
SLOT="3.5"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm arm64 ppc64 x86"
# Common dependencies
# POM: ${P}.pom
diff --git a/dev-java/antlr-runtime/antlr-runtime-4.9.3.ebuild b/dev-java/antlr-runtime/antlr-runtime-4.9.3.ebuild
new file mode 100644
index 000000000000..31d041e6a974
--- /dev/null
+++ b/dev-java/antlr-runtime/antlr-runtime-4.9.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Without annotation processing using runtime-testsuite/processors,
+# the tests are bound to fail. However, the annotation processor
+# has been dropped from the 'master' branch as of January 2022, so
+# when updating this package to a new upstream version, please
+# check if it is possible to enable the tests and pass them.
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.antlr:antlr4-runtime:4.9.3"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="${PN%-runtime}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="ANTLR 4 Runtime"
+HOMEPAGE="https://www.antlr.org/"
+SRC_URI="https://github.com/antlr/antlr4/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="4"
+KEYWORDS="amd64 ~arm arm64 ppc64 x86"
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+S="${WORKDIR}/${MY_PN}4-${PV}"
+
+JAVA_SRC_DIR="runtime/Java/src"