summaryrefslogtreecommitdiff
path: root/dev-haskell/zlib/zlib-0.6.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
commitfd70f5e3ed54d5e013c11a3f3e632e80838171d0 (patch)
treec6bf0dac8239e644ccc09b184e4eb9cca9701dcf /dev-haskell/zlib/zlib-0.6.2.3.ebuild
parent5deadca7219297a3c1f90eca00544a00e33efdbc (diff)
gentoo auto-resync : 23:07:2022 - 02:48:51
Diffstat (limited to 'dev-haskell/zlib/zlib-0.6.2.3.ebuild')
-rw-r--r--dev-haskell/zlib/zlib-0.6.2.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/zlib/zlib-0.6.2.3.ebuild b/dev-haskell/zlib/zlib-0.6.2.3.ebuild
new file mode 100644
index 000000000000..47fa30ed782a
--- /dev/null
+++ b/dev-haskell/zlib/zlib-0.6.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: +pkg-config
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Compression and decompression in the gzip and zlib formats"
+HOMEPAGE="https://hackage.haskell.org/package/zlib"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~ppc-macos"
+IUSE="bundled-c-zlib non-blocking-ffi"
+
+RDEPEND=">=dev-lang/ghc-8.4.3:=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ virtual/pkgconfig
+ test? ( >=dev-haskell/quickcheck-2 <dev-haskell/quickcheck-3
+ >=dev-haskell/tasty-0.8 <dev-haskell/tasty-1.5
+ >=dev-haskell/tasty-hunit-0.8 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.11 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag bundled-c-zlib bundled-c-zlib) \
+ $(cabal_flag non-blocking-ffi non-blocking-ffi) \
+ --flag=pkg-config
+}