summaryrefslogtreecommitdiff
path: root/dev-haskell/zip-archive
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/zip-archive
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/zip-archive')
-rw-r--r--dev-haskell/zip-archive/Manifest5
-rw-r--r--dev-haskell/zip-archive/metadata.xml18
-rw-r--r--dev-haskell/zip-archive/zip-archive-0.1.3.4.ebuild35
-rw-r--r--dev-haskell/zip-archive/zip-archive-0.2.3.7.ebuild37
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-haskell/zip-archive/Manifest b/dev-haskell/zip-archive/Manifest
new file mode 100644
index 000000000000..2fd138c1620d
--- /dev/null
+++ b/dev-haskell/zip-archive/Manifest
@@ -0,0 +1,5 @@
+DIST zip-archive-0.1.3.4.tar.gz 11250 BLAKE2B 830cce7d1600b66833e53584da68b07bfbb0417e9a752bedeca02b436e287ce187477851660d426104f392b6e508409a79abb70b0c781523100d7d547a155e4a SHA512 8476041bd3674a42c3777c54243037162d3fdf6f8e0c0bcb9577a4cd76a41d6d9dbdddc482845256858b284bd2bb6ad06cce8208c5584e60553ae659386f8165
+DIST zip-archive-0.2.3.7.tar.gz 12902 BLAKE2B a9b5563034cebb36c604752691950577996bf04e33bafd449019b08532f99635959502b4147ecf8e282d5a9379e6f09d2d2fe730579595e4d2991c152dcbe836 SHA512 3849a9ac806d69b496bfd2973ba8908b981cd72f900565fc9aea8a2b4080ec7c6fe8c579158c22da0ddc398faecf77a7ae1793eecf4d3054d0bdc06fde2aa7cc
+EBUILD zip-archive-0.1.3.4.ebuild 940 BLAKE2B 4b14c4be3762f89da61e6b613a3bbeeaa86734caabf5defb592e536d40156d586be89d58da1dcf3254025407e2f3e62643aa405ac8de16d406f119aaa03d29eb SHA512 e2207e5097df551220c3c23fc333aa6bd0ff7d0f2eb9f74aad7bf19757dfdc3b8aa5fdfbd5a61a442412fcd7c78ad4f9761ade5b9c76083f38decc86592db497
+EBUILD zip-archive-0.2.3.7.ebuild 963 BLAKE2B ba2ad5b538786e6dc7d08ca984ac0cba51ee05965607695412e1a58f34175b2a9957db9f85d5721461279bbcc8e7c5589edde0c3d59d705d0a6228d305d11a19 SHA512 93d51a4aca842cfed74abf13386a22ab19904f9c6486477c343912bbc2be13d5581ba1df999bf44448e5fd9ecdfc7f4496da2a09fd2ea4c3db5e2e38399a190a
+MISC metadata.xml 554 BLAKE2B c174354f44b6718bb8fe11bd45e5ab1474362828356539197f38160104c2589fcfddd691d120294d65f14a1a7659c5777f018e96b1cbddb9aa952e688c3c119d SHA512 0dd9cdbf572293e8e8aef46bc393c2cdb672b09170e383bc1a18100275061369abb875d38a8d00a7da5a7babe45ea827d551e19e49053649daad9fdd4201e5cb
diff --git a/dev-haskell/zip-archive/metadata.xml b/dev-haskell/zip-archive/metadata.xml
new file mode 100644
index 000000000000..3f1368b5d4f1
--- /dev/null
+++ b/dev-haskell/zip-archive/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ The zip-archive library provides functions for creating, modifying,
+ and extracting files from zip archives.
+ </longdescription>
+ <use>
+ <flag name="executable">Build the Zip executable.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">jgm/zip-archive</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/zip-archive/zip-archive-0.1.3.4.ebuild b/dev-haskell/zip-archive/zip-archive-0.1.3.4.ebuild
new file mode 100644
index 000000000000..eb02969ae28c
--- /dev/null
+++ b/dev-haskell/zip-archive/zip-archive-0.1.3.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Library for creating and modifying zip archives"
+HOMEPAGE="https://github.com/jgm/zip-archive"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="executable"
+
+RDEPEND=">=dev-haskell/binary-0.5:=[profile?]
+ >=dev-haskell/digest-0.0.0.1:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/utf8-string-0.3.1:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-7.0.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/hunit
+ app-arch/zip
+ )"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable)
+}
diff --git a/dev-haskell/zip-archive/zip-archive-0.2.3.7.ebuild b/dev-haskell/zip-archive/zip-archive-0.2.3.7.ebuild
new file mode 100644
index 000000000000..8b1de9acd6b8
--- /dev/null
+++ b/dev-haskell/zip-archive/zip-archive-0.2.3.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Library for creating and modifying zip archives"
+HOMEPAGE="https://github.com/jgm/zip-archive"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="executable"
+
+RDEPEND=">=dev-haskell/binary-0.5:=[profile?]
+ >=dev-haskell/digest-0.0.0.1:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/old-time:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( app-arch/zip
+ dev-haskell/hunit )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable)
+}