summaryrefslogtreecommitdiff
path: root/dev-haskell/yesod-json/yesod-json-1.1.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/yesod-json/yesod-json-1.1.2.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/yesod-json/yesod-json-1.1.2.2.ebuild')
-rw-r--r--dev-haskell/yesod-json/yesod-json-1.1.2.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/yesod-json/yesod-json-1.1.2.2.ebuild b/dev-haskell/yesod-json/yesod-json-1.1.2.2.ebuild
new file mode 100644
index 000000000000..5a50b662d84d
--- /dev/null
+++ b/dev-haskell/yesod-json/yesod-json-1.1.2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generate content for Yesod using the aeson package"
+HOMEPAGE="https://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.5:=[profile?]
+ >=dev-haskell/attoparsec-conduit-0.5:=[profile?]
+ dev-haskell/blaze-builder:=[profile?]
+ >=dev-haskell/conduit-0.5:=[profile?]
+ >=dev-haskell/safe-0.2:=[profile?]
+ >=dev-haskell/shakespeare-js-1.0:=[profile?]
+ >=dev-haskell/text-0.8:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?]
+ >=dev-haskell/wai-1.3:=[profile?]
+ >=dev-haskell/wai-extra-1.3:=[profile?]
+ >=dev-haskell/yesod-core-1.1:=[profile?]
+ >=dev-haskell/yesod-routes-1.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hspec
+ dev-haskell/wai-test
+ )"