summaryrefslogtreecommitdiff
path: root/dev-haskell/witherable
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-23 08:50:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-23 08:50:16 +0100
commit34efeba333bb7b35b450c57f2045c933b84bd252 (patch)
tree86c991fd2ec812228e134e90c5eac088e50dfa18 /dev-haskell/witherable
parentfd70f5e3ed54d5e013c11a3f3e632e80838171d0 (diff)
gentoo auto-resync : 23:07:2022 - 08:50:15
Diffstat (limited to 'dev-haskell/witherable')
-rw-r--r--dev-haskell/witherable/Manifest4
-rw-r--r--dev-haskell/witherable/metadata.xml8
-rw-r--r--dev-haskell/witherable/witherable-0.4.2.ebuild48
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-haskell/witherable/Manifest b/dev-haskell/witherable/Manifest
new file mode 100644
index 000000000000..561f14e3964b
--- /dev/null
+++ b/dev-haskell/witherable/Manifest
@@ -0,0 +1,4 @@
+DIST witherable-0.4.2-rev2.cabal 2285 BLAKE2B 973c4d8502b8f4441b6d0bc9d8684f9a5bb750b89868bf393c27c3eef0a36de548821891b0745df804efc6d7f0f75bf41e5a101cf5d461e52824e687b5261e60 SHA512 839310a6771e4a1de5241528c5ff78de78b0ddb22597c30059cae1cb79ec9d3779f90ef345eed96eab7907e41a83ca73a9a0ce25185e57a3bc282d8704827e3b
+DIST witherable-0.4.2.tar.gz 11876 BLAKE2B 58294fc66aa0e60cbb3a75b73ddc89ed3bb64ba62c2a462028afdfe0a86c219cb80db8a008c6abd9c5688fb684c05f2156dd51c796efd586a1a2f72a30ca7e7e SHA512 14ad590e24b93fc25f16fecaf71d6f9f891a903dd76e052d9f6c21b464f0d28df4f019d33ac36086341a6c5bd20833d7b0c2d19543460d1530899c0c25cea852
+EBUILD witherable-0.4.2.ebuild 1695 BLAKE2B fe60266ebb53d2f63601bf6b8ad1aa07e67888fd65b551e9dbd11cc4ad8145e2ecb999b568f0db16c9367a169ad7eeb409f6bbc6f5329367b9141f749861218a SHA512 26ff2b5e8c4b2d4eecfad7964b370f3e40625518fce125aaba8e278b822da7aeb46cd88b8589b3499cd24b71c0c0dfa361b95d3999b823d1dc34da96f9555074
+MISC metadata.xml 250 BLAKE2B 3adf9597d5114c480b4cc9fb5c3e231d8475b795cd6dce77986e13583ab6e59b43857cf2328570490abef0062a8b8a6b73d231867f9b62124855515cdc044d6d SHA512 5ef2c1d34a3438b39a38c041d45bb06bd0f1ae8a3f8b971bd5aaf36dee560f380e9abefab0c2a4cd7b518e151f5c6a0d0c7cd53caee9a384818f1bdc7deeadc4
diff --git a/dev-haskell/witherable/metadata.xml b/dev-haskell/witherable/metadata.xml
new file mode 100644
index 000000000000..937381521944
--- /dev/null
+++ b/dev-haskell/witherable/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-haskell/witherable/witherable-0.4.2.ebuild b/dev-haskell/witherable/witherable-0.4.2.ebuild
new file mode 100644
index 000000000000..ef6c8606c917
--- /dev/null
+++ b/dev-haskell/witherable/witherable-0.4.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+CABAL_HACKAGE_REVISION="2"
+inherit haskell-cabal
+
+DESCRIPTION="filterable traversable"
+HOMEPAGE="https://github.com/fumieval/witherable"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal
+ -> ${P}-rev${CABAL_HACKAGE_REVISION}.cabal"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/base-orphans-0.8.4:=[profile?] <dev-haskell/base-orphans-0.9:=[profile?]
+ >=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-haskell/indexed-traversable-0.1.1:=[profile?] <dev-haskell/indexed-traversable-0.2:=[profile?]
+ >=dev-haskell/indexed-traversable-instances-0.1:=[profile?] <dev-haskell/indexed-traversable-instances-0.2:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.12.0:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.12.2.0:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.4
+ test? ( >=dev-haskell/quickcheck-2.14.2
+ dev-haskell/quickcheck-instances
+ dev-haskell/tasty
+ dev-haskell/tasty-quickcheck )
+"
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${P}-rev${CABAL_HACKAGE_REVISION}.cabal" "${S}/${PN}.cabal" || die
+
+ # Convert to unix line endings
+ dos2unix "${S}/${PN}.cabal" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}