summaryrefslogtreecommitdiff
path: root/dev-haskell/vector
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
commit407525b571b48cfd65e1ad7a02d250a927c967c9 (patch)
tree844bea44d85dc7218f54970af1c42cc9d55c3f1a /dev-haskell/vector
parent89c6c06b8c42107dd231687a1012354e7d3039fc (diff)
gentoo resync : 01.12.2017
Diffstat (limited to 'dev-haskell/vector')
-rw-r--r--dev-haskell/vector/Manifest2
-rw-r--r--dev-haskell/vector/metadata.xml56
2 files changed, 27 insertions, 31 deletions
diff --git a/dev-haskell/vector/Manifest b/dev-haskell/vector/Manifest
index 1bbfa96be529..033f0d127c9e 100644
--- a/dev-haskell/vector/Manifest
+++ b/dev-haskell/vector/Manifest
@@ -3,4 +3,4 @@ DIST vector-0.10.12.3.tar.gz 103617 BLAKE2B cd4a4fda8a3da5b431c316d04b23eb82947f
DIST vector-0.11.0.0.tar.gz 115558 BLAKE2B e2475a37593b92f896c48ff85f6e506fb5011d89173bb0fe12492ed8c6f9620f426c9db88cbc274b37aade52bf6ca3cbdc7cf03b013371b37f2d1b42c348a117 SHA512 4f31e45d08a08c09e5ce73cca4da70e954bf3921d05130b9458c7f2ba267602e0aafc96496595000fd7b82f80aa9147c880917dc64086dab7bf5b2cd426539e0
EBUILD vector-0.10.12.3.ebuild 1592 BLAKE2B 418bc7d6570795fc008f735ae306cd6173255c19da9602030142f75fc803d75c1e36c4a075080593476bce55d223a89b31fc829800fbbde2807c537034267871 SHA512 6257d68861966ec6768d435239179b8cc9d35cea0023085392c87b6a0be620bc7577d74911ece596d1d2b0f19e6974cad8c08b7155056bef472a3deeffd614c3
EBUILD vector-0.11.0.0.ebuild 1401 BLAKE2B c963221760f2ef6ecd59bd57307d1cfdd92b4d460262730894aa00b8226ed5c8c918ce656d987cf5469724fdff2b6c4e176d428c0d49778343ed2a273aa6bef7 SHA512 e23c6b4371a9f9c662192fae3e832c783c92fa40a64131cb6391946398df256bc308cfdccd88b55847bf23260c4052387ae7ba50fb794c9fa2fa6cc6f241e3a8
-MISC metadata.xml 2517 BLAKE2B 64fcf88b270829bdab5aced6250360a8c4be4e7f3e224592c64015ef6a85d18ec894493a58324b00478ecb48f9503692eca098ee3d8e3207a697e7d01b4ed30f SHA512 a2d7060a6e3db9c5748f892469929a6dd852cad6869a29555bfd9105b069b927fb1d9d0ab4ad8c7884b88a9d67a8cf2c493d3b1f6ddc1cc8c9f4bfac65993389
+MISC metadata.xml 2431 BLAKE2B ab4b371c0626e51fa792aa18b7a7622921ea12a7b76d8855441865f46372a3dfa11fd0d0acdafb11983b614b6733325a28711d149660d3e0d874fe24754cf7c4 SHA512 58c6d75396f364fa29acf4287a1411448c2a77f5589be30fc83bdde998773f15c5d5a4fd7e6e95b5454c33ad49aa367a6b557c445612f85f99924520825002ba
diff --git a/dev-haskell/vector/metadata.xml b/dev-haskell/vector/metadata.xml
index 8d7aed4adc3b..fac2f4dc8e54 100644
--- a/dev-haskell/vector/metadata.xml
+++ b/dev-haskell/vector/metadata.xml
@@ -6,72 +6,68 @@
<name>Gentoo Haskell</name>
</maintainer>
<longdescription>
-
An efficient implementation of Int-indexed arrays (both mutable
and immutable), with a powerful loop optimisation framework .
-
+
It is structured as follows:
-
+
["Data.Vector"] Boxed vectors of arbitrary types.
-
+
["Data.Vector.Unboxed"] Unboxed vectors with an adaptive
representation based on data type families.
-
+
["Data.Vector.Storable"] Unboxed vectors of 'Storable' types.
-
+
["Data.Vector.Primitive"] Unboxed vectors of primitive types as
defined by the @primitive@ package. "Data.Vector.Unboxed" is more
flexible at no performance cost.
-
+
["Data.Vector.Generic"] Generic interface to the vector types.
-
+
Each module has a @Safe@ version with is marked as @Trustworthy@
(see &lt;http://hackage.haskell.org/trac/ghc/wiki/SafeHaskell&gt;).
-
+
There is also a (draft) tutorial on common uses of vector.
-
+
* &lt;http://haskell.org/haskellwiki/Numeric_Haskell:_A_Vector_Tutorial&gt;
-
+
Please use the project trac to submit bug reports and feature
requests.
-
+
* &lt;http://trac.haskell.org/vector&gt;
-
+
Changes in version 0.9
-
+
* 'MonadPlus' instance for boxed vectors
-
+
* Export more @construct@ and @constructN@ from @Safe@ modules
-
+
* Require @primitive-0.4.0.1@
-
+
Changes in version 0.8
-
+
* New functions: @constructN@, @constructrN@
-
+
* Support for GHC 7.2 array copying primitives
-
+
* New fixity for @(!)@
-
+
* Safe Haskell support (contributed by David Terei)
-
+
* 'Functor', 'Monad', 'Applicative', 'Alternative', 'Foldable' and
'Traversable' instances for boxed vectors
(/WARNING: they tend to be slow and are only provided for completeness/)
-
+
* 'Show' instances for immutable vectors follow containers conventions
-
+
* 'Read' instances for all immutable vector types
-
+
* Performance improvements
-
</longdescription>
<use>
<flag name="boundschecks">Enable bounds checking</flag>
- <flag name="internalchecks">Enable internal consistency checks at the cost of a
- significant performance penalty</flag>
- <flag name="unsafechecks">Enable bounds checking in unsafe operations at the cost of a
- significant performance penalty</flag>
+ <flag name="internalchecks">Enable internal consistency checks at the cost of a significant performance penalty</flag>
+ <flag name="unsafechecks">Enable bounds checking in unsafe operations at the cost of a significant performance penalty</flag>
</use>
<upstream>
<remote-id type="github">haskell/vector</remote-id>