summaryrefslogtreecommitdiff
path: root/dev-haskell/vector
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-haskell/vector
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/vector')
-rw-r--r--dev-haskell/vector/Manifest6
-rw-r--r--dev-haskell/vector/files/vector-0.11.0.0-primitive-0.6.2.0.patch21
-rw-r--r--dev-haskell/vector/metadata.xml75
-rw-r--r--dev-haskell/vector/vector-0.10.12.3.ebuild53
-rw-r--r--dev-haskell/vector/vector-0.11.0.0.ebuild50
5 files changed, 0 insertions, 205 deletions
diff --git a/dev-haskell/vector/Manifest b/dev-haskell/vector/Manifest
deleted file mode 100644
index 033f0d127c9e..000000000000
--- a/dev-haskell/vector/Manifest
+++ /dev/null
@@ -1,6 +0,0 @@
-AUX vector-0.11.0.0-primitive-0.6.2.0.patch 753 BLAKE2B 1117ef087b476dc7a35bdf4286d980a9be438c71ab6d08f0219b03a714859ea30c444b983ec04b03e297a8100cca37c6f64f75167c55a002c8767899b0b47e72 SHA512 09cf5972b6d7ae61fe87246df675229c73c37c8d510b1e56e6ffce4d445fa75578efdbaba26c7cda23d588f68c75ea9f27a854f2d5e0cba00e6c8bdd515eeada
-DIST vector-0.10.12.3.tar.gz 103617 BLAKE2B cd4a4fda8a3da5b431c316d04b23eb82947f08cc930059beb3182c9c68d646c6a767168ae2fd82d06a782991b055421a0558dbf41a1e92f06d265c043cdb2048 SHA512 2b2c98f1fbaaf4f5e7243e18a08e373e85acb06dddf73a48d34b966bfd736efc72880babec9c47859bd8d6d6928a28ac9acd9134eb0ef61b2f88fa31bf18811b
-DIST vector-0.11.0.0.tar.gz 115558 BLAKE2B e2475a37593b92f896c48ff85f6e506fb5011d89173bb0fe12492ed8c6f9620f426c9db88cbc274b37aade52bf6ca3cbdc7cf03b013371b37f2d1b42c348a117 SHA512 4f31e45d08a08c09e5ce73cca4da70e954bf3921d05130b9458c7f2ba267602e0aafc96496595000fd7b82f80aa9147c880917dc64086dab7bf5b2cd426539e0
-EBUILD vector-0.10.12.3.ebuild 1592 BLAKE2B 418bc7d6570795fc008f735ae306cd6173255c19da9602030142f75fc803d75c1e36c4a075080593476bce55d223a89b31fc829800fbbde2807c537034267871 SHA512 6257d68861966ec6768d435239179b8cc9d35cea0023085392c87b6a0be620bc7577d74911ece596d1d2b0f19e6974cad8c08b7155056bef472a3deeffd614c3
-EBUILD vector-0.11.0.0.ebuild 1401 BLAKE2B c963221760f2ef6ecd59bd57307d1cfdd92b4d460262730894aa00b8226ed5c8c918ce656d987cf5469724fdff2b6c4e176d428c0d49778343ed2a273aa6bef7 SHA512 e23c6b4371a9f9c662192fae3e832c783c92fa40a64131cb6391946398df256bc308cfdccd88b55847bf23260c4052387ae7ba50fb794c9fa2fa6cc6f241e3a8
-MISC metadata.xml 2431 BLAKE2B ab4b371c0626e51fa792aa18b7a7622921ea12a7b76d8855441865f46372a3dfa11fd0d0acdafb11983b614b6733325a28711d149660d3e0d874fe24754cf7c4 SHA512 58c6d75396f364fa29acf4287a1411448c2a77f5589be30fc83bdde998773f15c5d5a4fd7e6e95b5454c33ad49aa367a6b557c445612f85f99924520825002ba
diff --git a/dev-haskell/vector/files/vector-0.11.0.0-primitive-0.6.2.0.patch b/dev-haskell/vector/files/vector-0.11.0.0-primitive-0.6.2.0.patch
deleted file mode 100644
index 3b78ad74efc3..000000000000
--- a/dev-haskell/vector/files/vector-0.11.0.0-primitive-0.6.2.0.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/Data/Vector.hs b/Data/Vector.hs
-index db6dfb7..f074bf0 100644
---- a/Data/Vector.hs
-+++ b/Data/Vector.hs
-@@ -152,3 +152,3 @@ module Data.Vector (
- -- ** Lists
-- toList, fromList, fromListN,
-+ toList, Data.Vector.fromList, Data.Vector.fromListN,
-
-@@ -222,4 +222,4 @@ instance Exts.IsList (Vector a) where
- type Item (Vector a) = a
-- fromList = fromList
-- fromListN = fromListN
-+ fromList = Data.Vector.fromList
-+ fromListN = Data.Vector.fromListN
- toList = toList
-@@ -343,3 +343,3 @@ instance Traversable.Traversable Vector where
- {-# INLINE traverse #-}
-- traverse f xs = fromList Applicative.<$> Traversable.traverse f (toList xs)
-+ traverse f xs = Data.Vector.fromList Applicative.<$> Traversable.traverse f (toList xs)
-
diff --git a/dev-haskell/vector/metadata.xml b/dev-haskell/vector/metadata.xml
deleted file mode 100644
index fac2f4dc8e54..000000000000
--- a/dev-haskell/vector/metadata.xml
+++ /dev/null
@@ -1,75 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- An efficient implementation of Int-indexed arrays (both mutable
- and immutable), with a powerful loop optimisation framework .
-
- It is structured as follows:
-
- ["Data.Vector"] Boxed vectors of arbitrary types.
-
- ["Data.Vector.Unboxed"] Unboxed vectors with an adaptive
- representation based on data type families.
-
- ["Data.Vector.Storable"] Unboxed vectors of 'Storable' types.
-
- ["Data.Vector.Primitive"] Unboxed vectors of primitive types as
- defined by the @primitive@ package. "Data.Vector.Unboxed" is more
- flexible at no performance cost.
-
- ["Data.Vector.Generic"] Generic interface to the vector types.
-
- Each module has a @Safe@ version with is marked as @Trustworthy@
- (see &lt;http://hackage.haskell.org/trac/ghc/wiki/SafeHaskell&gt;).
-
- There is also a (draft) tutorial on common uses of vector.
-
- * &lt;http://haskell.org/haskellwiki/Numeric_Haskell:_A_Vector_Tutorial&gt;
-
- Please use the project trac to submit bug reports and feature
- requests.
-
- * &lt;http://trac.haskell.org/vector&gt;
-
- Changes in version 0.9
-
- * 'MonadPlus' instance for boxed vectors
-
- * Export more @construct@ and @constructN@ from @Safe@ modules
-
- * Require @primitive-0.4.0.1@
-
- Changes in version 0.8
-
- * New functions: @constructN@, @constructrN@
-
- * Support for GHC 7.2 array copying primitives
-
- * New fixity for @(!)@
-
- * Safe Haskell support (contributed by David Terei)
-
- * 'Functor', 'Monad', 'Applicative', 'Alternative', 'Foldable' and
- 'Traversable' instances for boxed vectors
- (/WARNING: they tend to be slow and are only provided for completeness/)
-
- * 'Show' instances for immutable vectors follow containers conventions
-
- * 'Read' instances for all immutable vector types
-
- * Performance improvements
- </longdescription>
- <use>
- <flag name="boundschecks">Enable bounds checking</flag>
- <flag name="internalchecks">Enable internal consistency checks at the cost of a significant performance penalty</flag>
- <flag name="unsafechecks">Enable bounds checking in unsafe operations at the cost of a significant performance penalty</flag>
- </use>
- <upstream>
- <remote-id type="github">haskell/vector</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-haskell/vector/vector-0.10.12.3.ebuild b/dev-haskell/vector/vector-0.10.12.3.ebuild
deleted file mode 100644
index 056efaa250b0..000000000000
--- a/dev-haskell/vector/vector-0.10.12.3.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.3
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Efficient Arrays"
-HOMEPAGE="https://github.com/haskell/vector"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE="+boundschecks internalchecks unsafechecks"
-
-RDEPEND=">=dev-haskell/primitive-0.5.0.1:=[profile?] <dev-haskell/primitive-0.7:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10
- test? ( >=dev-haskell/quickcheck-2.7 <dev-haskell/quickcheck-2.9
- dev-haskell/random
- dev-haskell/test-framework
- dev-haskell/test-framework-quickcheck2
- >=dev-haskell/transformers-0.2.0.0 )
-"
-
-src_prepare() {
- local can_spec_const="yes"
-
- cabal_chdeps \
- "QuickCheck >= 2.7 && < 2.8" "QuickCheck >= 2.7 && < 2.9"
-
- ghc-supports-interpreter || can_spec_const="no"
-
- # ghci-less GHC can't do ANN #482960
- if [[ ${can_spec_const} == "no" ]]; then
- einfo "Disabling 'ForceSpecConstr' due to bug #482960"
- sed -e 's/{-# ANN type SPEC ForceSpecConstr #-}/{- # ANN type SPEC ForceSpecConstr #-}/' \
- -i Data/Vector/Fusion/Stream/Monadic.hs || die
- fi
-}
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag boundschecks boundschecks) \
- $(cabal_flag internalchecks internalchecks) \
- $(cabal_flag unsafechecks unsafechecks)
-}
diff --git a/dev-haskell/vector/vector-0.11.0.0.ebuild b/dev-haskell/vector/vector-0.11.0.0.ebuild
deleted file mode 100644
index f27cf913c98b..000000000000
--- a/dev-haskell/vector/vector-0.11.0.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# ebuild generated by hackport 0.4.6.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Efficient Arrays"
-HOMEPAGE="https://github.com/haskell/vector"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE="+boundschecks internalchecks unsafechecks"
-
-RESTRICT=test # -O2 -g makes tests build hang
-
-RDEPEND=">=dev-haskell/primitive-0.5.0.1:=[profile?] <dev-haskell/primitive-0.7:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10
- test? ( >=dev-haskell/quickcheck-2.7
- dev-haskell/random
- dev-haskell/test-framework
- dev-haskell/test-framework-quickcheck2
- >=dev-haskell/transformers-0.2.0.0 )
-"
-
-PATCHES=("${FILESDIR}"/${P}-primitive-0.6.2.0.patch)
-
-src_prepare() {
- default
-
- cabal_chdeps \
- "QuickCheck >= 2.7 && < 2.8" "QuickCheck >= 2.7" \
- 'base >= 4.3 && < 4.9' 'base >= 4.3' \
- 'ghc-prim >= 0.2 && < 0.5' 'ghc-prim >= 0.2'
-}
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag boundschecks boundschecks) \
- $(cabal_flag internalchecks internalchecks) \
- $(cabal_flag unsafechecks unsafechecks)
-}