summaryrefslogtreecommitdiff
path: root/dev-haskell/uuid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/uuid
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/uuid')
-rw-r--r--dev-haskell/uuid/Manifest5
-rw-r--r--dev-haskell/uuid/metadata.xml3
-rw-r--r--dev-haskell/uuid/uuid-1.3.15-r1.ebuild42
-rw-r--r--dev-haskell/uuid/uuid-1.3.15.ebuild36
4 files changed, 47 insertions, 39 deletions
diff --git a/dev-haskell/uuid/Manifest b/dev-haskell/uuid/Manifest
index d231c4c5ebe0..b703706b595d 100644
--- a/dev-haskell/uuid/Manifest
+++ b/dev-haskell/uuid/Manifest
@@ -1,3 +1,4 @@
+DIST uuid-1.3.15-rev2.cabal 2642 BLAKE2B db44dabaa7962207d089fb79db6781e4387fb1958366e938125ec95d79125fc277fe1167a0aab2d133441c95a70953cee5ab30b4a1811bfd5c6733f178239ed5 SHA512 cb8a0aa11945375d175de2c48c710ef0f423d38fa4960ef91050e04038a402b38f532e25d5f56ecd715513dbb05da25922744ffde51edd8bb99b55985c9342be
DIST uuid-1.3.15.tar.gz 8815 BLAKE2B fec665690dc6fe05e9b7083700ca5ba2723d9bbd7cdc7f8770359d26b9b4b32572e15b686bc4589a3bed2cd25caa02cbea96270ea2e373941451aa6f315df401 SHA512 acb5c17b809bee5ce2f1591f3382a7c3a57e9d20a47d8f47be717b0e7fbfd803603810ebaaf88597bcf98dff698f4807dc7d8122a0d7d36785a47e0e065fb59e
-EBUILD uuid-1.3.15.ebuild 1499 BLAKE2B b70a5cbd169775a742849c7904d351049e923580f9b0f6c1f1319dc1b9f367bc7f91bee8de83537c7bb985e121d27b768b9d5f937893142451d53ab9118bd52f SHA512 a7b66f42e73202500a4491c3939e291a319274bfaa5b77473d4c0693960d4b7ee9a247d5fa45c1f1cf68ce01f2e95b184e2915d52c33dbad35772f09faa1f009
-MISC metadata.xml 328 BLAKE2B 28dc31dfc087b15e03a61a12ed766c5fe3ed9d328e8f6f461618c235cba25c3032df539920164bf31ab04ccc376c1d02815723a2d560b817bdb6533cbe9aea3b SHA512 996a273983ea1f004269779e07d8f6d0591d382980dfa8d734b4852d43e93b6b6323778342a2f9cd3072e6f1001f117b4a1be770a86b31c03e8951b48d987014
+EBUILD uuid-1.3.15-r1.ebuild 1273 BLAKE2B 9edde4fdbd08db3873c6ecf5f158e6e4c1b6fa42c27c24ee0c872879d3bba6543761d1f99a2b7f40121b967b45922984481160cbf66172986a420e58fcba1d6b SHA512 06ed23fd037476eb609ff416d0e2707fca89cd3a7ae47579bf9987db097d9afeecbbf5cb4a2eb7c253699e5e53ebe6ef10f78da3011d5c8d397186996507999c
+MISC metadata.xml 376 BLAKE2B d204d11a52b4b6342b96d506c0a5f2440731e183007d77fe9b8f5540b1465a33dfd2856dcd88d140c1df4d0b727f94ab57937633487593ecc7193b9ea4cf8a9a SHA512 1f695175b9e03ca9d7d6434c52522aa0e121cd7ac4bcdab7ea75302c832c131ca521d49c92b11fc74c4147af0e42a2699f37375c27d1b3c9160bd86083420b32
diff --git a/dev-haskell/uuid/metadata.xml b/dev-haskell/uuid/metadata.xml
index 8bd9ed7a20bf..5626c2e65497 100644
--- a/dev-haskell/uuid/metadata.xml
+++ b/dev-haskell/uuid/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Haskell</name>
</maintainer>
<upstream>
- <remote-id type="github">aslatter/uuid</remote-id>
+ <remote-id type="hackage">uuid</remote-id>
+ <remote-id type="github">haskell-hvr/uuid</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/uuid/uuid-1.3.15-r1.ebuild b/dev-haskell/uuid/uuid-1.3.15-r1.ebuild
new file mode 100644
index 000000000000..679ee0de762c
--- /dev/null
+++ b/dev-haskell/uuid/uuid-1.3.15-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_HACKAGE_REVISION=2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="For creating, comparing, parsing and printing Universally Unique Identifiers"
+HOMEPAGE="https://github.com/haskell-hvr/uuid"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/cryptohash-md5-0.11.100:=[profile?] <dev-haskell/cryptohash-md5-0.12
+ >=dev-haskell/cryptohash-sha1-0.11.100:=[profile?] <dev-haskell/cryptohash-sha1-0.12
+ >=dev-haskell/entropy-0.3.7:=[profile?] <dev-haskell/entropy-0.5
+ =dev-haskell/network-info-0.2*:=[profile?]
+ >=dev-haskell/random-1.1:=[profile?] <dev-haskell/random-1.3
+ =dev-haskell/uuid-types-1.0.5*:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ || (
+ ( >=dev-haskell/text-1.2.3.0 <dev-haskell/text-1.3 )
+ =dev-haskell/text-2.0*
+ )
+ dev-haskell/text:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ >=dev-haskell/quickcheck-2.14.2 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/tasty-1.4.0.1 <dev-haskell/tasty-1.5
+ =dev-haskell/tasty-hunit-0.10*
+ =dev-haskell/tasty-quickcheck-0.10*
+ )
+"
diff --git a/dev-haskell/uuid/uuid-1.3.15.ebuild b/dev-haskell/uuid/uuid-1.3.15.ebuild
deleted file mode 100644
index 86d31756c2da..000000000000
--- a/dev-haskell/uuid/uuid-1.3.15.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# ebuild generated by hackport 0.7.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite has too new tasty
-inherit haskell-cabal
-
-DESCRIPTION="For creating, comparing, parsing and printing Universally Unique Identifiers"
-HOMEPAGE="https://github.com/haskell-hvr/uuid"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
-
-RESTRICT=test
-
-RDEPEND=">=dev-haskell/cryptohash-md5-0.11.100:=[profile?] <dev-haskell/cryptohash-md5-0.12:=[profile?]
- >=dev-haskell/cryptohash-sha1-0.11.100:=[profile?] <dev-haskell/cryptohash-sha1-0.12:=[profile?]
- >=dev-haskell/entropy-0.3.7:=[profile?] <dev-haskell/entropy-0.5:=[profile?]
- >=dev-haskell/network-info-0.2:=[profile?] <dev-haskell/network-info-0.3:=[profile?]
- >=dev-haskell/random-1.1:=[profile?] <dev-haskell/random-1.3:=[profile?]
- >=dev-haskell/uuid-types-1.0.5:=[profile?] <dev-haskell/uuid-types-1.0.6:=[profile?]
- >=dev-lang/ghc-8.4.3:=
- >=dev-haskell/text-1.2.3.0:=[profile?] <dev-haskell/text-2.1:=[profile?]
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.2.0.1"
-# test? ( >=dev-haskell/quickcheck-2.14.2 <dev-haskell/quickcheck-2.15
-# >=dev-haskell/tasty-1.4.0.1 <dev-haskell/tasty-1.5
-# >=dev-haskell/tasty-hunit-0.10 <dev-haskell/tasty-hunit-0.11
-# >=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11 )
-# "