summaryrefslogtreecommitdiff
path: root/dev-haskell/utf8-string
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/utf8-string
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/utf8-string')
-rw-r--r--dev-haskell/utf8-string/Manifest5
-rw-r--r--dev-haskell/utf8-string/metadata.xml10
-rw-r--r--dev-haskell/utf8-string/utf8-string-0.3.8.ebuild29
-rw-r--r--dev-haskell/utf8-string/utf8-string-1.0.1.1.ebuild29
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-haskell/utf8-string/Manifest b/dev-haskell/utf8-string/Manifest
new file mode 100644
index 000000000000..124194df93f5
--- /dev/null
+++ b/dev-haskell/utf8-string/Manifest
@@ -0,0 +1,5 @@
+DIST utf8-string-0.3.8.tar.gz 9129 BLAKE2B 9ee624a9a1258b19134ac63e6b15fbb71a17e03e78be49c464c3c76eeaf2f052c65f8df360900a1e9badb31d7f27059aa33642e6244bd665e62519abe663065a SHA512 70f6ceaf4d9d6e6fe7b787facbb733f276ac5ba10c49c43e0da283b481f0579e0933f6343f5158973a6f0aac342f5b76258281dbd0c420bf652ad3c3787eb1fb
+DIST utf8-string-1.0.1.1.tar.gz 8667 BLAKE2B db2f899e0f78e44700cec859fd71982024e05f971ab5fef36071410c207a23dce1fa7430ce6cdeefdb5b2c28509eb5848946e2207e046ab7a4105c56e25fce16 SHA512 2dd647625478c9738b3af5e23e1e5ff92968449ad74e6d53dc308fa0f2b08b63c421a1cbe5491dd260b9b32770ec626843d320a09b80eb984211dba53934b965
+EBUILD utf8-string-0.3.8.ebuild 691 BLAKE2B bfaab36dc35a91e2411de2bf2776d558bbaa182d931749fc684dcc3c0679d07dfc6189ad5ba67410cd7db1a2e96daeeb08dcded0ff5f8819f0067211eb30632e SHA512 49789d1ad0591842a25882a56e77a8011e146487cf3677226cc9b793ef056758dd84028ce65d8783a5e9dcdeca438f498d4adb99eab3267e6938666ed5398ba6
+EBUILD utf8-string-1.0.1.1.ebuild 704 BLAKE2B 65cd6bcdd233920b1770287469f5a92d2dbb0c39cd03465b39e5388d39ff252c285a47bedc143e1df37ea2167d571e7252ffd593bfae54732350d7ae8e0b1821 SHA512 5a76578650b05a51bd653134d867f79704707e40366167a26f4e0b537104ad3d6f7ebc3f22704511f7bb2e4c4d8fd01927a0ff35c79dbfa278e0d150e3cd51c0
+MISC metadata.xml 309 BLAKE2B 41ec5100a1fe355f798d48894322ecf00bc7802fac10222f95e96674335f9537e23f04c37bddc1e1cdec7728b33c3a6d3781dbaf2be464fc5643b0468e1ec4d8 SHA512 ce8b570dcd924d3409d3dd5c2d27601799b30ba8a166f502d262b66d02c63f5110bbcf92fb5ad5a610a68d4a97cd55a70bf5730d17a2a590a0df83d4e00c2deb
diff --git a/dev-haskell/utf8-string/metadata.xml b/dev-haskell/utf8-string/metadata.xml
new file mode 100644
index 000000000000..91873f17286f
--- /dev/null
+++ b/dev-haskell/utf8-string/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">glguy/utf8-string</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/utf8-string/utf8-string-0.3.8.ebuild b/dev-haskell/utf8-string/utf8-string-0.3.8.ebuild
new file mode 100644
index 000000000000..127cba44d0c7
--- /dev/null
+++ b/dev-haskell/utf8-string/utf8-string-0.3.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Support for reading and writing UTF8 Strings"
+HOMEPAGE="https://github.com/glguy/utf8-string/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'base >= 3 && < 4.8' 'base >= 3'
+}
diff --git a/dev-haskell/utf8-string/utf8-string-1.0.1.1.ebuild b/dev-haskell/utf8-string/utf8-string-1.0.1.1.ebuild
new file mode 100644
index 000000000000..3435d32f2ec0
--- /dev/null
+++ b/dev-haskell/utf8-string/utf8-string-1.0.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Support for reading and writing UTF8 Strings"
+HOMEPAGE="https://github.com/glguy/utf8-string/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'base >= 4.3 && < 4.9' 'base >= 4.3'
+}