summaryrefslogtreecommitdiff
path: root/dev-haskell/uri-bytestring
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/uri-bytestring
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/uri-bytestring')
-rw-r--r--dev-haskell/uri-bytestring/Manifest3
-rw-r--r--dev-haskell/uri-bytestring/metadata.xml14
-rw-r--r--dev-haskell/uri-bytestring/uri-bytestring-0.2.2.1.ebuild41
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-haskell/uri-bytestring/Manifest b/dev-haskell/uri-bytestring/Manifest
new file mode 100644
index 000000000000..43a0f765db52
--- /dev/null
+++ b/dev-haskell/uri-bytestring/Manifest
@@ -0,0 +1,3 @@
+DIST uri-bytestring-0.2.2.1.tar.gz 20755 SHA256 9185e8f05d5c5154348c0d57d0df2b92ba6d09153fbdebded995b2f54e71c67e SHA512 d540722657b80039de25a6893067ea8fa50228420725ea22b95a6b7fb3e99803e41b18006b307973fd38fe5ba58d611d3115d1b677e3a36c38168b92289fee97 WHIRLPOOL 6067dd4e279839e95cb7a972133590612ef64cfeee100b6b339fba7e75779c06d4e8c6edf099189f3014abbfb1d6bf522a2bbd6fbec61477fcca7e372f74c822
+EBUILD uri-bytestring-0.2.2.1.ebuild 1091 SHA256 504074dcf4560564b21b4fbdb26b6a5ea94c24d2ca9e865e10c89bcc7a460de7 SHA512 23875303ea0a540ef864e0f754f29b8f86e7dcc4e0a9ff823c6afa2c2efb980b199c13e0ff976b6132ec704611e964bb6b005ec2be23ed3902478067c1c0175a WHIRLPOOL 53cc4b988a7a033e1b0d37d72893c96de7fa41af0c633c977d28518439dbcb1cb087b8bcac6ffd98ee46763fdfaa8370f2c2df6f1b97f81894da10a18df8f978
+MISC metadata.xml 511 SHA256 f429abd0d77d8b602e81b316ac36f2c9b396c2e85845b89f52fb149a3cab230c SHA512 d21aadfa0df81fe2542de2a92f94fe055c0040e5c963d33bbdab5a8a2da085b64788f4141fad8ddf6c5e0959c275ae650be95298e7a984e7535045503b257a42 WHIRLPOOL 9a2bc87cdb88285836b55cfc4d80cc68b3245fef386c2b0e608374872e89ab18834de1804d66f038b707827017e927a266cb80578eab74e7a8e2850fa15aedd7
diff --git a/dev-haskell/uri-bytestring/metadata.xml b/dev-haskell/uri-bytestring/metadata.xml
new file mode 100644
index 000000000000..16a771dc5920
--- /dev/null
+++ b/dev-haskell/uri-bytestring/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ uri-bytestring aims to be an RFC3986 compliant URI parser that uses efficient ByteStrings for parsing and representing the URI data.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Soostone/uri-bytestring</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/uri-bytestring/uri-bytestring-0.2.2.1.ebuild b/dev-haskell/uri-bytestring/uri-bytestring-0.2.2.1.ebuild
new file mode 100644
index 000000000000..4c8313e17e44
--- /dev/null
+++ b/dev-haskell/uri-bytestring/uri-bytestring-0.2.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: -lib-werror
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell URI parsing as ByteStrings"
+HOMEPAGE="https://github.com/Soostone/uri-bytestring"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.12:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ >=dev-haskell/blaze-builder-0.3.0.0:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/generics-sop-0.2
+ dev-haskell/hunit
+ dev-haskell/lens-simple
+ dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances
+ dev-haskell/semigroups
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-lib-werror
+}