summaryrefslogtreecommitdiff
path: root/dev-haskell/uniqueid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/uniqueid
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/uniqueid')
-rw-r--r--dev-haskell/uniqueid/Manifest4
-rw-r--r--dev-haskell/uniqueid/files/uniqueid-0.1.1-ghc-7.8.patch46
-rw-r--r--dev-haskell/uniqueid/metadata.xml18
-rw-r--r--dev-haskell/uniqueid/uniqueid-0.1.1.ebuild26
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-haskell/uniqueid/Manifest b/dev-haskell/uniqueid/Manifest
new file mode 100644
index 000000000000..b5ac27f07d8a
--- /dev/null
+++ b/dev-haskell/uniqueid/Manifest
@@ -0,0 +1,4 @@
+AUX uniqueid-0.1.1-ghc-7.8.patch 1383 BLAKE2B 92ea3035b38b4f86559fff85d346940cd9f2222e4ef2e922128b14051db2b48ac70531146289bcd7a526d8498ab6f9440f1a8a4b6e38d5b3a88353f80a4acdec SHA512 2cb2bc04bc8ee52279ec953ed1435411d4715dec009012d191bd07df4ccd334ca4a60be123d00bf9a74a8f9e94e01b2fcea0c0692fdcf77c7d7a0c5d7b0948e5
+DIST uniqueid-0.1.1.tar.gz 2779 BLAKE2B 73ad9af177f20575caaefb12261d58801a391bfcbaa6b8ef1596538fd7536ec8b6aa35997277a39454250bc779c4c6174b1b3e7853bad5cc21d9ed72764ce517 SHA512 4a1f753a320a5ddae8dd47c3e3729144cf28effaaa6f16a8cf13ad614e4aba3f720f82025f86d7c04ae5c28d03825b4d3442caa01cd534dfa05a70c6c9cadc68
+EBUILD uniqueid-0.1.1.ebuild 612 BLAKE2B 8376f2a0d435428a811478463769faaa3290dfc3cf407d28a22056da8d7576c34565bbc0dc3772a9ca76710ccec4e4284fe4961043adcbd5503ba72156bad224 SHA512 d2f59d6c18195d618eaaaef78e64f0fe058f398640ac9ed37579bd2c13f1baa1aec1252223b1ed787dda049f7b29a20a369ca20c5b7afb858b5a26163f06a380
+MISC metadata.xml 628 BLAKE2B 57879a83e3a6279bde5c6061154b7c35f62ff4bb0e6272c8b3f31fde6fadcc5673c19dfd74e5220ea4e0f448b316f76feb4a0e1bfb594ca35d216ca4b86ea758 SHA512 1f422717c439530df37fcad80a491643d1f9754eb130acdff4991a1f0e98a87db6c43bea2eea5ad1837aefe251a492085730773aae68f2a3de9c7a48aaa43e83
diff --git a/dev-haskell/uniqueid/files/uniqueid-0.1.1-ghc-7.8.patch b/dev-haskell/uniqueid/files/uniqueid-0.1.1-ghc-7.8.patch
new file mode 100644
index 000000000000..a48815ecda0e
--- /dev/null
+++ b/dev-haskell/uniqueid/files/uniqueid-0.1.1-ghc-7.8.patch
@@ -0,0 +1,46 @@
+diff --git a/Data/Unique/Id.hs b/Data/Unique/Id.hs
+index f41127e..56853d9 100644
+--- a/Data/Unique/Id.hs
++++ b/Data/Unique/Id.hs
+@@ -14,7 +14,7 @@ module Data.Unique.Id (
+ ) where
+
+ import GHC.Exts
+-import GHC.IOBase ( unsafeDupableInterleaveIO )
++import GHC.IO ( unsafeDupableInterleaveIO )
+
+ import Data.IORef
+ import System.IO.Unsafe ( unsafePerformIO )
+@@ -55,15 +55,15 @@ splitIdSupplyL ids = ids1 : splitIdSupplyL ids2
+ idFromSupply :: IdSupply -> Id
+ idFromSupply (IdSupply n _ _) = Id (I# n)
+
+-instance Eq Id where Id (I# x) == Id (I# y) = x ==# y
++instance Eq Id where Id (I# x) == Id (I# y) = isTrue# (x ==# y)
+
+ instance Ord Id
+ where
+- Id (I# x) < Id (I# y) = x <# y
+- Id (I# x) <= Id (I# y) = x <=# y
++ Id (I# x) < Id (I# y) = isTrue# (x <# y)
++ Id (I# x) <= Id (I# y) = isTrue# (x <=# y)
+
+ compare (Id (I# x)) (Id (I# y)) =
+- if x ==# y then EQ else if x <# y then LT else GT
++ if isTrue# (x ==# y) then EQ else if isTrue# (x <# y) then LT else GT
+
+ instance Show Id
+ where
+diff --git a/uniqueid.cabal b/uniqueid.cabal
+index 8099520..83aaa39 100644
+--- a/uniqueid.cabal
++++ b/uniqueid.cabal
+@@ -18,7 +18,7 @@ Build-Type: Simple
+ Stability: experimental
+
+ Library
+- Build-Depends: base >= 3 && < 5
++ Build-Depends: base >= 3 && < 5, ghc-prim
+ Exposed-Modules: Data.Unique.Id
+ Extensions: MagicHash
+ Ghc-Options: -Wall
diff --git a/dev-haskell/uniqueid/metadata.xml b/dev-haskell/uniqueid/metadata.xml
new file mode 100644
index 000000000000..12547a354095
--- /dev/null
+++ b/dev-haskell/uniqueid/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package provides splittable supplies of unique
+ identifiers. The implementation mimics (only) essential
+ parts of the code that is used internally in GHC for
+ the same purpose. After improvements of the value-supply
+ package it is now deprecated.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">sebfisch/uniqueid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/uniqueid/uniqueid-0.1.1.ebuild b/dev-haskell/uniqueid/uniqueid-0.1.1.ebuild
new file mode 100644
index 000000000000..89a693e9b6c9
--- /dev/null
+++ b/dev-haskell/uniqueid/uniqueid-0.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+DESCRIPTION="Splittable Unique Identifier Supply"
+HOMEPAGE="https://github.com/sebfisch/uniqueid/wikis"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.8.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.8.patch
+}