summaryrefslogtreecommitdiff
path: root/dev-haskell/uniplate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/uniplate
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/uniplate')
-rw-r--r--dev-haskell/uniplate/Manifest3
-rw-r--r--dev-haskell/uniplate/metadata.xml38
-rw-r--r--dev-haskell/uniplate/uniplate-1.6.12.ebuild34
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-haskell/uniplate/Manifest b/dev-haskell/uniplate/Manifest
new file mode 100644
index 000000000000..69341dec7f4a
--- /dev/null
+++ b/dev-haskell/uniplate/Manifest
@@ -0,0 +1,3 @@
+DIST uniplate-1.6.12.tar.gz 30055 BLAKE2B 557c3eeb14c0b292d4e0325a711babec39a76829822aee07e38ee49f7a4c3f82e72e6231c00fad1c7831864a7df4a9e12b3e913b60fe0e227d651d39c73300af SHA512 049b07e8a57db7e44d91fc9c8dcfb5c49b78a692a730061763cb8bcc4fbc3ed1065bd7a4c337e3d344693df882a0718b6d3bb6a6ea1e7d520a36d252d7038b07
+EBUILD uniplate-1.6.12.ebuild 944 BLAKE2B adc59c98510ddd9a3f778a2a81bb29bc7b1c8154e884d011636e30e72f4d210736f0f305fc93d97058555ea78cb633a6c1bd541ac898464848caed932dc1fe12 SHA512 ce4958e139d1c6060aafd56f2adb5296890a90050028604f51bb45b6ab9bc1605d8c47f428bbc1933a440bdcdf9d847d4829cd15eade5f4bda676afa6715808f
+MISC metadata.xml 1613 BLAKE2B 635834b68d6f154f689302e4713069a66dc6165e2f78c8d2dc5be80919db983be9fada67cfe6961321658130b8da8cee13300c72d9ce9a0c61ae91ce04e567d2 SHA512 d29dfda9d4b53863b51928c40ccf25a6082f150a054fe9da9d48cf462fdf181d90e1b19b19312b72421b68637c8593481beaedf1d28e95278bf567151948dad9
diff --git a/dev-haskell/uniplate/metadata.xml b/dev-haskell/uniplate/metadata.xml
new file mode 100644
index 000000000000..fd8349c40e4b
--- /dev/null
+++ b/dev-haskell/uniplate/metadata.xml
@@ -0,0 +1,38 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Uniplate is library for writing simple and concise generic operations.
+ Uniplate has similar goals to the original Scrap Your Boilerplate work,
+ but is substantially simpler and faster. The Uniplate manual is available at
+ &lt;http://community.haskell.org/~ndm/darcs/uniplate/uniplate.htm&gt;.
+
+ To get started with Uniplate you should import one of the three following
+ modules:
+
+ * "Data.Generics.Uniplate.Data" - to quickly start writing generic functions.
+ Most users should start by importing this module.
+
+ * "Data.Generics.Uniplate.Direct" - a replacement for "Data.Generics.Uniplate.Data"
+ with substantially higher performance (around 5 times), but requires writing
+ instance declarations.
+
+ * "Data.Generics.Uniplate.Operations" - definitions of all the operations defined
+ by Uniplate. Both the above two modules re-export this module.
+
+ In addition, some users may want to make use of the following modules:
+
+ * "Data.Generics.Uniplate.Zipper" - a zipper built on top of Uniplate instances.
+
+ * "Data.Generics.SYB" - users transitioning from the Scrap Your Boilerplate library.
+
+ * "Data.Generics.Compos" - users transitioning from the Compos library.
+
+ * "Data.Generics.Uniplate.DataOnly" - users making use of both @Data@ and @Direct@
+ to avoid getting instance conflicts.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/uniplate/uniplate-1.6.12.ebuild b/dev-haskell/uniplate/uniplate-1.6.12.ebuild
new file mode 100644
index 000000000000..fb5353dc4319
--- /dev/null
+++ b/dev-haskell/uniplate/uniplate-1.6.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: +separate_syb,+typeable_fingerprint
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Help writing simple, concise and fast generic operations"
+HOMEPAGE="http://community.haskell.org/~ndm/uniplate/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hashable-1.1.2.3:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ dev-haskell/syb:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.1:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=separate_syb \
+ --flag=typeable_fingerprint
+}