summaryrefslogtreecommitdiff
path: root/dev-haskell/uniplate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/uniplate
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/uniplate')
-rw-r--r--dev-haskell/uniplate/Manifest5
-rw-r--r--dev-haskell/uniplate/metadata.xml38
-rw-r--r--dev-haskell/uniplate/uniplate-1.6.12.ebuild34
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-haskell/uniplate/Manifest b/dev-haskell/uniplate/Manifest
new file mode 100644
index 000000000000..a47868250d91
--- /dev/null
+++ b/dev-haskell/uniplate/Manifest
@@ -0,0 +1,5 @@
+DIST uniplate-1.6.12.tar.gz 30055 SHA256 fcc60bc6b3f6e925f611646db90e6db9f05286a9363405f844df1dc15572a8b7 SHA512 049b07e8a57db7e44d91fc9c8dcfb5c49b78a692a730061763cb8bcc4fbc3ed1065bd7a4c337e3d344693df882a0718b6d3bb6a6ea1e7d520a36d252d7038b07 WHIRLPOOL d44c14e7c913496ff3d7802847e265efc29e1cc4283887268c86230f24e59f93e435ffa4f16ee6c081cd9bbfffbba4d351c3f7e5688697c2e6a8098ba037d722
+EBUILD uniplate-1.6.12.ebuild 944 SHA256 a352a03f3188bbae7542fbd1ab45d083a50da0ef8dfeaf77b5da16e911aa413d SHA512 ce4958e139d1c6060aafd56f2adb5296890a90050028604f51bb45b6ab9bc1605d8c47f428bbc1933a440bdcdf9d847d4829cd15eade5f4bda676afa6715808f WHIRLPOOL e48d78ec4e1b108a4e6e42fffde7656fdbe06bbf62d22d70ad3fbd297941cf2bf615591ea1f16e02e4dcbec759bfc824e3ab4c4c392eeed6cec4f7ffde4f05b6
+MISC ChangeLog 2966 SHA256 b324616595e945813f4eab096ef6f0f812ca8f13c8f795d54f6eeeadb427a69d SHA512 4c1c21015c59132c48e92cd13c45f4d3296df610b14df484f62f8106012ccbdea01b34d874de21aed6c0e620b1b6b1352a8396dde9bb7bc168dccc4eef479c8e WHIRLPOOL 6b7af7e05036c84344c0889585985e5f304a78b7790b12e92bf2419df52a07b60f43d4fca1958d25bc3a856eed76435c3a3d22383a2458eb4aa7b064d9f54e83
+MISC ChangeLog-2015 704 SHA256 926d4cd8964b67983c53fdcb4caa54872d3b0db7d316e00f1b5b78ec71fcc8cb SHA512 833954271e4fda815c541943c85fe3480663732b4aad64d7f756e050f11e125c8336dacb2f8a10189ae5c7a6fa007c5e6b16da2107dc111e073f37e206c414ea WHIRLPOOL d5a8ab9a49b8988adf63dfb30d4444eb1282253539827a47847fade774c90185d4968f10b23e409a6da71507873e846df31375eaf27b5449fdcee9be25e38f1d
+MISC metadata.xml 1613 SHA256 1fc63e26e9828e9c4506b560a03ead11e9c8b4c4a11d042da1cbed6163ed0e55 SHA512 d29dfda9d4b53863b51928c40ccf25a6082f150a054fe9da9d48cf462fdf181d90e1b19b19312b72421b68637c8593481beaedf1d28e95278bf567151948dad9 WHIRLPOOL cfd768e6e87892bb952132650b750afd46dd7f8ee439596e21e0b7f60fd76a110a3984fd0b7a73db55719d1a99edc2bcedfd886e965fcfedaa14fe8aa8c0ce2d
diff --git a/dev-haskell/uniplate/metadata.xml b/dev-haskell/uniplate/metadata.xml
new file mode 100644
index 000000000000..fd8349c40e4b
--- /dev/null
+++ b/dev-haskell/uniplate/metadata.xml
@@ -0,0 +1,38 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Uniplate is library for writing simple and concise generic operations.
+ Uniplate has similar goals to the original Scrap Your Boilerplate work,
+ but is substantially simpler and faster. The Uniplate manual is available at
+ &lt;http://community.haskell.org/~ndm/darcs/uniplate/uniplate.htm&gt;.
+
+ To get started with Uniplate you should import one of the three following
+ modules:
+
+ * "Data.Generics.Uniplate.Data" - to quickly start writing generic functions.
+ Most users should start by importing this module.
+
+ * "Data.Generics.Uniplate.Direct" - a replacement for "Data.Generics.Uniplate.Data"
+ with substantially higher performance (around 5 times), but requires writing
+ instance declarations.
+
+ * "Data.Generics.Uniplate.Operations" - definitions of all the operations defined
+ by Uniplate. Both the above two modules re-export this module.
+
+ In addition, some users may want to make use of the following modules:
+
+ * "Data.Generics.Uniplate.Zipper" - a zipper built on top of Uniplate instances.
+
+ * "Data.Generics.SYB" - users transitioning from the Scrap Your Boilerplate library.
+
+ * "Data.Generics.Compos" - users transitioning from the Compos library.
+
+ * "Data.Generics.Uniplate.DataOnly" - users making use of both @Data@ and @Direct@
+ to avoid getting instance conflicts.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/uniplate/uniplate-1.6.12.ebuild b/dev-haskell/uniplate/uniplate-1.6.12.ebuild
new file mode 100644
index 000000000000..fb5353dc4319
--- /dev/null
+++ b/dev-haskell/uniplate/uniplate-1.6.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: +separate_syb,+typeable_fingerprint
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Help writing simple, concise and fast generic operations"
+HOMEPAGE="http://community.haskell.org/~ndm/uniplate/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hashable-1.1.2.3:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ dev-haskell/syb:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.1:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=separate_syb \
+ --flag=typeable_fingerprint
+}