summaryrefslogtreecommitdiff
path: root/dev-haskell/trifecta/trifecta-2.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
commitfd70f5e3ed54d5e013c11a3f3e632e80838171d0 (patch)
treec6bf0dac8239e644ccc09b184e4eb9cca9701dcf /dev-haskell/trifecta/trifecta-2.1.2.ebuild
parent5deadca7219297a3c1f90eca00544a00e33efdbc (diff)
gentoo auto-resync : 23:07:2022 - 02:48:51
Diffstat (limited to 'dev-haskell/trifecta/trifecta-2.1.2.ebuild')
-rw-r--r--dev-haskell/trifecta/trifecta-2.1.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/trifecta/trifecta-2.1.2.ebuild b/dev-haskell/trifecta/trifecta-2.1.2.ebuild
new file mode 100644
index 000000000000..494bbaeeb0da
--- /dev/null
+++ b/dev-haskell/trifecta/trifecta-2.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A modern parser combinator library with convenient diagnostics"
+HOMEPAGE="https://github.com/ekmett/trifecta/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.6:=[profile?] <dev-haskell/ansi-terminal-0.12:=[profile?]
+ >=dev-haskell/blaze-builder-0.3.0.1:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/blaze-html-0.9:=[profile?] <dev-haskell/blaze-html-0.10:=[profile?]
+ >=dev-haskell/blaze-markup-0.8:=[profile?] <dev-haskell/blaze-markup-0.9:=[profile?]
+ >=dev-haskell/charset-0.3.5.1:=[profile?] <dev-haskell/charset-1:=[profile?]
+ >=dev-haskell/comonad-5:=[profile?] <dev-haskell/comonad-6:=[profile?]
+ >=dev-haskell/fingertree-0.1:=[profile?] <dev-haskell/fingertree-0.2:=[profile?]
+ >=dev-haskell/hashable-1.2.4:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-haskell/indexed-traversable-0.1.1:=[profile?] <dev-haskell/indexed-traversable-0.2:=[profile?]
+ >=dev-haskell/lens-4.14:=[profile?] <dev-haskell/lens-6:=[profile?]
+ >=dev-haskell/parsers-0.12.1:=[profile?] <dev-haskell/parsers-1:=[profile?]
+ >=dev-haskell/prettyprinter-1.7:=[profile?] <dev-haskell/prettyprinter-2:=[profile?]
+ >=dev-haskell/prettyprinter-ansi-terminal-1.1.2:=[profile?] <dev-haskell/prettyprinter-ansi-terminal-2:=[profile?]
+ >=dev-haskell/profunctors-5.2:=[profile?] <dev-haskell/profunctors-6:=[profile?]
+ >=dev-haskell/reducers-3.12.1:=[profile?] <dev-haskell/reducers-4:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.1:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/utf8-string-0.3.6:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/quickcheck )
+"