summaryrefslogtreecommitdiff
path: root/dev-haskell/timezone-olson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/timezone-olson
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/timezone-olson')
-rw-r--r--dev-haskell/timezone-olson/Manifest4
-rw-r--r--dev-haskell/timezone-olson/metadata.xml21
-rw-r--r--dev-haskell/timezone-olson/timezone-olson-0.1.7-r1.ebuild34
-rw-r--r--dev-haskell/timezone-olson/timezone-olson-0.1.7.ebuild27
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-haskell/timezone-olson/Manifest b/dev-haskell/timezone-olson/Manifest
new file mode 100644
index 000000000000..3703a51a790f
--- /dev/null
+++ b/dev-haskell/timezone-olson/Manifest
@@ -0,0 +1,4 @@
+DIST timezone-olson-0.1.7.tar.gz 11313 BLAKE2B c2bb71f949beac730e9fe9ff6a5aacbe301ffb8012b6e622179a029523784d0f3a2745ff3dd8a86ecb109fed90f44a121a4b5e8f4766bf6061a7233429267221 SHA512 136bca829b40edd3c46f83e2d19b496da7b6e7268825ff017fa598f9dc8a9de5fd65101f417e9c22ae8b845c61c98347944971f8f41072be60d894ea148a4e0a
+EBUILD timezone-olson-0.1.7-r1.ebuild 910 BLAKE2B 66936573e05739b92b9855495f0fbd227dadcd3bddeb2e650f4742b532fc6b7d507235b060b3777d72f1690aa044ff51518deda018c5e6983f628f34ae8d3ed8 SHA512 0d55040a4d9940763d81104b1bcb5b7e4be5ab05861d7dcc65504a5b6fbdb735af928e003fc7fb7b0e8fa299aa29891148bce84600aadeb8886923375a416440
+EBUILD timezone-olson-0.1.7.ebuild 849 BLAKE2B 85304efe9e8551b40542ba84ae2f1b14236381e89405e117fe0c6ca54617496cd64f5801f92c7006435eece6fa7f17e93e021edbd7c172a3b81cf92551cd2e70 SHA512 64e3ef4a64a27a63c86f99a157c8b902a86e7263a44e4b4992f358f2a4afcbdcda52f79aebd073ee107ed7213e6c96067c3633fde1bce7069ec5a717464b949b
+MISC metadata.xml 821 BLAKE2B ad98bfb2a5a5854e2cae7091dca6c206a37dccffa001bed5df75a0f318b200a1571e265042857d1e74abf019deda50557ee655f811737eb63f8a7a67b18f1818 SHA512 1ee91c0270137d4710f9052eadf7f522006108d9d6d2939ae44641d365078daec9671699e09aa69c19d0a8e5e503f1bceb6a0458ef3ca6f123c73bb3f774c2de
diff --git a/dev-haskell/timezone-olson/metadata.xml b/dev-haskell/timezone-olson/metadata.xml
new file mode 100644
index 000000000000..dec7b007d319
--- /dev/null
+++ b/dev-haskell/timezone-olson/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A parser and renderer for binary Olson timezone
+ files whose format is specified by the tzfile(5)
+ man page on Unix-like systems. For more
+ information about this format, see
+ &lt;http://www.twinsun.com/tz/tz-link.htm&gt;. Functions
+ are provided for converting the parsed data into
+ 'TimeZoneSeries' objects from the timezone-series
+ package. On many platforms, binary Olson timezone
+ files suitable for use with this package are
+ available in the directory /usr/share/zoneinfo
+ and its subdirectories on your computer.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/timezone-olson/timezone-olson-0.1.7-r1.ebuild b/dev-haskell/timezone-olson/timezone-olson-0.1.7-r1.ebuild
new file mode 100644
index 000000000000..ea8b76b4ea8e
--- /dev/null
+++ b/dev-haskell/timezone-olson/timezone-olson-0.1.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A pure Haskell parser and renderer for binary Olson timezone files"
+HOMEPAGE="http://projects.haskell.org/time-ng/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/extensible-exceptions-0.1.0:=[profile?] <dev-haskell/extensible-exceptions-0.2:=[profile?]
+ >=dev-haskell/timezone-series-0.1.0:=[profile?] <dev-haskell/timezone-series-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'binary >= 0.4.1 && < 0.8' 'binary >= 0.4.1' \
+ 'time >= 1.1.4 && < 1.6' 'time >= 1.1.4'
+}
diff --git a/dev-haskell/timezone-olson/timezone-olson-0.1.7.ebuild b/dev-haskell/timezone-olson/timezone-olson-0.1.7.ebuild
new file mode 100644
index 000000000000..8e70bf87d783
--- /dev/null
+++ b/dev-haskell/timezone-olson/timezone-olson-0.1.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A pure Haskell parser and renderer for binary Olson timezone files"
+HOMEPAGE="http://projects.haskell.org/time-ng/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/binary-0.4.1:=[profile?] <dev-haskell/binary-0.8:=[profile?]
+ >=dev-haskell/extensible-exceptions-0.1.0:=[profile?] <dev-haskell/extensible-exceptions-0.2:=[profile?]
+ >=dev-haskell/timezone-series-0.1.0:=[profile?] <dev-haskell/timezone-series-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"