summaryrefslogtreecommitdiff
path: root/dev-haskell/threads
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/threads
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/threads')
-rw-r--r--dev-haskell/threads/Manifest3
-rw-r--r--dev-haskell/threads/metadata.xml34
-rw-r--r--dev-haskell/threads/threads-0.5.1.4.ebuild29
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-haskell/threads/Manifest b/dev-haskell/threads/Manifest
new file mode 100644
index 000000000000..4867718ebe24
--- /dev/null
+++ b/dev-haskell/threads/Manifest
@@ -0,0 +1,3 @@
+DIST threads-0.5.1.4.tar.gz 7395 BLAKE2B ca81e06509d5dd9603e6b8affb248eb397040845e0fff26adda91086e08eb2d78982a9342f0d6bb0b3b6aab4ead33b3b26500683e221db60f5833b3ff4c280bd SHA512 4fcce77d88bf5eeb0ef172efec8525327ae11739c89a7d31b775ed686ad943aecb53f8140539262fdc8992b338943e9f905ebf97bc7c01312a12a88ac4c08129
+EBUILD threads-0.5.1.4.ebuild 909 BLAKE2B 10be59723378144f05acae8a262e2c83e632d524afd780eb8dabbc0aa67b87d7ae18649585274911aad0222895d28b5a2c5833fb6f0fb77821e28a3d51fc602a SHA512 dc5e71dd61b09e2d23c69e40d114bac1f2470dde6907faa0c9adeeef7e44fc55d9729b7502dbb0b87876d3f971c8fe5bf79290e8fa941556d4cb1090daf02fe5
+MISC metadata.xml 1018 BLAKE2B 405986db23ff3277088864efb403b7fa20d998c37a75dcc953b6a0c490d442d469843cf856142e43f2a46ac458b1f7bb6c9e8476ac85e1ea7214cda51552c88b SHA512 b50d6d809ae35893296cf851ecf03c5a5b69342eee6db42ef13907afe224b4d46047b4bd68dafcab51e972a7cbff0e28aa6ed2b1123d1fb9d15dc6b512be564d
diff --git a/dev-haskell/threads/metadata.xml b/dev-haskell/threads/metadata.xml
new file mode 100644
index 000000000000..2baf8cca4f23
--- /dev/null
+++ b/dev-haskell/threads/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package provides functions to fork threads and
+ wait for their result, whether it's an exception or a
+ normal value.
+
+ Besides waiting for the termination of a single thread
+ this packages also provides functions to wait for a
+ group of threads to terminate.
+
+ This package is similar to the
+ @threadmanager@, @async@ and @spawn@ packages.
+ The advantages of this package are:
+
+ * Simpler API.
+
+ * More efficient in both space and time.
+
+ * No space-leak when forking a large number of threads.
+
+ * Correct handling of asynchronous exceptions.
+
+ * GHC specific functionality like @forkOn@ and @forkIOWithUnmask@.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">basvandijk/threads</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/threads/threads-0.5.1.4.ebuild b/dev-haskell/threads/threads-0.5.1.4.ebuild
new file mode 100644
index 000000000000..b7c1db28f512
--- /dev/null
+++ b/dev-haskell/threads/threads-0.5.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fork threads and wait for their result"
+HOMEPAGE="https://github.com/basvandijk/threads"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/stm-2.1:=[profile?] <dev-haskell/stm-2.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.9.2
+ test? ( >=dev-haskell/concurrent-extra-0.5.1 <dev-haskell/concurrent-extra-0.8
+ >=dev-haskell/hunit-1.2.2 <dev-haskell/hunit-1.4
+ >=dev-haskell/test-framework-0.2.4 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2.4 <dev-haskell/test-framework-hunit-0.4 )
+"