summaryrefslogtreecommitdiff
path: root/dev-haskell/text-icu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/text-icu
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/text-icu')
-rw-r--r--dev-haskell/text-icu/Manifest3
-rw-r--r--dev-haskell/text-icu/metadata.xml39
-rw-r--r--dev-haskell/text-icu/text-icu-0.7.0.1.ebuild32
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-haskell/text-icu/Manifest b/dev-haskell/text-icu/Manifest
new file mode 100644
index 000000000000..24e028cfd658
--- /dev/null
+++ b/dev-haskell/text-icu/Manifest
@@ -0,0 +1,3 @@
+DIST text-icu-0.7.0.1.tar.gz 45533 BLAKE2B 1eda34ad7a8bcaa26814cb4fdb864e67531aca5dc80ece9a71dd770022ec7729e7e2960729c707ab9b5d4e8ad3b112e50572d26a2f2a573ffd6f3c914a0b5545 SHA512 54551ce0d629bffcca32fc855bfcdf2e24282359ce3a32578a98de4f4ad15378fa7df98c59d73323549a2ac873b10a10202bda02f5be83fbe1ab945aac5e50a9
+EBUILD text-icu-0.7.0.1.ebuild 806 BLAKE2B d30aa4cad290b8aca4715a946ff207f5f33ae384bf7f356b5c0de2eca84f5a85c283be83de6b8d1ff21a035943510fda7904e1d9010f496e88ea8acb9e72d999 SHA512 e62603b7ac3eaf9025717ee2dda9c82d0ca053acb1068771f3d46554e2b3a90c4a6500ff115c31d56e57672519a8da33e23efec5e1982265a7644e4d4ddbcfef
+MISC metadata.xml 1375 BLAKE2B 598c2f18ecd8c76ae5b8de8f9bf78c75e4d185f49e2ca74425b7379240018fcbef5c390bcc23747c919855fa3be2357f7fe8c5367fe3d30aedb7510dbb789f9c SHA512 0ff41b1b72b3cc09947f6937b969a07e98c9d04bb0967cf4feb066c755ea1da415a6138099aff4550cc7423a02d1c5f95a16e865c2c127e3551a62521e05d79f
diff --git a/dev-haskell/text-icu/metadata.xml b/dev-haskell/text-icu/metadata.xml
new file mode 100644
index 000000000000..bf8841a2a444
--- /dev/null
+++ b/dev-haskell/text-icu/metadata.xml
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Haskell bindings to the International Components for Unicode (ICU)
+ libraries. These libraries provide robust and full-featured Unicode
+ services on a wide variety of platforms.
+
+ Features include:
+
+ * Both pure and impure bindings, to allow for fine control over efficiency
+ and ease of use.
+
+ * Breaking of strings on character, word, sentence, and line boundaries.
+
+ * Access to the Unicode Character Database (UCD) of character metadata.
+
+ * String collation functions, for locales where the conventions for
+ lexicographic ordering differ from the simple numeric ordering of
+ character codes.
+
+ * Character set conversion functions, allowing conversion between
+ Unicode and over 220 character encodings.
+
+ * Unicode normalization. (When implementations keep strings in a
+ normalized form, they can be assured that equivalent strings have a
+ unique binary representation.)
+
+ * Regular expression search and replace.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">bos/text-icu</remote-id>
+ <remote-id type="bitbucket">bos/text-icu</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/text-icu/text-icu-0.7.0.1.ebuild b/dev-haskell/text-icu/text-icu-0.7.0.1.ebuild
new file mode 100644
index 000000000000..5ca406411cc3
--- /dev/null
+++ b/dev-haskell/text-icu/text-icu-0.7.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Bindings to the ICU library"
+HOMEPAGE="https://github.com/bos/text-icu"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/text-0.9.1.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ dev-libs/icu:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/hunit-1.2
+ >=dev-haskell/quickcheck-2.4
+ dev-haskell/random
+ >=dev-haskell/test-framework-0.4
+ >=dev-haskell/test-framework-hunit-0.2
+ >=dev-haskell/test-framework-quickcheck2-0.2 )
+"