summaryrefslogtreecommitdiff
path: root/dev-haskell/text-icu/text-icu-0.7.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
commitfd70f5e3ed54d5e013c11a3f3e632e80838171d0 (patch)
treec6bf0dac8239e644ccc09b184e4eb9cca9701dcf /dev-haskell/text-icu/text-icu-0.7.1.0.ebuild
parent5deadca7219297a3c1f90eca00544a00e33efdbc (diff)
gentoo auto-resync : 23:07:2022 - 02:48:51
Diffstat (limited to 'dev-haskell/text-icu/text-icu-0.7.1.0.ebuild')
-rw-r--r--dev-haskell/text-icu/text-icu-0.7.1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/text-icu/text-icu-0.7.1.0.ebuild b/dev-haskell/text-icu/text-icu-0.7.1.0.ebuild
new file mode 100644
index 000000000000..36a69b685a0d
--- /dev/null
+++ b/dev-haskell/text-icu/text-icu-0.7.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Bindings to the ICU library"
+HOMEPAGE="https://github.com/bos/text-icu"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RESTRICT=test # QuickCheck occasionally finds counterexamples
+# and fails to build: Duplicate instance declarations: instance NFData Ordering
+
+RDEPEND=">=dev-haskell/text-0.9.1.0:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ dev-libs/icu
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+# test? ( >=dev-haskell/hunit-1.2
+# >=dev-haskell/quickcheck-2.4
+# dev-haskell/random
+# >=dev-haskell/test-framework-0.4
+# >=dev-haskell/test-framework-hunit-0.2
+# >=dev-haskell/test-framework-quickcheck2-0.2 )
+# "