summaryrefslogtreecommitdiff
path: root/dev-haskell/test-framework-th
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-haskell/test-framework-th
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-haskell/test-framework-th')
-rw-r--r--dev-haskell/test-framework-th/Manifest4
-rw-r--r--dev-haskell/test-framework-th/metadata.xml49
-rw-r--r--dev-haskell/test-framework-th/test-framework-th-0.2.4.ebuild20
3 files changed, 13 insertions, 60 deletions
diff --git a/dev-haskell/test-framework-th/Manifest b/dev-haskell/test-framework-th/Manifest
index fbf4169b1167..0e0e799beda9 100644
--- a/dev-haskell/test-framework-th/Manifest
+++ b/dev-haskell/test-framework-th/Manifest
@@ -1,3 +1,3 @@
DIST test-framework-th-0.2.4.tar.gz 2977 BLAKE2B f43f3f964eecfba401db1fb574ab9ef4bf9b575251a60f196ddd451c23f8c29ea44f90d441eae2f5d923d053061a247820fc0a399e59e1eb088ba31abf38ef44 SHA512 0e8b6898eb7bf481bafb0c9ff9caa615dbf768e538e26b15ab899c5c9a1ad6bd6ed76ef93cf9a823706046d41f49fbb0cbe660bf846e59a608a0e5d21e89686b
-EBUILD test-framework-th-0.2.4.ebuild 760 BLAKE2B d69427c8091d0aaa3515d1d07312dd73d83c3dfefba6f1f5dd57bb56ab3cda71a1113df62db8ba3952f7c24482e2f48f65097b3e7bf6e673935c83a18df8fe33 SHA512 91bc479abbd21808687604a083a45c5d49aae61b2aeed9f8f5d6c8f57fa048c759aed36847b8e421cee3325394ca487e869e623624bc750dfab88cbdefe9a640
-MISC metadata.xml 1980 BLAKE2B 5048d5716f585e4b30b73713b513fb44dac589fa4a9b13a96b659159e412c074d3877d201319a72798119f633b49389d9e1643afc3c9935f5970e685625e464f SHA512 6fa19ea53be7c7dc114c6bdc70b41cd0ebf60c7a25f36cd2035ef7225c1da11e5de7d08eaf1bf41df7d305db5be5f3a26aea089a6a117481fd361ed3d0a2701c
+EBUILD test-framework-th-0.2.4.ebuild 751 BLAKE2B 1ebd22db456c11fc4d6246c98447fefe662b0409a80aff25465931fe67dde5d8fa2d32801bae4dde8b3f1a80702d59ea3651337dd9ae358b0abc8ba2c2b4c6ec SHA512 c8f3652d0d31b4c9d66037049307eb26829cac9d3be118fdc03786d4d867b4feac8bd13180449a51de05aefd0c2b411070a066cafd18f44759326407897218b6
+MISC metadata.xml 249 BLAKE2B 84b809c265ff2a09d1f06c66d4797652ff4c64205d94323e07333ae0fbddcfb8c58d0176a8cc52bd37e9353371d987b9b473b9747cb082e1c2871ed80fcfa144 SHA512 ce055b41ff1c10209e88579fe21ce16550be7e9b21f87724564f06430aa6f478974f186a10c8ff7e92398f534c09109aeed57eae1c6d2b56b5c99ebfb64a0015
diff --git a/dev-haskell/test-framework-th/metadata.xml b/dev-haskell/test-framework-th/metadata.xml
index a8fce2d224aa..b7878815d80d 100644
--- a/dev-haskell/test-framework-th/metadata.xml
+++ b/dev-haskell/test-framework-th/metadata.xml
@@ -5,53 +5,4 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- @test-framework-th@ contains two interesting functions: @defaultMainGenerator@ and @testGroupGenerator@.
-
- @defaultMainGenerator@ will extract all functions beginning with case_ or prop_ in the module and put them in a testGroup.
-
- &gt; -- file SomeModule.hs
- &gt; ( -# LANGUAGE TemplateHaskell #- )
- &gt; module SomeModule where
- &gt; import Test.Framework.TH
- &gt; import Test.Framework
- &gt; import Test.HUnit
- &gt; import Test.Framework.Providers.HUnit
- &gt; import Test.Framework.Providers.QuickCheck2
- &gt;
- &gt; -- observe this line!
- &gt; main = $(defaultMainGenerator)
- &gt; case_1 = do 1 @=? 1
- &gt; case_2 = do 2 @=? 2
- &gt; prop_reverse xs = reverse (reverse xs) == xs
- &gt; where types = xs::[Int]
-
- is the same as
-
- &gt; -- file SomeModule.hs
- &gt; ( -# LANGUAGE TemplateHaskell #- )
- &gt; module SomeModule where
- &gt; import Test.Framework.TH
- &gt; import Test.Framework
- &gt; import Test.HUnit
- &gt; import Test.Framework.Providers.HUnit
- &gt; import Test.Framework.Providers.QuickCheck2
- &gt;
- &gt; -- observe this line!
- &gt; main =
- &gt; defaultMain [
- &gt; testGroup "SomeModule" [ testCase "1" case_1, testCase "2" case_2, testProperty "reverse" prop_reverse]
- &gt; ]
- &gt;
- &gt; case_1 = do 1 @=? 1
- &gt; case_2 = do 2 @=? 2
- &gt; prop_reverse xs = reverse (reverse xs) == xs
- &gt; where types = xs::[Int]
-
- @testGroupGenerator@ is like @defaultMainGenerator@ but without @defaultMain@. It is useful if you need a function for the testgroup
- (e.g. if you want to be able to call the testgroup from another module).
- </longdescription>
- <upstream>
- <remote-id type="github">finnsson/test-generator</remote-id>
- </upstream>
</pkgmetadata>
diff --git a/dev-haskell/test-framework-th/test-framework-th-0.2.4.ebuild b/dev-haskell/test-framework-th/test-framework-th-0.2.4.ebuild
index 812e3653792f..cc8dadb87ad8 100644
--- a/dev-haskell/test-framework-th/test-framework-th-0.2.4.ebuild
+++ b/dev-haskell/test-framework-th/test-framework-th-0.2.4.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-# ebuild generated by hackport 0.3.1.9999
+# ebuild generated by hackport 0.6.6.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
-DESCRIPTION="Automagically generate the HUnit and Quickcheck code using Template Haskell"
+DESCRIPTION="Automagically generate the HUnit and Quickcheck using Template Haskell"
HOMEPAGE="https://github.com/finnsson/test-generator"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
@@ -18,9 +18,11 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="dev-haskell/haskell-src-exts:=[profile?]
- >=dev-haskell/language-haskell-extract-0.2:=[profile?]
- dev-haskell/regex-posix:=[profile?]
- dev-haskell/test-framework:=[profile?]
- >=dev-lang/ghc-6.10.4:="
+ >=dev-haskell/language-haskell-extract-0.2:=[profile?]
+ dev-haskell/regex-posix:=[profile?]
+ dev-haskell/test-framework:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6"
+ >=dev-haskell/cabal-1.6
+"