summaryrefslogtreecommitdiff
path: root/dev-haskell/tasty-rerun
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/tasty-rerun
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/tasty-rerun')
-rw-r--r--dev-haskell/tasty-rerun/Manifest5
-rw-r--r--dev-haskell/tasty-rerun/metadata.xml64
-rw-r--r--dev-haskell/tasty-rerun/tasty-rerun-1.1.5.ebuild32
-rw-r--r--dev-haskell/tasty-rerun/tasty-rerun-1.1.6.ebuild32
4 files changed, 133 insertions, 0 deletions
diff --git a/dev-haskell/tasty-rerun/Manifest b/dev-haskell/tasty-rerun/Manifest
new file mode 100644
index 000000000000..822ea77f9541
--- /dev/null
+++ b/dev-haskell/tasty-rerun/Manifest
@@ -0,0 +1,5 @@
+DIST tasty-rerun-1.1.5.tar.gz 5376 BLAKE2B fe3723004d07e2836b83e85406580a5a74706c5f3cb6b445f575623c8ae1cd659ce8143e11891c4dbdf9b0b9f487b53d8ce64be61b16ba324a0d565bc6e25979 SHA512 becee5c62b425e57666c3cc9b65a7342b1af46e44212ade1360f0cd255cb909cfd9b049d88ff8238940760534479ce077f0e24526359545fff0ab849a0c0d7b7
+DIST tasty-rerun-1.1.6.tar.gz 5399 BLAKE2B 48e329b4f188d618b4a3a2b8eb94723fe0a3a883c64668ed36b7a099bcc86228eb3a0fe42173e8564f14942ab73a2637831b9da4ebf3a4dd4b312bda870fd860 SHA512 dc4db9a4dba424d9d948a4e44d4402b17ab363554493a68035ec0d94bfb6e9e2965e8c9c4b519a071707c70eabd7ea70a4f265f32983e35bf0ee64cd67948808
+EBUILD tasty-rerun-1.1.5.ebuild 1024 BLAKE2B 4073fea7ff9758da57ce5d6d1ea5e1ac73215ec78c99c575639ce2f659ac336a8b6aa7d29aa08807f3dcc74dfb146c90d9a77714b32911ef29ee28c9c55e3ab0 SHA512 f259946c2d3cfe403f34d52ef05a1323b67113cb517aee68ad0bafeef2403cdd42ffc8ebc4bbbe77e50fcf7406706f630c33092e77953a6210a55463cb4c93c1
+EBUILD tasty-rerun-1.1.6.ebuild 1022 BLAKE2B 98f1cbbda7990ff47322eb5ea84f65071eb2e6ec52eb4805e18ac37806d1fff623920225bc653aed7a9d397dfb3baaba72095f97ae66f8db7374ea8ae2a428a1 SHA512 c8c644925deb41bc6c786fd327cf999a3fbb8061fdc096da1dd29c3d706b4e337ab73f399200ab135306e08cbdeb73e9c9f938a6f31c293fb4f2234c2de1ae3f
+MISC metadata.xml 2520 BLAKE2B 168bec58887892ef09313be19f5e114c17ace8d078340b1fa037166f150658e815c48cde5ac39bb72ce510cc96e1c4936bf4d4d489fcfc0018d99eced54cbfd7 SHA512 4cbced2264f235c58c1ebe60937a8ff0c846384be4d53add2c7d3d81927a55e1bf1be9795d94fe2e72ca510f3cfc2fc1b5e1e947eb4a17d2826acb8c275014b6
diff --git a/dev-haskell/tasty-rerun/metadata.xml b/dev-haskell/tasty-rerun/metadata.xml
new file mode 100644
index 000000000000..452f659c0580
--- /dev/null
+++ b/dev-haskell/tasty-rerun/metadata.xml
@@ -0,0 +1,64 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This ingredient adds the ability to run tests by first filtering the test tree
+ based on the result of a previous test run. For example, you can use this to
+ run only those tests that failed in the last run, or to run only tests that
+ have been added since tests were last ran.
+
+ This ingredient is specifically an ingredient *transformer* - given a list of
+ 'Tasty.Ingredient's, 'rerunningTests' adds the ability for all of these
+ ingredients to run against a filtered test tree. This transformer can be
+ applied as follows:
+
+ &gt; import Test.Tasty
+ &gt; import Test.Tasty.Runners
+ &gt;
+ &gt; main :: IO ()
+ &gt; main =
+ &gt; defaultMainWithIngredients
+ &gt; [ rerunningTests [ listingTests, consoleTestReporter ] ]
+ &gt; tests
+ &gt;
+ &gt; tests :: TestTree
+ &gt; tests = undefined
+
+ This ingredient adds three command line parameters:
+
+ [@--rerun-update@] If specified the results of this test run will be saved to
+ the log file at @--rerun-log-file@. If the ingredient does not execute tests
+ (for example, @--list-tests@ is used) then the log file will not be
+ updated. This option is not enabled by default. This option does not require
+ a value.
+
+ [@--rerun-log-file@] The path to the log file to read previous test
+ information from, and where to write new information to (if @--rerun-update@
+ is specified). This option defaults to @.tasty-rerun-log@.
+
+ [@--rerun-filter@] Which filters to apply to the 'Tasty.TestTree' based on
+ previous test runs. The value of this option is a comma separated list of the
+ following options:
+
+ * @failures@: Only run tests that failed on the previous run.
+
+ * @exceptions@: Only run tests that threw an exception on the previous run.
+
+ * @new@: Only run tests that are new since the previous test run.
+
+ * @successful@: Only run tests that were successful in the previous run.
+
+ Multiple options can be combined and will be taken under disjunction - so
+ @--rerun-filter=failures,exceptions@ will run only tests that failed *or*
+ threw an exception on the last run.
+
+ Defaults to all filters, which means all tests will be ran.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ocharles/tasty-rerun</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/tasty-rerun/tasty-rerun-1.1.5.ebuild b/dev-haskell/tasty-rerun/tasty-rerun-1.1.5.ebuild
new file mode 100644
index 000000000000..3d67e2318b08
--- /dev/null
+++ b/dev-haskell/tasty-rerun/tasty-rerun-1.1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Run tests by filtering the tests depending on the result of previous runs"
+HOMEPAGE="https://github.com/ocharles/tasty-rerun"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.1.2:=[profile?]
+ >=dev-haskell/optparse-applicative-0.6:=[profile?]
+ >=dev-haskell/reducers-3.10.1:=[profile?]
+ >=dev-haskell/split-0.1:=[profile?] <dev-haskell/split-0.3:=[profile?]
+ >=dev-haskell/stm-2.4.2:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/tasty-0.10:=[profile?] <dev-haskell/tasty-0.12:=[profile?]
+ >=dev-haskell/transformers-0.3.0.0:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+"
diff --git a/dev-haskell/tasty-rerun/tasty-rerun-1.1.6.ebuild b/dev-haskell/tasty-rerun/tasty-rerun-1.1.6.ebuild
new file mode 100644
index 000000000000..f49889cbe2f4
--- /dev/null
+++ b/dev-haskell/tasty-rerun/tasty-rerun-1.1.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Run tests by filtering the tests depending on the result of previous runs"
+HOMEPAGE="https://github.com/ocharles/tasty-rerun"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.1.2:=[profile?]
+ >=dev-haskell/optparse-applicative-0.6:=[profile?]
+ >=dev-haskell/reducers-3.10.1:=[profile?]
+ >=dev-haskell/split-0.1:=[profile?] <dev-haskell/split-0.3:=[profile?]
+ >=dev-haskell/stm-2.4.2:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/tasty-0.10:=[profile?] <dev-haskell/tasty-0.12:=[profile?]
+ >=dev-haskell/transformers-0.3.0.0:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+"