summaryrefslogtreecommitdiff
path: root/dev-haskell/tasty-expected-failure
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/tasty-expected-failure
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/tasty-expected-failure')
-rw-r--r--dev-haskell/tasty-expected-failure/Manifest3
-rw-r--r--dev-haskell/tasty-expected-failure/metadata.xml25
-rw-r--r--dev-haskell/tasty-expected-failure/tasty-expected-failure-0.11.1.2.ebuild32
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-haskell/tasty-expected-failure/Manifest b/dev-haskell/tasty-expected-failure/Manifest
new file mode 100644
index 000000000000..534ca8c01a21
--- /dev/null
+++ b/dev-haskell/tasty-expected-failure/Manifest
@@ -0,0 +1,3 @@
+DIST tasty-expected-failure-0.11.1.2.tar.gz 3781 BLAKE2B 04101b477457747abbf1a90fed80ab8692e3f771f27fae8310c0451839b38efadf1751ae302a1bac0f020e01533030563c45a2c0d75b03f9cda88ee23d1d8e12 SHA512 31f89d64a1f700a2563b291d287f559e023b0b1059cf5ad35eb9a8b2d4a7d90b2ffced828017b3e86d7ece0b125787f7512e9f4745c75d38bbc688e09031aae5
+EBUILD tasty-expected-failure-0.11.1.2.ebuild 745 BLAKE2B b635671f6f37788177f8ea8315558102b0bc80b45107b7f7bfcca1ffaca423ba1b184eccb19abcc67c952c3a3fce3108a383a9f83e0521b0ebebb3a9050a21cb SHA512 6a0d37ea7eda7932fe7128a53d3f01fd229ac152d715891e2219b2363e89fd7b8cbf74241582a1c9f9ca841f0a682aa3662f7792776cb7aebb71432982066b27
+MISC metadata.xml 1198 BLAKE2B 916fc5054a8fba5dafbea48bb7074ab2bcbd986191298d2a985b9d89f4db424d38277f4229baec55c5b327fd8142aa2510e0d001f69818248480009e2e7a2285 SHA512 1c2e7390095a26f26d3fb57b7715fe34afb209b63761e3597e578d72169b8b6f802361adfa15652c054560c210707dee0d00c43326e82c73eec7ff4df70e72d1
diff --git a/dev-haskell/tasty-expected-failure/metadata.xml b/dev-haskell/tasty-expected-failure/metadata.xml
new file mode 100644
index 000000000000..38e4a3a924f5
--- /dev/null
+++ b/dev-haskell/tasty-expected-failure/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ With the function &#39;Test.Tasty.ExpectedFailure.expectFail&#39; in the provided module
+ &quot;Test.Tasty.ExpectedFailure&quot;, you can mark that you expect test cases to fail,
+ and not to pass.
+
+ This can for example be used for test-driven development: Create the tests,
+ mark them with &#39;Test.Tasty.ExpectedFailure.expectFail&#39;, and you can still push
+ to the main branch, without your continuous integration branch failing.
+
+ Once someone implements the feature or fixes the bug (maybe unknowingly), the
+ test suite will tell him so, due to the now unexpectedly passing test, and he
+ can remove the &#39;Test.Tasty.ExpectedFailure.expectFail&#39; marker.
+
+ The module also provides &#39;Test.Tasty.ExpectedFailure.ignoreTest&#39; to avoid
+ running a test. Both funtions are implemented via the more general
+ &#39;Test.Tasty.ExpectedFailure.warpTest&#39;, which is also provided.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/tasty-expected-failure/tasty-expected-failure-0.11.1.2.ebuild b/dev-haskell/tasty-expected-failure/tasty-expected-failure-0.11.1.2.ebuild
new file mode 100644
index 000000000000..8da7513fe22d
--- /dev/null
+++ b/dev-haskell/tasty-expected-failure/tasty-expected-failure-0.11.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Mark tasty tests as failure expected"
+HOMEPAGE="https://github.com/nomeata/tasty-expected-failure"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/tasty-0.11:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'base >= 4.5 && <4.14' 'base >= 4.5'
+ default
+}