summaryrefslogtreecommitdiff
path: root/dev-haskell/system-fileio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/system-fileio
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/system-fileio')
-rw-r--r--dev-haskell/system-fileio/Manifest3
-rw-r--r--dev-haskell/system-fileio/metadata.xml20
-rw-r--r--dev-haskell/system-fileio/system-fileio-0.3.16.3.ebuild29
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/system-fileio/Manifest b/dev-haskell/system-fileio/Manifest
new file mode 100644
index 000000000000..2aaaea0b08ec
--- /dev/null
+++ b/dev-haskell/system-fileio/Manifest
@@ -0,0 +1,3 @@
+DIST system-fileio-0.3.16.3.tar.gz 15296 BLAKE2B 18a48c74794f9b2fbe33a181ce007984fdfab61202832a1bab395a3b3c1ba25aa5f45649f2b33e7608d422ad92a42719e6997ed9ab3ca4370e055d366476d779 SHA512 74ee4028caa77194120d66316677cc0f184fd4af5c4feaa7d713145b97dab8bcebc2f4b971464f9a68f8e304021d0fe5c52272bb282db0925559ff0ff6937842
+EBUILD system-fileio-0.3.16.3.ebuild 869 BLAKE2B becbce34a36b8ad974d2c6d878e7251d92f791aaa400440df7c0c9379aba2e4b8189403c02b68d7385dcb232860189d03588e8410aad907ede8d66f2e7721273 SHA512 83cc19033f9bf9a0fdc35b159eda86419f39eaa5bc7745c1db49aed0e6844b9bb93eb194d68e3fa6bce4b432437dc6cb7267c59df998d2b341fdc9ca8b47f09c
+MISC metadata.xml 757 BLAKE2B bc8189d57e01933bede97c622425c894858e26f5a51456c17f37f2f313edb5c1ab6ea0418e3f9dbc07a73740ba739590ba5e3939931e522746e6ddb66a34addb SHA512 f54a873966d7476a2bd24095b2f83a2d5f3f80d93758050543f648ba85a578070891028db294881ce3497663e23d70d816246d72e2c10310c6b7f693728c3ace
diff --git a/dev-haskell/system-fileio/metadata.xml b/dev-haskell/system-fileio/metadata.xml
new file mode 100644
index 000000000000..b1faa3826194
--- /dev/null
+++ b/dev-haskell/system-fileio/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This is a small wrapper around the \"directory\", \"unix\", and \"Win32\"
+ packages, for use with \"system-filepath\". It provides a consistent API
+ to the various versions of these packages distributed with different
+ versions of GHC.
+
+ In particular, this library supports working with POSIX files that have
+ paths which can't be decoded in the current locale encoding.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">fpco/haskell-filesystem</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/system-fileio/system-fileio-0.3.16.3.ebuild b/dev-haskell/system-fileio/system-fileio-0.3.16.3.ebuild
new file mode 100644
index 000000000000..808a5bd88c44
--- /dev/null
+++ b/dev-haskell/system-fileio/system-fileio-0.3.16.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Consistent filesystem interaction across GHC versions (deprecated)"
+HOMEPAGE="https://github.com/fpco/haskell-filesystem"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/system-filepath-0.3.1:=[profile?] <dev-haskell/system-filepath-0.5:=[profile?]
+ >=dev-haskell/text-0.7.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/chell-0.4 <dev-haskell/chell-0.5
+ >=dev-haskell/temporary-1.1 <dev-haskell/temporary-2.0
+ >=dev-haskell/transformers-0.2 )
+"