summaryrefslogtreecommitdiff
path: root/dev-haskell/strict
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/strict
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/strict')
-rw-r--r--dev-haskell/strict/Manifest3
-rw-r--r--dev-haskell/strict/metadata.xml13
-rw-r--r--dev-haskell/strict/strict-0.3.2.ebuild22
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/strict/Manifest b/dev-haskell/strict/Manifest
new file mode 100644
index 000000000000..0d6d6e368919
--- /dev/null
+++ b/dev-haskell/strict/Manifest
@@ -0,0 +1,3 @@
+DIST strict-0.3.2.tar.gz 3948 BLAKE2B f882834fdd7b6df5c1f7c56e93f895380ff291096feb73b627ba26c7d6f41555ef6a135d7d5fdac19f28c48869f9987bd510530300f968482538c79fe1842286 SHA512 ca27ee2b557669c409c0417b2005ceb612ad95040fd4a798535cdbc83b8b7a51a36bb66bc2e7bff04b5b965313894a51910a274d67a891530ed119c831bcd686
+EBUILD strict-0.3.2.ebuild 567 BLAKE2B 6f648fe49c6879a4940f1230d000b855221cae75814b9f253d7a5dbc60f576526879bb00822c5edd4049f73eab99a2c31eb53b4cf9d9ccd69fd88f089be3bf18 SHA512 ac19fba355b74a7838f38e7d721dfc160fead0f0a88823e33e567ba7339073115a26f9d0cb5747b721b7663f63c2c184c8cf9daa8c817ced27e15a6f410a90fa
+MISC metadata.xml 434 BLAKE2B d70d7c3c439f2cc625885ce9df67be8b9d5ca520ff672868b17a9ea5406519b9763f56ba3b8a04d76b8c0f6666f5971bc5744e4364119814efd4020a0bfd3f37 SHA512 ff58eaedb8c7e7e4f4937bd5a9423827479514333bae86d9a6e7b60f957468975d7764ede2900696da478ad50ba75963018f7782f4811ab01cb78ffcc1677553
diff --git a/dev-haskell/strict/metadata.xml b/dev-haskell/strict/metadata.xml
new file mode 100644
index 000000000000..3e475704a457
--- /dev/null
+++ b/dev-haskell/strict/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package provides strict versions of some standard Haskell data
+ types (pairs, Maybe and Either). It also contains strict IO
+ operations.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/strict/strict-0.3.2.ebuild b/dev-haskell/strict/strict-0.3.2.ebuild
new file mode 100644
index 000000000000..0b3cd3a7b1e1
--- /dev/null
+++ b/dev-haskell/strict/strict-0.3.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Strict data types and String IO"
+HOMEPAGE="http://www.cse.unsw.edu.au/~rl/code/strict.html"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"