summaryrefslogtreecommitdiff
path: root/dev-haskell/snap-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/snap-core
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/snap-core')
-rw-r--r--dev-haskell/snap-core/Manifest5
-rw-r--r--dev-haskell/snap-core/metadata.xml47
-rw-r--r--dev-haskell/snap-core/snap-core-0.9.8.0.ebuild57
-rw-r--r--dev-haskell/snap-core/snap-core-1.0.1.0.ebuild55
4 files changed, 164 insertions, 0 deletions
diff --git a/dev-haskell/snap-core/Manifest b/dev-haskell/snap-core/Manifest
new file mode 100644
index 000000000000..95b71185880f
--- /dev/null
+++ b/dev-haskell/snap-core/Manifest
@@ -0,0 +1,5 @@
+DIST snap-core-0.9.8.0.tar.gz 91610 BLAKE2B 291dd696482f3406b58081fc3dede958cd255ef725ee84d0e4706b096c9c468832b99e5e3d61771e0c652cc0463e831a9c7119595328f18443deedd901625417 SHA512 8bf98590294b3f8752255612b90378f19cec14067f2eaddab496cee5fddb4b8be954aada5a7831b81611d7ffc04d74156eb8fdb5d3c5f45e30259c7f86605585
+DIST snap-core-1.0.1.0.tar.gz 139670 BLAKE2B 13c0839ef95b2260e1272dbf26c9ee1f8970094e3f9ffea728d760f4bf11a260ad73120495a39305e8d8d05cb39c230db08ae1e4094efcaf7879acf4680f61c3 SHA512 ed862530f235adca6f193c96d45b31705534089c58637bf8d0d9d8cd898db8f25494990e210151adc737c34e3cc59f5e0a47cc6b1e638dae9104e991e27dbe8b
+EBUILD snap-core-0.9.8.0.ebuild 2583 BLAKE2B 9247faaf39384f594d041fda396637affeb1128f9ffc01725946aaeae30daa565e62f8dc8be953627ef1e21b42f1639443074c0a14b76406e389d0a59f5c6d53 SHA512 64daa778afd91fefe627b1cad171a1feedc045ad1d0e9c08a061aa57ba89ba1bfe5ee05923870056dd5e2fac62aa7428c78b27f70999c7b12f89a2ebf787ae96
+EBUILD snap-core-1.0.1.0.ebuild 2677 BLAKE2B fe836a952b776b8d301c9c08286139b8def6dbca876615280daf7a4f8b561d509553ab7bb3d7447eb9e41f9e40dba8993863ca730beb229cfc77ccb70c54ec97 SHA512 f9e0ff4f1e06c677bcb04f5454ad335d96fe0e8e293a6493e7741401607826fcda7d1b718ccc3149d4fe6df358b65a413038b328cde140574c03b9a41662ac57
+MISC metadata.xml 1855 BLAKE2B 061e56d781f921b5ad34683a6c5c2192a282567e5efa39c315c50cdf915032d70c66d8f270c76647b47ad5c9bee1b666305dc3d9fa790c941bb9ecd416fdf792 SHA512 f497be0430344459a95055207a06f9b9b2b33c6a0edc2cff99ad89051a5d8f615258aaf94234689d4443a6d30e0c4a6df1dadeba2fe142b1f0c324932691e66f
diff --git a/dev-haskell/snap-core/metadata.xml b/dev-haskell/snap-core/metadata.xml
new file mode 100644
index 000000000000..f00884306e68
--- /dev/null
+++ b/dev-haskell/snap-core/metadata.xml
@@ -0,0 +1,47 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="portable">No non-haskell unportable code.</flag>
+ </use>
+ <longdescription>
+ Snap is a simple and fast web development framework and server written in
+ Haskell. For more information or to download the latest version, you can
+ visit the Snap project website at &lt;http://snapframework.com/&gt;.
+
+ This library contains the core definitions and types for the Snap framework,
+ including:
+
+ 1. Primitive types and functions for HTTP (requests, responses, cookies,
+ post/query parameters, etc)
+
+ 2. Type aliases and helper functions for Iteratee I/O
+
+ 3. A monad for programming web handlers called \"Snap\", inspired by
+ happstack's (&lt;http://happstack.com/index.html&gt;), which allows:
+
+ * Stateful access to the HTTP request and response objects
+
+ * Monadic failure (i.e. MonadPlus/Alternative instances) for declining
+ to handle requests and chaining handlers together
+
+ * Early termination of the computation if you know early what you want
+ to return and want to prevent further monadic processing
+
+ /Quick start/: The 'Snap' monad and HTTP definitions are in "Snap.Core",
+ some iteratee utilities are in "Snap.Iteratee".
+
+ Higher-level facilities for building web applications (like user/session
+ management, component interfaces, data modeling, etc.) are planned but not
+ yet implemented, so this release will mostly be of interest for those who:
+
+ * need a fast and minimal HTTP API at roughly the same level of abstraction
+ as Java servlets, or
+
+ * are interested in contributing to the Snap Framework project.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/snap-core/snap-core-0.9.8.0.ebuild b/dev-haskell/snap-core/snap-core-0.9.8.0.ebuild
new file mode 100644
index 000000000000..ed5746eb2b61
--- /dev/null
+++ b/dev-haskell/snap-core/snap-core-0.9.8.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Snap: A Haskell Web Framework (core interfaces and types)"
+HOMEPAGE="http://snapframework.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="debug portable"
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ >=dev-haskell/attoparsec-enumerator-0.3:=[profile?] <dev-haskell/attoparsec-enumerator-0.4:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/blaze-builder-enumerator-0.2:=[profile?] <dev-haskell/blaze-builder-enumerator-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-0.3:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/enumerator-0.4.15:=[profile?] <dev-haskell/enumerator-0.5:=[profile?]
+ >=dev-haskell/hunit-1.2:=[profile?] <dev-haskell/hunit-2:=[profile?]
+ >=dev-haskell/monadcatchio-transformers-0.2.1:=[profile?] <dev-haskell/monadcatchio-transformers-0.4:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/random-1:=[profile?] <dev-haskell/random-2:=[profile?]
+ >=dev-haskell/regex-posix-0.95:=[profile?] <dev-haskell/regex-posix-1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unix-compat-0.2:=[profile?] <dev-haskell/unix-compat-0.5:=[profile?]
+ >=dev-haskell/unordered-containers-0.1.4.3:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.6:=[profile?] <dev-haskell/vector-0.12:=[profile?]
+ >=dev-haskell/zlib-enum-0.2.1:=[profile?] <dev-haskell/zlib-enum-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ >=dev-haskell/hashable-1.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ portable? ( >=dev-haskell/time-locale-compat-0.1:=[profile?] <dev-haskell/time-locale-compat-0.2:=[profile?] )
+ !portable? ( >=dev-haskell/bytestring-mmap-0.2.2:=[profile?] <dev-haskell/bytestring-mmap-0.3:=[profile?]
+ >=dev-haskell/old-locale-1:=[profile?] <dev-haskell/old-locale-2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'time >= 1.0 && < 1.6' 'time >= 1.0'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug) \
+ $(cabal_flag portable portable)
+}
diff --git a/dev-haskell/snap-core/snap-core-1.0.1.0.ebuild b/dev-haskell/snap-core/snap-core-1.0.1.0.ebuild
new file mode 100644
index 000000000000..c34b212ca497
--- /dev/null
+++ b/dev-haskell/snap-core/snap-core-1.0.1.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Snap: A Haskell Web Framework (core interfaces and types)"
+HOMEPAGE="http://snapframework.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="debug portable"
+
+RDEPEND=">=dev-haskell/attoparsec-0.12:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ >=dev-haskell/bytestring-builder-0.10.4:=[profile?] <dev-haskell/bytestring-builder-0.11:=[profile?]
+ >=dev-haskell/case-insensitive-1.1:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/hunit-1.2:=[profile?] <dev-haskell/hunit-2:=[profile?]
+ >=dev-haskell/io-streams-1.3:=[profile?] <dev-haskell/io-streams-1.4:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
+ >=dev-haskell/monad-control-1.0:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/random-1:=[profile?] <dev-haskell/random-2:=[profile?]
+ >=dev-haskell/readable-0.1:=[profile?] <dev-haskell/readable-0.4:=[profile?]
+ >=dev-haskell/regex-posix-0.95:=[profile?] <dev-haskell/regex-posix-1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/transformers-base-0.4:=[profile?] <dev-haskell/transformers-base-0.5:=[profile?]
+ >=dev-haskell/unix-compat-0.3:=[profile?] <dev-haskell/unix-compat-0.5:=[profile?]
+ >=dev-haskell/unordered-containers-0.1.4.3:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.6:=[profile?] <dev-haskell/vector-0.12:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ portable? ( >=dev-haskell/time-locale-compat-0.1:=[profile?] <dev-haskell/time-locale-compat-0.2:=[profile?] )
+ !portable? ( >=dev-haskell/old-locale-1:=[profile?] <dev-haskell/old-locale-2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/hashable
+ >=dev-haskell/parallel-3 <dev-haskell/parallel-4
+ >=dev-haskell/quickcheck-2.3.0.2 <dev-haskell/quickcheck-3
+ >=dev-haskell/test-framework-0.8.0.3 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2.7 <dev-haskell/test-framework-hunit-0.4
+ >=dev-haskell/test-framework-quickcheck2-0.2.12.1 <dev-haskell/test-framework-quickcheck2-0.4
+ >=dev-haskell/zlib-0.5 <dev-haskell/zlib-0.7 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug) \
+ $(cabal_flag portable portable)
+}