summaryrefslogtreecommitdiff
path: root/dev-haskell/skylighting
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/skylighting
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/skylighting')
-rw-r--r--dev-haskell/skylighting/Manifest5
-rw-r--r--dev-haskell/skylighting/metadata.xml24
-rw-r--r--dev-haskell/skylighting/skylighting-0.1.1.5.ebuild48
-rw-r--r--dev-haskell/skylighting/skylighting-0.3.ebuild49
4 files changed, 126 insertions, 0 deletions
diff --git a/dev-haskell/skylighting/Manifest b/dev-haskell/skylighting/Manifest
new file mode 100644
index 000000000000..69d6302eb1f2
--- /dev/null
+++ b/dev-haskell/skylighting/Manifest
@@ -0,0 +1,5 @@
+DIST skylighting-0.1.1.5.tar.gz 584235 BLAKE2B 87226657d721b1491565f6003eb0d9087edd7f25a67549bc60b219f4c0ff5a5d799a9aa1c42b087a805af235434ea288f1f659711eeb2299395ce5f976a734b2 SHA512 2d430d2067d7694978620af0c63ce47240074055bf5179b968ac2a430b9968f445307347c8975e550823f509c05ab600f07c3d1cdc7f8909bf19506e0153e3ef
+DIST skylighting-0.3.tar.gz 537701 BLAKE2B 5589aed231b25bd33160a314b5924432fe2c508bc58fbe1567d0742e19ff46784069c3e33f68888751e1c5252ead8050c7895d6fd6a05efd9588b79aee74eecf SHA512 5ecff7f3fcf244d58fa21a83ebad9358661079cd559802a7b7b888bef7969f40587f2ca80aefae5b5424e05c1fe6bc168a6df034eb843b3613f7b3fc0abedc04
+EBUILD skylighting-0.1.1.5.ebuild 1254 BLAKE2B f6951af4b99d68ab4901d25616a50d29707e3b67967a6727bfc10f31fc158b25080b1e436fdbd1f13ac4e974769757b66313fdf15d5d43b3010d52e74c9af2a4 SHA512 1fc517e98b1aec0c7c6f4b4a97e15f6b4cc4578411389d7b56c835fd365823f52bcf659696590607b47f4d0c5e16ee2f43c5c6e2f6175d53d6346886049126a4
+EBUILD skylighting-0.3.ebuild 1280 BLAKE2B 165eb27ae69006d421d4043c833d2f6bcb25ddf8d463356795f496f4720f7233bf9fed97582285dbb4f2593fd0ea839405351eaf097b8a492bcee0732b3d6ca3 SHA512 077c289c545d28c8b4c26f43ca3c8eab92fc1c8e677ded26efe868c4276a408800cd036d7a36bc73001b0637d3d7fd428e923151d23ffeaca4b8a45a14ce0892
+MISC metadata.xml 824 BLAKE2B 40102d8937d28fe2b98f055019288ea9fb08307e23702e46c2f10e815006e4a3f4fa11a34fd787c1053441f30a27c138252ce853e9c22867523b3be8fa711f3c SHA512 377bf69b015def5abcaa6dde5865890fb97188b09b4539f13f704880d61aa352df3f4a8f5a76bcadc51e4938ed6336e4732540a8ee12e705aa6fa39e58f9b792
diff --git a/dev-haskell/skylighting/metadata.xml b/dev-haskell/skylighting/metadata.xml
new file mode 100644
index 000000000000..45342c91c5fd
--- /dev/null
+++ b/dev-haskell/skylighting/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="executable">Build the skylighting executable.</flag>
+ </use>
+ <longdescription>
+ Skylighting is a syntax highlighting library with
+ support for over one hundred languages. It derives
+ its tokenizers from XML syntax definitions used
+ by KDE's KSyntaxHighlighting framework, so any
+ syntax supported by that framework can be added.
+ An optional command-line program is provided.
+ Skylighting is intended to be the successor to
+ highlighting-kate.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">jgm/skylighting</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/skylighting/skylighting-0.1.1.5.ebuild b/dev-haskell/skylighting/skylighting-0.1.1.5.ebuild
new file mode 100644
index 000000000000..47a38e9f18dd
--- /dev/null
+++ b/dev-haskell/skylighting/skylighting-0.1.1.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: -bootstrap
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="syntax highlighting library"
+HOMEPAGE="https://github.com/jgm/skylighting"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ dev-haskell/hxt:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/regex-pcre-builtin:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ executable? ( dev-haskell/pretty-show:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.2.0
+ test? ( dev-haskell/diff
+ dev-haskell/hunit
+ dev-haskell/random
+ dev-haskell/tasty
+ dev-haskell/tasty-golden
+ dev-haskell/tasty-hunit
+ !executable? ( dev-haskell/pretty-show ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bootstrap \
+ $(cabal_flag executable executable)
+}
diff --git a/dev-haskell/skylighting/skylighting-0.3.ebuild b/dev-haskell/skylighting/skylighting-0.3.ebuild
new file mode 100644
index 000000000000..78336add296a
--- /dev/null
+++ b/dev-haskell/skylighting/skylighting-0.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: -bootstrap,+system-pcre
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="syntax highlighting library"
+HOMEPAGE="https://github.com/jgm/skylighting"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="executable"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ dev-haskell/hxt:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/regex-pcre:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ executable? ( dev-haskell/pretty-show:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/diff
+ dev-haskell/hunit
+ dev-haskell/random
+ dev-haskell/tasty
+ dev-haskell/tasty-golden
+ dev-haskell/tasty-hunit
+ !executable? ( dev-haskell/pretty-show ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bootstrap \
+ $(cabal_flag executable executable) \
+ --flag=system-pcre
+}