summaryrefslogtreecommitdiff
path: root/dev-haskell/skylighting-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/skylighting-core
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/skylighting-core')
-rw-r--r--dev-haskell/skylighting-core/Manifest3
-rw-r--r--dev-haskell/skylighting-core/metadata.xml25
-rw-r--r--dev-haskell/skylighting-core/skylighting-core-0.8.5.ebuild53
3 files changed, 81 insertions, 0 deletions
diff --git a/dev-haskell/skylighting-core/Manifest b/dev-haskell/skylighting-core/Manifest
new file mode 100644
index 000000000000..835c0fa4dbe3
--- /dev/null
+++ b/dev-haskell/skylighting-core/Manifest
@@ -0,0 +1,3 @@
+DIST skylighting-core-0.8.5.tar.gz 675746 BLAKE2B 3a17423f5412228930df78e86b00b3d0339bced0a00e801a9986177f7099e9e5706b1858e3a4064db84eeec3b0fdde3f043b05b62de85d6a92d2d47a5cbb136d SHA512 ad411d7e0fd72adeb4cdbf6fc57d6191c51d9319b25c8d41ad35a66f885d518a842846cd7cf5ce35bdc31da74e0f9d97445f492628a4b5a2bceb85642aa23257
+EBUILD skylighting-core-0.8.5.ebuild 1393 BLAKE2B cae9c111639ba16103db61609b380cae0268753a54eb3a61894b112e18768b041702695d4a2a84c58b18e5b38268c4371bb80be5796124a708351a3d4c350018 SHA512 aa65fb1f748c102c539bdc3f869a1c86a97716538588346ca5231fc37ad21837739c280bf885ac49b05331357f1632c80b5b29ee6c1c17b6cb66813d4d112d0c
+MISC metadata.xml 860 BLAKE2B 168a330230e8a77fcdd7da5c60bbcc88546be72a0f383aa9e5e55370459982437a2cfd0a3a1645c4542e15a04e56a250c486650d13a18cf00bd6db03829623bf SHA512 e09699b10db27bf3ae4b794fcdc7e84f5a6ed870ce0fe28e269e337457f9be90e234d8f104e532d8c9c3dee0346547d9beaeb8f4a3e24a0d4d1a1e7553b7e225
diff --git a/dev-haskell/skylighting-core/metadata.xml b/dev-haskell/skylighting-core/metadata.xml
new file mode 100644
index 000000000000..4dccbfb7b1c7
--- /dev/null
+++ b/dev-haskell/skylighting-core/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="executable">Build the skylighting executable.</flag>
+ </use>
+ <longdescription>
+ Skylighting is a syntax highlighting library.
+ It derives its tokenizers from XML syntax
+ definitions used by KDE&#39;s KSyntaxHighlighting
+ framework, so any syntax supported by that
+ framework can be added. An optional command-line
+ program is provided.
+ Skylighting is intended to be the successor to
+ highlighting-kate.
+ This package provides the core highlighting
+ functionality under a permissive license. It also
+ bundles XML parser definitions licensed under the
+ GPL.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/skylighting-core/skylighting-core-0.8.5.ebuild b/dev-haskell/skylighting-core/skylighting-core-0.8.5.ebuild
new file mode 100644
index 000000000000..97378ef65296
--- /dev/null
+++ b/dev-haskell/skylighting-core/skylighting-core-0.8.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+#hackport: flags: +system-pcre
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="syntax highlighting library"
+HOMEPAGE="https://github.com/jgm/skylighting"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable"
+
+RDEPEND=">=dev-haskell/aeson-1.0:=[profile?]
+ >=dev-haskell/ansi-terminal-0.7:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ >=dev-haskell/colour-2.0:=[profile?]
+ dev-haskell/hxt:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/regex-pcre:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+ test? ( dev-haskell/diff
+ dev-haskell/hunit
+ dev-haskell/pretty-show
+ dev-haskell/quickcheck
+ dev-haskell/random
+ dev-haskell/tasty
+ dev-haskell/tasty-golden
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ --flag=system-pcre
+}