summaryrefslogtreecommitdiff
path: root/dev-haskell/shakespeare/shakespeare-2.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/shakespeare/shakespeare-2.0.7.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/shakespeare/shakespeare-2.0.7.ebuild')
-rw-r--r--dev-haskell/shakespeare/shakespeare-2.0.7.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-haskell/shakespeare/shakespeare-2.0.7.ebuild b/dev-haskell/shakespeare/shakespeare-2.0.7.ebuild
new file mode 100644
index 000000000000..d4eb111b7497
--- /dev/null
+++ b/dev-haskell/shakespeare/shakespeare-2.0.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A toolkit for making compile-time interpolated templates"
+HOMEPAGE="https://www.yesodweb.com/book/shakespearean-templates"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test_coffee test_export test_roy"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/blaze-html:=[profile?]
+ dev-haskell/blaze-markup:=[profile?]
+ dev-haskell/exceptions:=[profile?]
+ >=dev-haskell/parsec-2:=[profile?] <dev-haskell/parsec-4:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/hspec-2 <dev-haskell/hspec-3
+ dev-haskell/hunit )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test_coffee test_coffee) \
+ $(cabal_flag test_export test_export) \
+ $(cabal_flag test_roy test_roy)
+}