summaryrefslogtreecommitdiff
path: root/dev-haskell/retry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/retry
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/retry')
-rw-r--r--dev-haskell/retry/Manifest3
-rw-r--r--dev-haskell/retry/metadata.xml20
-rw-r--r--dev-haskell/retry/retry-0.7.4.2.ebuild32
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-haskell/retry/Manifest b/dev-haskell/retry/Manifest
new file mode 100644
index 000000000000..37322777b3e0
--- /dev/null
+++ b/dev-haskell/retry/Manifest
@@ -0,0 +1,3 @@
+DIST retry-0.7.4.2.tar.gz 9721 BLAKE2B 419f36f128ff3c1977daf6aff15346a499a199c444f1867d08b4da6351465f28298f85e77801fa197c26844558111853abede237939bfdf22fe7f1d977620c3e SHA512 5caeb55225759eae466dc0b0a78ff2538380fda75fbd52758639c12c20e3194d2b272fb9286fbffaf70366418654f2e46088954921a9840720b590598314ba2b
+EBUILD retry-0.7.4.2.ebuild 954 BLAKE2B a6025117e292270414b9c52ddc3f50346102cda54d694d4a8ff6cceed61ef979544dae09054b03201fd29dd973d8b7fd27b6618ade3736bb3a3c4ee32e32ffe1 SHA512 ee6f5d5f826a362dfaae75a154fb5528f6a092326fd327780f15b30f2d36513ff39aa778f5117b0f2b2a79a50c6b5f3aa6c778b34afd1169a41619aef0047bfe
+MISC metadata.xml 828 BLAKE2B 39e47fb53e0a6197850173d421049327a61f09ed8d24c44a5a09901b84af7a4529985d98d8eb340e34eaf1c766892cffd1b123de7dbcfe84b75ce9431b14cfc4 SHA512 59c32a88a5c3a50ac820c0c768f33f66f928b2674fb89a12b6f2be318a94b0043ef31d6b3db45296bd52989222a18947a5ae582b75232726daf63e75aa42d277
diff --git a/dev-haskell/retry/metadata.xml b/dev-haskell/retry/metadata.xml
new file mode 100644
index 000000000000..8df6740dd53a
--- /dev/null
+++ b/dev-haskell/retry/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package exposes combinators that can wrap arbitrary
+ monadic actions. They run the action and potentially retry
+ running it with some configurable delay for a configurable
+ number of times.
+ The purpose is to make it easier to work with IO and
+ especially network IO actions that often experience temporary
+ failure and warrant retrying of the original action. For
+ example, a database query may time out for a while, in which
+ case we should hang back for a bit and retry the query instead
+ of simply raising an exception.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/retry/retry-0.7.4.2.ebuild b/dev-haskell/retry/retry-0.7.4.2.ebuild
new file mode 100644
index 000000000000..b497f43dc689
--- /dev/null
+++ b/dev-haskell/retry/retry-0.7.4.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Retry combinators for monadic actions that may fail"
+HOMEPAGE="https://github.com/Soostone/retry"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/exceptions-0.5:=[profile?] <dev-haskell/exceptions-0.9:=[profile?]
+ >=dev-haskell/random-1:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/hspec-1.9
+ >=dev-haskell/hunit-1.2.5.2 <dev-haskell/hunit-1.6
+ dev-haskell/mtl
+ >=dev-haskell/quickcheck-2.7 <dev-haskell/quickcheck-2.10
+ dev-haskell/stm )
+"