summaryrefslogtreecommitdiff
path: root/dev-haskell/resolv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/resolv
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/resolv')
-rw-r--r--dev-haskell/resolv/Manifest3
-rw-r--r--dev-haskell/resolv/metadata.xml31
-rw-r--r--dev-haskell/resolv/resolv-0.1.2.0.ebuild27
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-haskell/resolv/Manifest b/dev-haskell/resolv/Manifest
new file mode 100644
index 000000000000..0a73b06f65da
--- /dev/null
+++ b/dev-haskell/resolv/Manifest
@@ -0,0 +1,3 @@
+DIST resolv-0.1.2.0.tar.gz 156710 BLAKE2B dbad867d764db2075724a06d9f9dfa8dff882683849883cb9ade6d0654fefe9f024445cd137dca516b80cc2982544b794de7c82fd5d5f482a3891422a699f2c9 SHA512 fae2d0717a109b0d6cc19c51c773bc68c64c0048b9d930528cf5622ee270ebaddec180c1d444542e8eb036262611f5b88deadeea223fb2ef2b15b41369a2376e
+EBUILD resolv-0.1.2.0.ebuild 773 BLAKE2B b91c8be78d35f270255c820353aef82a2979d62033a00862885e653abbf2be60cac074ca77f89c5a2dedefe8db0c4d29fc94e624ba09e483787eacd65b91aa34 SHA512 b745104b695e8eeea23c5a2e9efdfa2d2fd4df011f5e52afa7cfcc4ac862bea786578eca0f85cbc6dce85786ffa1040da05349078e38b809237d8b3d8fbf1dd0
+MISC metadata.xml 1960 BLAKE2B 8b9024347be335cf065c2de0ef64dbb9473fb5f90b451b0cab65328f69d9fc5e7e271cf0c2c6b1172eb064ed8310930b9339e769fbb74bbdf55811c4cd67222c SHA512 c5c19481ca52a233c61124462b0560aed68d6c4b9604c9d401f42d2dfdb7556b54ca000133f658fc6c114b481d94b6a92fc365623bb8dd52c1de11179bb02259
diff --git a/dev-haskell/resolv/metadata.xml b/dev-haskell/resolv/metadata.xml
new file mode 100644
index 000000000000..9990695ff28a
--- /dev/null
+++ b/dev-haskell/resolv/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package implements an API for accessing
+ the [Domain Name Service (DNS)](https://tools.ietf.org/html/rfc1035)
+ resolver service via the standard @libresolv@ system library (whose
+ API is often available directly via the standard @libc@ C library) on
+ Unix systems.
+
+ This package also includes support for decoding message record types
+ as defined in the following RFCs:
+
+ - [RFC 1035](https://tools.ietf.org/html/rfc1035): Domain Names - Implementation And Specification
+ - [RFC 1183](https://tools.ietf.org/html/rfc1183): New DNS RR Definitions
+ - [RFC 2782](https://tools.ietf.org/html/rfc2782): A DNS RR for specifying the location of services (DNS SRV)
+ - [RFC 2915](https://tools.ietf.org/html/rfc2915): The Naming Authority Pointer (NAPTR) DNS Resource Record
+ - [RFC 3596](https://tools.ietf.org/html/rfc3596): DNS Extensions to Support IP Version 6
+ - [RFC 4034](https://tools.ietf.org/html/rfc4034): Resource Records for the DNS Security Extensions
+ - [RFC 4255](https://tools.ietf.org/html/rfc4255): Using DNS to Securely Publish Secure Shell (SSH) Key Fingerprints
+ - [RFC 4408](https://tools.ietf.org/html/rfc4408): Sender Policy Framework (SPF) for Authorizing Use of Domains in E-Mail, Version 1
+ - [RFC 5155](https://tools.ietf.org/html/rfc5155): DNS Security (DNSSEC) Hashed Authenticated Denial of Existence
+ - [RFC 6844](https://tools.ietf.org/html/rfc6844): DNS Certification Authority Authorization (CAA) Resource Record
+ - [RFC 6891](https://tools.ietf.org/html/rfc6891): Extension Mechanisms for DNS (EDNS(0))
+ - [RFC 7553](https://tools.ietf.org/html/rfc7553): The Uniform Resource Identifier (URI) DNS Resource Record
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/resolv/resolv-0.1.2.0.ebuild b/dev-haskell/resolv/resolv-0.1.2.0.ebuild
new file mode 100644
index 000000000000..b93b0da4fc23
--- /dev/null
+++ b/dev-haskell/resolv/resolv-0.1.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Broken test-suite: needs a port to new srcloc
+inherit haskell-cabal
+
+DESCRIPTION="Domain Name Service (DNS) lookup via the libresolv standard library routines"
+HOMEPAGE="https://hackage.haskell.org/package/resolv"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # fails to build test suite
+
+RDEPEND=">=dev-haskell/base16-bytestring-0.1:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2
+"