summaryrefslogtreecommitdiff
path: root/dev-haskell/recaptcha/recaptcha-0.1.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/recaptcha/recaptcha-0.1.0.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/recaptcha/recaptcha-0.1.0.3.ebuild')
-rw-r--r--dev-haskell/recaptcha/recaptcha-0.1.0.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/recaptcha/recaptcha-0.1.0.3.ebuild b/dev-haskell/recaptcha/recaptcha-0.1.0.3.ebuild
new file mode 100644
index 000000000000..15561ac60009
--- /dev/null
+++ b/dev-haskell/recaptcha/recaptcha-0.1.0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Functions for using the reCAPTCHA service in web applications"
+HOMEPAGE="https://github.com/jgm/recaptcha/tree/master"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND=">=dev-haskell/http-3001.1.4:=[profile?]
+ >=dev-haskell/xhtml-3000.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?] )
+ !network-uri? ( >=dev-haskell/network-2:=[profile?] <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}