summaryrefslogtreecommitdiff
path: root/dev-haskell/readargs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-22 02:42:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-22 02:42:13 +0100
commite7f37e03b952768321c8c943a80eff4152ea7bbd (patch)
tree355a9efb62297418cdadbc424b09dbafc54257e5 /dev-haskell/readargs
parent2518522472e5de9c52c78dc0246475fe0ae3cc05 (diff)
gentoo auto-resync : 22:08:2022 - 02:42:13
Diffstat (limited to 'dev-haskell/readargs')
-rw-r--r--dev-haskell/readargs/Manifest3
-rw-r--r--dev-haskell/readargs/metadata.xml74
-rw-r--r--dev-haskell/readargs/readargs-1.2.3.ebuild32
3 files changed, 0 insertions, 109 deletions
diff --git a/dev-haskell/readargs/Manifest b/dev-haskell/readargs/Manifest
deleted file mode 100644
index e0a51ca8636c..000000000000
--- a/dev-haskell/readargs/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST ReadArgs-1.2.3.tar.gz 5100 BLAKE2B 8d0ee19cb417a0159b9a0488f30d11319c7ce278713bbf6c0531385b6c337c2aad5f85a3d22e8559c8b13b3a89a9f42174cb53fe6e4ae2190740845c9c70002b SHA512 6fd78b26c6c0d7d2f40f1b4eef248eb55d8dc91668b578b2cf88132a364dd7741f6f4d389aeb0c80bdca7cb5dfc1524228113495a2ea3595b888eb27fb8d2dff
-EBUILD readargs-1.2.3.ebuild 841 BLAKE2B f18770ff18c41845aefe9315f7158b20f9e58dd52efae03ddbb7dc67a731db0df13873337a2f861abc2cf8fb0b9d8cabfb61f72e5cf12f27b1c5e7cdb5b75f4f SHA512 39705f5bbce088828b6a0107426b89eed0cc7295c8a76c6ec72a7b16ec9b194d78eaeb48d826f8ef4167af24c214bde3ccda00066accd8adf61bbdf0a32397ad
-MISC metadata.xml 2276 BLAKE2B 42338e2e9e82f4ba8bbad27cef4df3e82209f25a6c4920876488dbf639d8bc38529882f535002af68e9eb730f0f3690f9aea65ffa398c220d7b06e0be6a5b141 SHA512 e526f89478642eb5ffd0db74a835444a1873b37a68b7ca5a5f5ebee6b365d9c13fe4dd17e40533b4cc628ef5471aa60f2c5f59031bc9a3ec6b3e367641d3d5a2
diff --git a/dev-haskell/readargs/metadata.xml b/dev-haskell/readargs/metadata.xml
deleted file mode 100644
index b48729aeab8d..000000000000
--- a/dev-haskell/readargs/metadata.xml
+++ /dev/null
@@ -1,74 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- ReadArgs provides the @readArgs@ IO action, which lets you tell the compiler
- to parse the command line arguments to fit the type signature you give.
-
- For example @(a :: Int, b :: String, c :: Float) &lt;- readArgs@ would
- parse the first runtime argument as an @Int@, the second as a @String@ (no
- quotes required) and the third as a @Float@.
-
- If the runtime arguments are incompatible with the type signature,
- then a simple usage statement is given of the types needed.
-
- Continuing the previous example, if it was used in a
- program named @Example@, the error message for the above
- action would be:
-
- @
- usage: Example Int String Float
- @
-
- Any type that has both @Typeable@ and @Read@ instances
- can be used. @Char@, @String@, and @Text@ are handled specially so that
- command line arguments for both do not require quotes (as their
- @Read@ instances do). A special instance is provided for @FilePath@ so
- that no constructor or quotes are required.
-
- @readArgs@ also supports optional arguments and variadic arguments.
- Optional arguments are specified using @Maybe@, and variadic arguments
- using a list. @(a :: Int, b :: Maybe String, c :: [Float]) &lt;- readArgs@
- would successfully parse any of the following sets of command line arguments:
-
- @
- Example 1
- Example 1 2 3 4
- Example 1 foo
- Example 1 foo 2 3 4
- @
-
- But not
-
- @
- Example
- Example foo
- Example 1.0
- @
-
- Usage statements for optional and variadic arguments use command-line
- parlance:
-
- @
- usage: Example Int [String] [Float..]
- @
-
- Note that both optional and variadic parsers are greedy by default
- (so @Example 1 2 3 4@ was parsed as @(1, "2", [3.0,4.0])@. They
- may both be made non-greedy through use of the @NonGreedy@ constructor:
-
- @
- ( a :: Int
- , NonGreedy b :: NonGreedy Maybe String
- , NonGreedy c :: NonGreedy [] Float
- ) &lt;- readArgs
- @
- </longdescription>
- <upstream>
- <remote-id type="github">rampion/ReadArgs</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-haskell/readargs/readargs-1.2.3.ebuild b/dev-haskell/readargs/readargs-1.2.3.ebuild
deleted file mode 100644
index 11eac0f1647a..000000000000
--- a/dev-haskell/readargs/readargs-1.2.3.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# ebuild generated by hackport 0.5.1.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-MY_PN="ReadArgs"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple command line argument parsing"
-HOMEPAGE="https://github.com/rampion/ReadArgs"
-SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/system-filepath-0.4.7:=[profile?] <dev-haskell/system-filepath-0.5:=[profile?]
- >=dev-haskell/text-0.11.1.13:=[profile?] <dev-haskell/text-12:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? ( >=dev-haskell/hspec-1.3 <dev-haskell/hspec-3 )
-"
-
-S="${WORKDIR}/${MY_P}"