summaryrefslogtreecommitdiff
path: root/dev-haskell/quickcheck/quickcheck-2.14.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/quickcheck/quickcheck-2.14.3.ebuild
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/quickcheck/quickcheck-2.14.3.ebuild')
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.14.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/quickcheck/quickcheck-2.14.3.ebuild b/dev-haskell/quickcheck/quickcheck-2.14.3.ebuild
new file mode 100644
index 000000000000..bcfff140bd41
--- /dev/null
+++ b/dev-haskell/quickcheck/quickcheck-2.14.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: +base4,-base3,-old-random,templatehaskell:template-haskell
+
+CABAL_PN="QuickCheck"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Automatic testing of Haskell programs"
+HOMEPAGE="https://github.com/nick8325/quickcheck"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux"
+IUSE="+template-haskell"
+
+RDEPEND=">=dev-haskell/random-1.2.0:=[profile?] <dev-haskell/random-1.3:=[profile?]
+ >=dev-haskell/splitmix-0.1:=[profile?] <dev-haskell/splitmix-0.2:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-base3 \
+ --flag=base4 \
+ --flag=-old-random \
+ $(cabal_flag template-haskell templatehaskell)
+}