summaryrefslogtreecommitdiff
path: root/dev-haskell/pretty-hex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/pretty-hex
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/pretty-hex')
-rw-r--r--dev-haskell/pretty-hex/Manifest4
-rw-r--r--dev-haskell/pretty-hex/metadata.xml4
-rw-r--r--dev-haskell/pretty-hex/pretty-hex-1.1.ebuild24
3 files changed, 27 insertions, 5 deletions
diff --git a/dev-haskell/pretty-hex/Manifest b/dev-haskell/pretty-hex/Manifest
index f1dad39ea333..b1db21ea4af9 100644
--- a/dev-haskell/pretty-hex/Manifest
+++ b/dev-haskell/pretty-hex/Manifest
@@ -1,3 +1,5 @@
DIST pretty-hex-1.0.tar.gz 2950 BLAKE2B 7fd2049eb42e4e596a54207820d66874620554e72d8f3dae48f5f42b7be089e2b9fe9c9e318a5b13fa4448630a54a7aab3eff593882e6e8df1ed2466a502f35e SHA512 a5ffdecf56b586a23b1243bcace040c7043cc67ced07c5f94d459a2e6a00cade98c70e1480be763ef75946d2aedf87e00d2b653a6f8f23d21cd8e9ab198ea45d
+DIST pretty-hex-1.1.tar.gz 3305 BLAKE2B 833b6056cd8b3ecf0601757cb5b51284e80af613afb81b50a6329fb690d0b8d7d67a263d96ab67794e5bbb17b8dac5b36e39e08e0f1a2b47038f216033f94e66 SHA512 e61223ea492d179e21dd0b26626e6dd32cc24e9e895e27ecedcdc20f70e7ca1db8ef69754a4273a4776d0574570c1d85de6e240f9d3ca0af003bd45416df7c3c
EBUILD pretty-hex-1.0.ebuild 566 BLAKE2B 4aa7d5ff86ef9b8f0256e60b8050501627a080dd325f8bc6dc3643213834d52680f50d5d7ede85167fc806c981d5d718cc90e4fe406cd0a4c449f9e2b8cfc3b1 SHA512 96627f6894182c05342d5a73e6ab7fe8eb53e20a4e9928fdd4d907c8778abfce79bfad6852425ccfdfbab523d28bfa88b5a74ba35a8a36144f50ace512069802
-MISC metadata.xml 398 BLAKE2B e7ea1c0493b5d40631edf9cef501019395707bf5367c5fb9672768a0140f28031b8aab7895feb68a76072d9288704f69261ead5668dc65f61eb3e1001b9b0e77 SHA512 2936f8b042377073c144e30421eb0a7fc0f6538e58e7f04fcb73be2946cc1e242f1fc9d4fef4599c5d013bf126cac605a4462d30b6405acf33d67be8da129da0
+EBUILD pretty-hex-1.1.ebuild 564 BLAKE2B e13c548f0c90e1c1e42e28174c724090b76de81c3a500560065c043799b61d3a702fb36dc047048911e1b5ae7daab91571acca05b3bcb05635b4a83bccfc5611 SHA512 657eabfa1e71a7400f500e464aeb9b6afa549dd2223a75006c49e228d56ef38f16f629ca7b7ac0078c57c310b2308118e5b115a923f8d8940672e49628fcd78f
+MISC metadata.xml 250 BLAKE2B 3adf9597d5114c480b4cc9fb5c3e231d8475b795cd6dce77986e13583ab6e59b43857cf2328570490abef0062a8b8a6b73d231867f9b62124855515cdc044d6d SHA512 5ef2c1d34a3438b39a38c041d45bb06bd0f1ae8a3f8b971bd5aaf36dee560f380e9abefab0c2a4cd7b518e151f5c6a0d0c7cd53caee9a384818f1bdc7deeadc4
diff --git a/dev-haskell/pretty-hex/metadata.xml b/dev-haskell/pretty-hex/metadata.xml
index 6c7bc22ecf52..937381521944 100644
--- a/dev-haskell/pretty-hex/metadata.xml
+++ b/dev-haskell/pretty-hex/metadata.xml
@@ -5,8 +5,4 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This library generates pretty hex dumps of ByteStrings in the
- style of other common *nix hex dump tools.
- </longdescription>
</pkgmetadata>
diff --git a/dev-haskell/pretty-hex/pretty-hex-1.1.ebuild b/dev-haskell/pretty-hex/pretty-hex-1.1.ebuild
new file mode 100644
index 000000000000..ef4d96251f2e
--- /dev/null
+++ b/dev-haskell/pretty-hex/pretty-hex-1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.6.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A library for hex dumps of ByteStrings"
+HOMEPAGE="https://hackage.haskell.org/package/pretty-hex"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"