summaryrefslogtreecommitdiff
path: root/dev-haskell/persistent-postgresql/persistent-postgresql-2.10.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-haskell/persistent-postgresql/persistent-postgresql-2.10.1.2.ebuild
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-haskell/persistent-postgresql/persistent-postgresql-2.10.1.2.ebuild')
-rw-r--r--dev-haskell/persistent-postgresql/persistent-postgresql-2.10.1.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/persistent-postgresql/persistent-postgresql-2.10.1.2.ebuild b/dev-haskell/persistent-postgresql/persistent-postgresql-2.10.1.2.ebuild
new file mode 100644
index 000000000000..f663f52a22d9
--- /dev/null
+++ b/dev-haskell/persistent-postgresql/persistent-postgresql-2.10.1.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Backend for the persistent library using postgresql"
+HOMEPAGE="http://www.yesodweb.com/book/persistent"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # tests require postgresql
+
+RDEPEND=">=dev-haskell/aeson-1.0:=[profile?]
+ dev-haskell/blaze-builder:=[profile?]
+ >=dev-haskell/conduit-1.2.12:=[profile?]
+ >=dev-haskell/monad-logger-0.3.25:=[profile?]
+ >=dev-haskell/persistent-2.10:=[profile?] <dev-haskell/persistent-3:=[profile?]
+ >=dev-haskell/postgresql-libpq-0.9.4.2:=[profile?] <dev-haskell/postgresql-libpq-0.10:=[profile?]
+ >=dev-haskell/postgresql-simple-0.6.1:=[profile?] <dev-haskell/postgresql-simple-0.7:=[profile?]
+ dev-haskell/resource-pool:=[profile?]
+ >=dev-haskell/resourcet-1.1.9:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?]
+ dev-haskell/unliftio-core:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+ test? ( dev-haskell/fast-logger
+ >=dev-haskell/hspec-2.4
+ dev-haskell/hspec-expectations
+ dev-haskell/hunit
+ dev-haskell/persistent-qq
+ dev-haskell/persistent-template
+ dev-haskell/persistent-test
+ dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances
+ dev-haskell/unordered-containers
+ dev-haskell/vector )
+"