summaryrefslogtreecommitdiff
path: root/dev-haskell/parsers/parsers-0.12.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/parsers/parsers-0.12.10.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/parsers/parsers-0.12.10.ebuild')
-rw-r--r--dev-haskell/parsers/parsers-0.12.10.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/parsers/parsers-0.12.10.ebuild b/dev-haskell/parsers/parsers-0.12.10.ebuild
new file mode 100644
index 000000000000..a262cb26304a
--- /dev/null
+++ b/dev-haskell/parsers/parsers-0.12.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Parsing combinators"
+HOMEPAGE="https://github.com/ekmett/parsers/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+attoparsec +parsec"
+
+RDEPEND=">=dev-haskell/base-orphans-0.3:=[profile?] <dev-haskell/base-orphans-1:=[profile?]
+ >=dev-haskell/charset-0.3:=[profile?] <dev-haskell/charset-1:=[profile?]
+ >=dev-haskell/mtl-2.0.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/semigroups-0.12:=[profile?] <dev-haskell/semigroups-1:=[profile?]
+ >=dev-haskell/text-0.10:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ attoparsec? ( >=dev-haskell/attoparsec-0.12.1.4:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?] )
+ parsec? ( >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag attoparsec attoparsec) \
+ $(cabal_flag parsec parsec)
+}