summaryrefslogtreecommitdiff
path: root/dev-haskell/pandoc-lua-marshal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
commitfd70f5e3ed54d5e013c11a3f3e632e80838171d0 (patch)
treec6bf0dac8239e644ccc09b184e4eb9cca9701dcf /dev-haskell/pandoc-lua-marshal
parent5deadca7219297a3c1f90eca00544a00e33efdbc (diff)
gentoo auto-resync : 23:07:2022 - 02:48:51
Diffstat (limited to 'dev-haskell/pandoc-lua-marshal')
-rw-r--r--dev-haskell/pandoc-lua-marshal/Manifest3
-rw-r--r--dev-haskell/pandoc-lua-marshal/metadata.xml8
-rw-r--r--dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.1.6.ebuild33
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-haskell/pandoc-lua-marshal/Manifest b/dev-haskell/pandoc-lua-marshal/Manifest
new file mode 100644
index 000000000000..340b2fddc80d
--- /dev/null
+++ b/dev-haskell/pandoc-lua-marshal/Manifest
@@ -0,0 +1,3 @@
+DIST pandoc-lua-marshal-0.1.6.tar.gz 41737 BLAKE2B 878f28c9f20b752f09c9c94215a90d7d2e43f32f598f95272aac0e1847d90cbe03df1a52cc93c025f24b8c439e633599d5b0d0b4c9f224f21c505b2a82cd8290 SHA512 be425707b82da8d82d544da5c67f58537ddaa7eabf2508ab4e7bd4c0cff05b394a784bea744e6f702047ee733e259369eef43de615436607b38ceb8bda89417d
+EBUILD pandoc-lua-marshal-0.1.6.ebuild 1174 BLAKE2B aac71c879b608cef7ffe02ec005e705817750822e2f469aa0f0156005350a44c02e2cb4e55560ab8654f71616ac7570b3794df4317432988236dc3c545f2be03 SHA512 3e70d9fc5190c0207547c1034611c66aa846d53438362f11bc59b22bf19aca5cede2ace0e15e1c2752be1885454af83287a92694a48faaa9cc550dc30989e1d1
+MISC metadata.xml 249 BLAKE2B 84b809c265ff2a09d1f06c66d4797652ff4c64205d94323e07333ae0fbddcfb8c58d0176a8cc52bd37e9353371d987b9b473b9747cb082e1c2871ed80fcfa144 SHA512 ce055b41ff1c10209e88579fe21ce16550be7e9b21f87724564f06430aa6f478974f186a10c8ff7e92398f534c09109aeed57eae1c6d2b56b5c99ebfb64a0015
diff --git a/dev-haskell/pandoc-lua-marshal/metadata.xml b/dev-haskell/pandoc-lua-marshal/metadata.xml
new file mode 100644
index 000000000000..b7878815d80d
--- /dev/null
+++ b/dev-haskell/pandoc-lua-marshal/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.1.6.ebuild b/dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.1.6.ebuild
new file mode 100644
index 000000000000..eb6badb0b986
--- /dev/null
+++ b/dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.1.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Use pandoc types in Lua"
+HOMEPAGE="https://github.com/pandoc/pandoc-lua-marshal"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/hslua-2.1:=[profile?] <dev-haskell/hslua-2.3:=[profile?]
+ >=dev-haskell/hslua-marshalling-2.1:=[profile?] <dev-haskell/hslua-marshalling-2.3:=[profile?]
+ >=dev-haskell/lua-2.1:=[profile?] <dev-haskell/lua-2.3:=[profile?]
+ >=dev-haskell/pandoc-types-1.22.1:=[profile?] <dev-haskell/pandoc-types-1.23:=[profile?]
+ >=dev-haskell/safe-0.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? ( >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/tasty-lua-1.0
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.11 )
+"