summaryrefslogtreecommitdiff
path: root/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild')
-rw-r--r--dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild
new file mode 100644
index 000000000000..ccaee0e55d7e
--- /dev/null
+++ b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Supports using pandoc with citeproc"
+HOMEPAGE="http://hackage.haskell.org/package/pandoc-citeproc"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bibutils embed_data_files +hexpat +network +small_base unicode_collation"
+RESTRICT=test # missing files: locales-en-US.xml: openBinaryFile
+
+RDEPEND=">=app-text/pandoc-1.12.0.2:=[profile?]
+ dev-haskell/aeson:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/json:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pandoc-types-1.12.3:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/split:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/tagsoup:=[profile?]
+ >=dev-haskell/texmath-0.6.4:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-haskell/yaml-0.8:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
+ hexpat? ( >=dev-haskell/hexpat-0.20.2:=[profile?] )
+ !hexpat? ( dev-haskell/xml:=[profile?] )
+ network? ( >=dev-haskell/http-4000.0.9:=[profile?]
+ >=dev-haskell/network-2:=[profile?] )
+ unicode_collation? ( dev-haskell/text-icu:=[profile?] )
+ !unicode_collation? ( dev-haskell/rfc5051:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.12
+ test? ( dev-haskell/aeson-pretty
+ >=dev-haskell/diff-0.3 )
+"
+
+src_configure() {
+ # workaround bug on ghc-7.6.3:
+ # > [13 of 24] Compiling Text.CSL.Input.Bibtex ...
+ # > stack overflow: use +RTS -K<size> to increase it
+ replace-hcflags -O[2-9] -O1
+
+ haskell-cabal_src_configure \
+ $(cabal_flag bibutils bibutils) \
+ $(cabal_flag embed_data_files embed_data_files) \
+ $(cabal_flag hexpat hexpat) \
+ $(cabal_flag network network) \
+ $(cabal_flag small_base small_base) \
+ $(cabal_flag unicode_collation unicode_collation)
+}