summaryrefslogtreecommitdiff
path: root/dev-haskell/openal/openal-1.7.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/openal/openal-1.7.0.4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/openal/openal-1.7.0.4.ebuild')
-rw-r--r--dev-haskell/openal/openal-1.7.0.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/openal/openal-1.7.0.4.ebuild b/dev-haskell/openal/openal-1.7.0.4.ebuild
new file mode 100644
index 000000000000..70ad746eecf2
--- /dev/null
+++ b/dev-haskell/openal/openal-1.7.0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.7.9999
+#hackport: flags: -usenativewindowslibraries,buildexamples:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="OpenAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A binding to the OpenAL cross-platform 3D audio API"
+HOMEPAGE="https://github.com/haskell-openal/ALUT"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-haskell/objectname-1.1:=[profile?] <dev-haskell/objectname-1.2:=[profile?]
+ >=dev-haskell/opengl-2.12:=[profile?] <dev-haskell/opengl-3.1:=[profile?]
+ >=dev-haskell/statevar-1.1:=[profile?] <dev-haskell/statevar-1.2:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.6:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ media-libs/openal
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples buildexamples) \
+ --flag=-usenativewindowslibraries
+}