summaryrefslogtreecommitdiff
path: root/dev-haskell/only
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/only
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/only')
-rw-r--r--dev-haskell/only/Manifest3
-rw-r--r--dev-haskell/only/metadata.xml19
-rw-r--r--dev-haskell/only/only-0.1.ebuild29
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-haskell/only/Manifest b/dev-haskell/only/Manifest
new file mode 100644
index 000000000000..a73c95cc0cb3
--- /dev/null
+++ b/dev-haskell/only/Manifest
@@ -0,0 +1,3 @@
+DIST Only-0.1.tar.gz 1960 BLAKE2B b57f48e58287c43395383e355ba9b2d42df4c8b65edbc268e7203853083524dc88540d63a052968b9776dc94064006241188b23e840e1e36872389f9e463d1ff SHA512 6b64178a433079449b6840b03345e70f2c5c03e322184a60d3ff2f4d0ae48be87042ff32dc1cabe1911b6c43f7162090ee067aa582c6d5ab56610ca4897a33de
+EBUILD only-0.1.ebuild 618 BLAKE2B d849e119cfb5edbc9a68e325b5b5d230dc61404d7e812b7345939c36dbb1303110ea6ef15ab90f568eeb41ecaf586960bb1ae2427392a3538c4b9c2da69c3564 SHA512 2591f2256f47584c93ebb60036f1be1b71ee5c182d2b621dec516d9aa4bb1803a192d0ba643ef8c2238b59c19c2ccb741ed15f660d1f0e54656c62fa0812de87
+MISC metadata.xml 779 BLAKE2B 2f1b17b0133b6eb1b3ef8a97b938640ef6cfd7971940acf2b168a338d71a6c61066e8271ec06bafe51ef399989f5ad328053c1b090a2382dbc4bfa26f2d12c09 SHA512 6f58cde68e293f6b336bb54c02dd1d04d6e1e7e76ca13010b98495a08bb9a153cc4841a80ba7677ce108ed4f5f7447bcfd9289d89fb4c20b47c862156e74bea1
diff --git a/dev-haskell/only/metadata.xml b/dev-haskell/only/metadata.xml
new file mode 100644
index 000000000000..180274c79810
--- /dev/null
+++ b/dev-haskell/only/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package provides a canonical anonymous 1-tuple type missing
+ from Haskell for attaching typeclass instances.
+
+ NOTE: There is also the &lt;/package/OneTuple OneTuple package&gt; which
+ by using a boxed @data@-type provides a 1-tuple type which has
+ laziness properties which are more faithful to the ones of Haskell&#39;s
+ native tuples; whereas the primary purpose of &#39;Only&#39; is to
+ provide the traditionally so named type-wrapper for attaching typeclass
+ instances.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/only/only-0.1.ebuild b/dev-haskell/only/only-0.1.ebuild
new file mode 100644
index 000000000000..a6ad69db5abe
--- /dev/null
+++ b/dev-haskell/only/only-0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.5.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="Only"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The 1-tuple type or single-value \"collection\""
+HOMEPAGE="https://hackage.haskell.org/package/Only"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+S="${WORKDIR}/${MY_P}"