summaryrefslogtreecommitdiff
path: root/dev-haskell/nothunks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/nothunks
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/nothunks')
-rw-r--r--dev-haskell/nothunks/Manifest3
-rw-r--r--dev-haskell/nothunks/metadata.xml17
-rw-r--r--dev-haskell/nothunks/nothunks-0.1.4-r1.ebuild51
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-haskell/nothunks/Manifest b/dev-haskell/nothunks/Manifest
new file mode 100644
index 000000000000..5c17d20b7ee6
--- /dev/null
+++ b/dev-haskell/nothunks/Manifest
@@ -0,0 +1,3 @@
+DIST nothunks-0.1.4.tar.gz 18501 BLAKE2B 5f5bda104990dbecf7e313134d1d723f5ecb0dfb9b3abdb0ab68774f55e416b954720de7ccc449047f795cb03464c15cbf37dd4e20bdac71d0188f8fb76dc70e SHA512 6decd4bcc6c72c09c87692e772affeb4bb22d6312974bfb184567e399844d437bd4c68814f2f208d82a012498090a780958d138a946e907258e9a5d221a697c4
+EBUILD nothunks-0.1.4-r1.ebuild 1229 BLAKE2B 36bf9f95d2b3659e6403a80d9121c3fa71304dfcdf4db6a8f7c051f1052a2d0f8ae3b3e1543cb68786a472af76c429a47dc8c5e69c3c76d88066ff4e8547077d SHA512 d0b951e56ef3d0e442a211f28be771ffcd77566bb577ed4a9cfc4da8a7fa47488da323716a5515391a4434fb9b8bb3417c34a6ddc54328e4ae335646df0bcdda
+MISC metadata.xml 581 BLAKE2B 5bd6265fea03ed5728dfd248127747094188013cde99b3b3e5ffb51d4779fc76282f7fd6ab33e8764e83c88417b1fa8a33c65791b4ba5b9f8723b15deee3e51f SHA512 fcced4c6273150bfb2b666b539cf0562ae6489c631c8b7813e1ef20088d25abc2f74551440921390357eb69297d67f86a272141af8ceb38a6362aab0802db696
diff --git a/dev-haskell/nothunks/metadata.xml b/dev-haskell/nothunks/metadata.xml
new file mode 100644
index 000000000000..de0c1b2d1b19
--- /dev/null
+++ b/dev-haskell/nothunks/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="bytestring">Provide instances for bytestring</flag>
+ <flag name="text">Provide instances for text</flag>
+ <flag name="vector">Provide instances for vector</flag>
+ </use>
+ <upstream>
+ <remote-id type="hackage">nothunks</remote-id>
+ <remote-id type="github">input-output-hk/nothunks</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/nothunks/nothunks-0.1.4-r1.ebuild b/dev-haskell/nothunks/nothunks-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..f70ecce1a7c2
--- /dev/null
+++ b/dev-haskell/nothunks/nothunks-0.1.4-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Examine values for unexpected thunks"
+HOMEPAGE="https://hackage.haskell.org/package/nothunks"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+bytestring +text +vector"
+
+CABAL_CHDEPS=(
+ 'hedgehog >= 1.1 && < 1.3' 'hedgehog >= 1.1'
+)
+
+RDEPEND="
+ >=dev-lang/ghc-8.10.6:=
+ text? (
+ || (
+ ( >=dev-haskell/text-1.2 <dev-haskell/text-1.3 )
+ ( >=dev-haskell/text-2 <dev-haskell/text-2.1 )
+ )
+ dev-haskell/text:=[profile?]
+ )
+ vector? (
+ >=dev-haskell/vector-0.12:=[profile?] <dev-haskell/vector-0.14:=[profile?]
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ >=dev-haskell/hedgehog-1.1
+ >=dev-haskell/random-1.1 <dev-haskell/random-1.3
+ >=dev-haskell/tasty-1.3 <dev-haskell/tasty-1.5
+ >=dev-haskell/tasty-hedgehog-1.1 <dev-haskell/tasty-hedgehog-1.5
+ )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag bytestring bytestring) \
+ $(cabal_flag text text) \
+ $(cabal_flag vector vector)
+}