summaryrefslogtreecommitdiff
path: root/dev-haskell/network-data/network-data-0.5.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/network-data/network-data-0.5.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/network-data/network-data-0.5.3.ebuild')
-rw-r--r--dev-haskell/network-data/network-data-0.5.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/network-data/network-data-0.5.3.ebuild b/dev-haskell/network-data/network-data-0.5.3.ebuild
new file mode 100644
index 000000000000..88fb2d222396
--- /dev/null
+++ b/dev-haskell/network-data/network-data-0.5.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Library for network data structures and their serialization"
+HOMEPAGE="http://hackage.haskell.org/package/network-data"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+small_base"
+
+# dev-haskell/prettyclass is not required for ghc 7.10.1, just adding
+# it for backwards compatibility with <ghc 7.10.1
+
+RDEPEND=">=dev-haskell/cereal-0.2:=[profile?]
+ >=dev-haskell/prettyclass-1.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+"
+
+src_prepare() {
+ if has_version "<dev-lang/ghc-7.10.1"; then
+ cabal_chdeps \
+ 'pretty >= 1.1.2' 'pretty >= 1.0, prettyclass >= 1.0'
+ fi
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag small_base small_base)
+}