summaryrefslogtreecommitdiff
path: root/dev-haskell/nats/nats-1.1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
commitfd70f5e3ed54d5e013c11a3f3e632e80838171d0 (patch)
treec6bf0dac8239e644ccc09b184e4eb9cca9701dcf /dev-haskell/nats/nats-1.1.2-r1.ebuild
parent5deadca7219297a3c1f90eca00544a00e33efdbc (diff)
gentoo auto-resync : 23:07:2022 - 02:48:51
Diffstat (limited to 'dev-haskell/nats/nats-1.1.2-r1.ebuild')
-rw-r--r--dev-haskell/nats/nats-1.1.2-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/nats/nats-1.1.2-r1.ebuild b/dev-haskell/nats/nats-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..7fc284ca23e7
--- /dev/null
+++ b/dev-haskell/nats/nats-1.1.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile"
+# break circular dependencies:
+# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Natural numbers"
+HOMEPAGE="https://github.com/ekmett/nats/"
+SRC_URI="
+ https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/3.cabal -> ${PF}.cabal"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="+binary +hashable +template-haskell"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+ hashable? ( >=dev-haskell/hashable-1.1.2.0:=[profile?] )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag binary binary) \
+ $(cabal_flag hashable hashable) \
+ $(cabal_flag template-haskell template-haskell)
+}